Can't download. Parent is missing

I’m getting the error, “Can’t download [name]. Parent is missing,” for 17 items in my Google Drive folder. This began after installing the 1.2 beta previously and then reverting back to the stable version. I just downloaded 1.2 final hoping this might resolve the issue, but it didn’t.

Some of the errors are on symlinked files but most are not. All of the files/folders giving errors are named in the errors like u'[name]' indicating they are unicode strings. Not sure if that could be part of the problem, or if that’s just an issue with how the folder names are being displayed in the errors.

Same here for 248 files. I’ve had it since 1.2 update and have not allowed my other computer to update until I can figure out why this is happening. I forced the update to 1.2.3 today and that didn’t help. Looking for any ideas on how to resolve this.

Idem for me.
I have two accounts. It’s OK for one of them but all my folders of the other accounts are not synced.
HELP !!! How can I get the old Insync version which was OK ?

This is a known issue and we are working on a fix.

Thanks :slight_smile:

I am running Arch Linux and have installed the latest version of insync and also get this parent missing response. I’ll hang in there until a fix is produced.

Why is it taking so long to fix? This program is a scam.

@raddevon, @jtreadwell, @Robert_J_Scally: Our investigation so far has revealed that upgrading to the 1.2 caused Insync database corruption for some of the users due to which they have encountered this issue. Could you send across your Insync logs too so that we could confirm? Here is how to find the logs: How to find the log files

If it turns out to be the case for you as well, you will have to resync from scratch as the fix would not be feasible.

We are working on adding additional safeguards to keep it from happening in future.

Apologies for the inconvenience

I have the logs, but I’m not sure where to send them. The forum doesn’t seem to accept anything except images.

@raddevon Send to Thanks.


Is this issue fixed. I have the same message. My installation on Ubuntu was working but stopped suddenly, no changes except maybe updating maintenance packages and security fixes. I’ve installed the latest version of insync but the issue seem to persist.

And where can I find the log on Linux?
Thank you

Hi I have 86 files that cannot sync as parent is missing
What do I do to resolve this?

I have been using this successfully on my mac to sync with macbook and shared google drive, it then stopped working on iMac, I have tried to download new version but it would not sync now having gone back to old version seems to sync some but not all

@Angela_Coleman Can you send in your logs to so we can take a closer look?

Having similar issues but I cannot tell what version this app is running. Sending log file to support email and will monitor this post or updates.

Additional notes: I can click on the error files listed and they open in Google Drive. Able to download from the Google sheet/doc but when clicking the Insync retry button, it returns same error.

More than 227 days later I cannot se any resolution on this issue and I also have it now, also Isync have stopped synchronizing if that may be related to this.

I am getting the same issue showing parent folder missing. Still no solution? What a shame.


i am also getting this error message, what is the fix for this ?

Dirty fix that worked for me: uninstall the program, delete all the files related to the program, reinstall the program. It will re-prompt account/location settings and start a flesh sync. Worth trying.

Hi all I am also getting this error. Is there any solution for this problem?

Hi! What’s your OS and Insync version at the moment?

$ lsb_release -a
No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 18.04 LTS
Release:	18.04
Codename:	bionic

$ insync --version