Can't Start Headless manage_selective_sync


I installed insync-headless on my server and wanted to sync selectively, but I couldn’t start the manage selective sync interface due to this error:

Traceback (most recent call last):
  File "<string>", line 6, in <module>
  File "", line 128, in <module>
  File "", line 134, in <module>
  File "npyscreen/", line 30, in run
  File "npyscreen/", line 41, in wrapper
  File "npyscreen/", line 82, in wrapper_no_fork
  File "", line 539, in setlocale
locale.Error: unsupported locale setting

Do you have any solution about this?
I have several files using Japanese characters but I installed the ja_JP locale already.

And another problem is that when I tried unsyncing files using the set_selective_sync command, it says no on the get_root_drive_files but insync keeps downloading the folders (which is sooooo many in my case). Any help?

@araishikeiwai For the locale error, please try listing the available locales with locale -a. If you have one with utf8, for example en_US.utf8, please try running Insync with

LC_ALL=en_US.utf8 insync-headless manage_selective_sync ...

For the second issue, we are currently investigating that.

I am having the same error.
Is there a solution?

OK, this works:

LC_ALL=en_US.utf8 insync-headless selective-sync

Make sure it’s not selective_sync, but selective-sync.

1 Like

@Danijel Hi!

My apologies we weren’t here sooner to jump in. I appreciate you sharing the solution you found. We are grateful for users like you!!