Debian Buster insync installation doesnt work

I am using insync since years and this on all of my Linux and Windows systems.
After a new installation of my system, I run Debian Buster (Kernel 4.18.0-3-amd64) and added the insync repository.

After running
“sudo apt install insync” I cant start insync like before my new system installation.

Every try of using any command on my terminal gives me the same output:

insync quit
Traceback (most recent call last):
File “isyncd/linux/headless/”, line 108, in ipc_insync
File “”, line 228, in meth
error: [Errno 111] Connection refused

I read some other topics with the same or similar problems but nothing helps.

Any idea what I can do?

Thanks in advance

Exact same problem here :

insync show
Traceback (most recent call last):
File “isyncd/linux/headless/”, line 108, in ipc_insync
File “”, line 228, in meth
error: [Errno 111] Connection refused

also :

insync start --no-daemon
Warning: Ignoring XDG_SESSION_TYPE=wayland on Gnome. Use QT_QPA_PLATFORM=wayland to run on Wayland anyway.
INFO 2019-02-22 18:37:56,513 [main__insync:main:105] insync version:
INFO 2019-02-22 18:37:56,514 [main__insync:main:106] client created <ideskmain.client.Client object at 0x7fc758136550>
INFO 2019-02-22 18:37:56,514 [unix_socket_server_portable:start:49] unix socket server thread start
INFO 2019-02-22 18:37:56,515 [main__insync:main:114] starting client
INFO 2019-02-22 18:37:56,519 [fswatch:_start:532] LinuxFSWatcher._start
INFO 2019-02-22 18:37:56,520 [fswatch:_pull_loop:267] Inotify loop enter
Received signal 11 SEGV_MAPERR 000000000108
#0 0x7fc75ada3c1f
#1 0x7fc7597cca9d
#2 0x7fc75ada412e
#3 0x7fc7834e86e0
#4 0x7fc776770db4
#5 0x7fc776772058
#6 0x7fc78142add4 glXCreatePbuffer
#7 0x7fc75982fc89
#8 0x7fc75981aa08
#9 0x7fc75b8e945d
#10 0x7fc759b24f11
#11 0x7fc759b26705
#12 0x7fc75bd9f857
#13 0x7fc75d5b9795
#14 0x7fc75ae0c5d5
#15 0x7fc75ae07970
#16 0x7fc7834ddfa3 start_thread
#17 0x7fc78306380f clone
r8: 0000000000000000 r9: 0000000000000001 r10: 0000000000000004 r11: 0000000000000206
r12: 0000562d48ab9cc0 r13: 0000562d48c562e0 r14: 0000562d48af97c0 r15: 0000000000000005
di: 0000562d48ab9cc0 si: 0000000000000000 bp: 0000562d48ab9cc0 bx: 0000000000000000
dx: 0000000000008041 ax: ffffffffffffff50 cx: 0000000000000000 sp: 00007fc6df7fd480
ip: 00007fc776770db4 efl: 0000000000010202 cgf: 002b000000000033 erf: 0000000000000004
trp: 000000000000000e msk: 0000000000000000 cr2: 0000000000000108
[end of stack trace]
Calling _exit(1). Core file will not be generated.

Debian Buster is supposed to be released in less than 3 weeks.

Thank you for reaching out, @Batsatac!

Tagging our engineer @Kurt_Ko for further assistance. :slight_smile:

I have the same problem.
Debian testing (Buster), Insync installed for a few years now. It stopped working a few weeks ago.

I’ve been having same problem on Buster.

My previous workaround was to simply uninstall and re-install every reboot(!) But thanks to @SabrinaTigik over at this thread here a superior workaround is to switch to the ubuntu/artful repo in your apt sources…

That has got me back to work. Will switch back to debian/buster on next release to see if they’ve solved it.

1 Like

Hi…I see the same issue as you: latest Buster image uses .57 kernel while the raspberrypi-kernel-headers package installs headers from .58. Normally these should be in sync unless you’ve installed a custom kernel or have run rpi-update.

I have the exact same problem but on Mac os. Seems to be stuck on some .git files (yes I’m uploading a git repo)