Dolphin overlay icons not working

According to https://www.insynchq.com/downloads, version 3.3.9.40955 added support for Dolphin file manager overlay icons. But in my laptop (KDE Neon 5.21 fully updated) it doesn’t work, i.e. not overlay icons are showed.

When I launch Dolphin from console I get this message:

kf.kio.widgets: The "Insync" plugin still installs the desktop file for plugin loading. Please use JSON metadata instead, see KAbstractFileItemActionPlugin class docs for instructions.

Is this a problem with my current setup or there is something wrong with the Dolphin support?

Hi @chgonzalez,

Let me check this with our engineers and I’ll update you here :slight_smile:

Hi, what the engineers said?

Hi! They are still investigating this, but I will follow it up again for you :slight_smile:

Hi @chgonzalez

Are you viewing a folder that is currently synced by Insync? (ex. ~/Insync/[EMAIL]/Google Drive/[FOLDER OR FILE]) The status overlay icons are only shown for files that are synced or are currently syncing by Insync

Yes, of course. But my Insync folder is in /home/myUserName/Google Drive/myUserName@gmail.com and is stored in a NTFS partition. Is this a problem for Insync?

Still waiting for an answer…

Hi @chgonzalez! Apologies for the delay in our responses and thank you for bumping this thread up. I’ve followed this up with our engineer.

I’ve updated to Insync 3.4.2 but still no overlay icons :frowning:

Any news from the engineers?

Hi @chgonzalez,

I have once again followed up if this has been investigated further and/or lined up for an upcoming release. Thank you for your patience!

Hi! Does right clicking on a file show an Insync menu? Also, are you using a non-default theme? :slight_smile:

Yes, there is an Insync menu with two entries: “View on web” and “Share”.

I’m using the default Breeze theme.

Got it, thank you! Let me forward this to our engineer and I’ll advise accordingly.

Any news from the engineer?

I’ve created another user on my system and Insync is working perfectly there. So I asumed that there was something wrong with my current user configuration.

I’ve removed my .config/Insync and .local/share/Insync folders, renamed my “Google Drive” folder to just “Insync” and lauched the Insync start wizard. The first sync is still in progress but Dolphin overlay icons are already showing up. So I guess that some config was messed up during some update. Even the context menu options are working again.

Thanks for your help.

@chgonzalez I appreciate the updates on both threads! :slight_smile: