Fail to start Insync 1.4.5.37069-xenial client on Linux Mint Sonya (XFCE)


#1

Hi guys!

Since the last update, insync client stops working. When I start on the shell, out.txt shows this message.

** (insync:20688): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-Xtx9bG8bOw: Connection refused
Traceback (most recent call last):
  File "<string>", line 6, in <module>
  File "__main__.py", line 128, in <module>
  File "__main__insync__.py", line 116, in <module>
  File "isyncd/linux/headless/cli.py", line 49, in run
  File "__main__insync__.py", line 32, in main
  File "ideskmain/client.py", line 10, in <module>
  File "idesksyncer/gdsyncer.py", line 3, in <module>
  File "idesksyncer/fsstate.py", line 23, in <module>
  File "idesksyncer/gdstate.py", line 8, in <module>
  File "idesksyncer/gdworks.py", line 17, in <module>
ImportError: cannot import name TDSyncTether

#2

Hi @orionx,

Tagging our Linux engineer @jimperio


#3

@jimperio could you please see what is wrong in Insync 1.4.5.37069-xenial client running on Linux Mint Sonya (XFCE)? Please, see the error above.


#4

Is there any solution? I’ve got the same error on Xubuntu 16.04. Using insync 1.4.5.37069-xenial also.


#5

Officially? None. No response.


#6

I updated my Linux Mint to 18.3 and nothing. Something is very wrong on insync dependencies.


#7

I just downgraded to 1.3.24 on my desktop, back to working fine.

Interestingly my XFCE laptop(also xubuntu 16.04) is running the same insync version (1.4.5.37069-xenial) without any issue.


#8

I did the same thing: downgrade to 1.3.2 to work properly.


#9

Hello guys, we’re sorry for not responding sooner. We’ll take a look at this and have a fix out within the week.


#10

Unfortunately, we have yet to replicate this error. We’ve tested so far on Linux Mint 18.2, both the case when upgrading from a 1.3 installation and when installing 1.4.5.37069-xenial.

Could you try (if you haven’t yet) uninstalling Insync (this won’t remove your current data at ~/.config/Insync), then re-installing 1.4.5.37069 (either via our APT repo or by downloading the installer from our downloads page)?

We will keep testing on our end and keep this thread updated.


#11

I reinstalled with the APT version. Still no dice. I have it working on my laptop (also Ubuntu 16.04 XFCE) but not on my desktop. Same error. Are there any new dependencies on the 1.4.5 version?


#12

@homerunnerd There are no new dependencies in 1.4 – it’s mostly changes to the core app code and the UI.

I asked you to re-install to test out the hypothesis that somehow, some old compiled Python files stick around and mess with the new class being imported on 1.4. Right now we are failing to see how the Python code can fail like that on just a specific Linux distribution.

We’ve also since tested on Mint 18.3 and are still unable to replicate the issue.


#13

Interestingly, I did a full system reinstall last night. (Insync is very important to my workflow…haha) and everything is working now. Still unclear what the problem was, but I have 1.4.5 working now.


#14

Glad to know it’s running well on your end! If you encounter any issues in the future, feel free to shoot us an email at support@insynchq.com. :slight_smile:


#15

My InSync instance still with this bug and almost nothing happen to fix it. The support to me is being abysmal. The technician answers my e-mails occasionally.