Fedora 30 and Insync 1.5.7.37371


#21

Negative, I’ve Nvidia (proprietary) driver + Intel (Optimus system) and I have the same issue.


#22

With Insync problem on Fedora 30, I found that Drive integration in Gnome 3.32 it’s a lot faster than before, almost no lag after first sync. In the meantime we get a fix, you could give it a try to work with Drive in Nautilus.


#23

That is true, but gnome 3.32 google drive integration relies on a networked file system, I suppose. So, if you have a slow network connection, operations on it are laggy (insync instead makes a mirror copy on local file system). Moreover, some file operations (even a simple saving dialogue window) do not show the drive folder. As you have said, just a workaround.


#25

Yes, as I said, it is a workaround until Insync HQ fix the bug.


#26

Still waiting for a fix. Meanwhile, all my operations with Drive work nicely using headless and no-daemon options. A cute terminal window remains open. :slightly_smiling_face:


#27

Any news? It’s taking a while…


#28

Waiting on fix too.

[danesh@hades yum.repos.d]$ insync start --no-daemon
libGL error: MESA-LOADER: failed to open radeonsi (search paths /usr/lib64/dri)
libGL error: failed to load driver: radeonsi
libGL error: MESA-LOADER: failed to open radeonsi (search paths /usr/lib64/dri)
libGL error: failed to load driver: radeonsi
libGL error: MESA-LOADER: failed to open swrast (search paths /usr/lib64/dri)
libGL error: failed to load driver: swrast
Segmentation fault (core dumped)
[danesh@hades yum.repos.d]$


#29

+1 for those waiting…

Exact same errors/messages as @Danesh_Manoharan

=Steve=


#30

Can confirm it is definitely something related to the GUI part. I have several Fedora systems running, and I have one laptop that the insync client is working on. The laptop uses an onboard Intel GPU, whereas my other Fedora systems are desktops with either NVIDIA or AMD GPUs running, where the GUI client fails with the same error messages as reported above.


#31

Perhaps insync guys are relying on v3 release.


#32

+1 waiting for a fix. (14+ days now)


#33

Well, there is not even a download available for Fedora 30, and the yum repo given in the Download packages menu doesn’t support 30 (after quite a few weeks, now). This is a shame for a paid service. I’m disappointed.


#34

Well, yes, that’s true. I’m getting used to launch Insync using console with headless and no-daemon options but that’s not correct. I’d like a couple of messages from the staff telling us that at least they are still working on a fix or a new version, perhaps a timetable or a tentative ETA.


#35

Plus the integration with nautilus is broken for the rpm download:

~:: nautilus
File “/usr/share/nautilus-python/extensions/insync_plugin.py”, line 138
print path
^
SyntaxError: Missing parentheses in call to ‘print’. Did you mean print(path)?

Apparently Nautilus is expecting python 3 now.

If Insync won’t properly support Fedora users they should make it clear BEFORE purchase.


#36

https://fedoraproject.org/wiki/Changes/NautilusExtensionsPython3

The Python backend for the nautilus-python extension will be updated from python2 to python3 . All Nautilus extensions written in Python will need to be checked for Python 3 compatibility and updated if necessary. Extensions compatible only with Python 2 will no longer be supported.


#37

Hi everyone,

Sorry for being MIA from here. But I’m here to let you guys know that our engineers are working on releasing a build for Fedora 30.

I’m really sorry it’s taking waaay longer that our usual release cadence, but please be assured that we really are working on this.


#38

Can you please expedite this solution? It has now been 41 days since it was reported, and many of us have badly out-of-sync files. It’s been a great product, but it’s pretty frustrating that I paid for it, but it does not work for 41 days and counting.


#39

Hi everyone,

I’m running InSync 1.5.7.37371 with Fedora 30 on Lenovo E540 with no problem at all… except non-functional repository. And also on an old desktop where I am not able to even start the service… I hope there will be a solution soon but is there any way I can help other users when I have this Lenovo machine with no problem?

Tom


#40

As mentioned above, as a temporary work around, you can start Insync in headless mode. A quick way to do this automatically is to add it to crontab. You can do this from the command line by entering:

crontab -e

which will open up a file in edit mode

insert the following into the file: @reboot insync-headless start

Then save the file.

This will start Insync automatically every time you reboot.

That said, it’s going on July - is anyone at Insync working to fix this?


#41

Is there any news on this? It’s now been a few weeks since your last post, and it would be nice to know what the rough ETA for a fix is.