Gui not starting; no sync at all

debian_stretch
issue

#45

I too have managed to get an insync-headless session up and running, but I’m getting strange updates as it tries to sync, and a target directory name change doesn’t seem to have been taken well :confused:

It seems to build the file structure on the target drive, but no actual files are syncing. This is the part that seems … less promising?

    :~$ insync-headless start --no-daemon &
    :~$ Qt WebEngine seems to be initialized from a plugin. Please set Qt::AA_ShareOpenGLContext
                  using QCoreApplication::setAttribute before constructing QGuiApplication.
          INFO     2018-12-10 18:31:56,523 [__main__insync__:main:105] insync version: 1.5.5.37368
          INFO     2018-12-10 18:31:56,524 [__main__insync__:main:106] client created
                         <ideskmain.client.Client object at 0x7f8ff0813bd0>
          INFO     2018-12-10 18:31:56,525 [unix_socket_server_portable:start:49] 
                         unix socket server thread start
         INFO     2018-12-10 18:31:56,525 [__main__insync__:main:114] starting client
         INFO     2018-12-10 18:31:56,531 [fswatch:_start:532] LinuxFSWatcher._start
         INFO     2018-12-10 18:31:56,532 [fswatch:_pull_loop:267] Inotify loop enter
         INFO     2018-12-10 18:31:56,543 [gdsyncer:sync_account:153] Syncing GDUser(id=u'*************',
                         email=u'********@gmail.com', name=u'*********').
    INFO     2018-12-10 18:31:56,705 [fsstate:setup:167] There are no existing trees.
    INFO     2018-12-10 18:31:56,842 [client:__on_gd_account_added:891] 
                  GDUser(id=u'100746353429552130553', email=u'*****@gmail.com', name=u'*****') 
                        (existing) is now being synced.
    INFO     2018-12-10 18:31:57,035 [fsworks:__process_main_tree:221] Main syncing location for
                        u'**********' becomes missing.
    INFO     2018-12-10 18:32:56,865 [_updater:_run:129] No updater available.

#46

… one more update: after a restart the files seem to be syncing, so I assume the “no updater available” is of no consequence? Getting a lot of sum_mismatch warnings, but so far no halting errors.

manage_selective_sync still fails (python run failures and a curses/terminal error), and I wish I had some sort of GUI, but this is progress! :smiley:


#47

Hello,

I don’t want to create yet another SEGV_MAPPER thread so I associate myself to this one.

I tried all listed proposals and more, including : purging/reinstalling InSync, purging all lib-gl-u-1-mesa-dri-whatever packages, starting with the no-daemon mode, installing insync-beta instead of insync, starting with the LD_LIBRARY_PATH variable, and getting the same :

Cannot load library /usr/lib/insync/platformthemes/libqgtk3.so: (/usr/lib/x86_64-linux-gnu/libcairo.so.2: undefined symbol: FT_Get_Var_Design_Coordinates)
QLibraryPrivate::loadPlugin failed on "/usr/lib/insync/platformthemes/libqgtk3.so" : "Cannot load library /usr/lib/insync/platformthemes/libqgtk3.so: (/usr/lib/x86_64-linux-gnu/libcairo.so.2: undefined symbol: FT_Get_Var_Design_Coordinates)"

So I’m still stuck. Worked like a charm for a year at least so I reinstalled v1.4.9 to get I to work again. I wish @Kurt_Ko could bring us a nice solution soon.

Working on a Debian Buster - Linux 4.14.0-3-amd64 #1 SMP Debian 4.14.17-1 (2018-02-14) x86_64 GNU/Linux.


#48

Same issue here. Fresh install of Stretch and Insync. Seemed to be working under Stretch. Then did dist-upgrade to Buster, changed the distribution in Insync’s sources.list.d file.

When I rebooted into Buster, Insync isn’t working and restarting it doesn’t help either. The System Monitor is not showing any Insync processes running.


#49

Same error in Debian Buster amd64

root@lnxwork01:~# apt install insync
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following NEW packages will be installed:
  insync
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/144 MB of archives.
After this operation, 400 MB of additional disk space will be used.
Selecting previously unselected package insync.
(Reading database ... 245869 files and directories currently installed.)
Preparing to unpack .../insync_1.5.5.37368-stretch_amd64.deb ...
Unpacking insync (1.5.5.37368-stretch) ...
Processing triggers for mime-support (3.61) ...
Processing triggers for desktop-file-utils (0.23-4) ...
Setting up insync (1.5.5.37368-stretch) ...
Insync installation has finished. You may now start it.
No protocol specified
Unable to init server: Could not connect: Connection refused

(zenity:14265): Gtk-WARNING **: 11:38:15.905: cannot open display: :0

When I try to start:

cmiranda@lnxwork01 ~ $ insync start --no-daemon
INFO     2019-01-22 11:35:10,178 [__main__insync__:main:105] insync version: 1.5.5.37368
INFO     2019-01-22 11:35:10,183 [__main__insync__:main:106] client created <ideskmain.client.Client object at 0x7f9a3b80bcd0>
INFO     2019-01-22 11:35:10,185 [unix_socket_server_portable:start:49] unix socket server thread start
INFO     2019-01-22 11:35:10,188 [__main__insync__:main:114] starting client
INFO     2019-01-22 11:35:10,216 [fswatch:_start:532] LinuxFSWatcher._start
INFO     2019-01-22 11:35:10,218 [fswatch:_pull_loop:267] Inotify loop enter
Received signal 11 SEGV_MAPERR 000000000108
#0 0x7f9a3eda3c1f <unknown>
#1 0x7f9a3d7cca9d <unknown>
#2 0x7f9a3eda412e <unknown>
#3 0x7f9a66a9c670 <unknown>
#4 0x7f9a59d32b24 <unknown>
#5 0x7f9a59d33da8 <unknown>
#6 0x7f9a649dedd4 glXCreatePbuffer
#7 0x7f9a3d82fc89 <unknown>
#8 0x7f9a3d81aa08 <unknown>
#9 0x7f9a3f8e945d <unknown>
#10 0x7f9a3db24f11 <unknown>
#11 0x7f9a3db26705 <unknown>
#12 0x7f9a3fd9f857 <unknown>
#13 0x7f9a415b9795 <unknown>
#14 0x7f9a3ee0c5d5 <unknown>
#15 0x7f9a3ee07970 <unknown>
#16 0x7f9a66a91fa3 start_thread
#17 0x7f9a666177ef clone
  r8: 0000000000000000  r9: 0000000000000001 r10: 0000000000000004 r11: 0000000000000206
 r12: 000055f3e8e50ae0 r13: 000055f3e8fbd600 r14: 000000000000000b r15: 000055f3e8e7bd40
  di: 000055f3e8e50ae0  si: 0000000000000000  bp: 000055f3e8e50ae0  bx: 0000000000000000
  dx: 0000000000008041  ax: ffffffffffffff50  cx: 0000000000000000  sp: 00007f99cb7fd480
  ip: 00007f9a59d32b24 efl: 0000000000010202 cgf: 002b000000000033 erf: 0000000000000004
 trp: 000000000000000e msk: 0000000000000000 cr2: 0000000000000108
[end of stack trace]
Calling _exit(1). Core file will not be generated.

This version installed

root@lnxwork01:~# dpkg -l |grep insync
ii  insync                                1.5.5.37368-stretch                   amd64        Google Drive sync and backup with multiple account support

#50

Tagging our engineer @Kurt_Ko for further assistance!


#51

insync start --no-daemon
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
Could not initialize GLX
Abandon (core dumped)


#53

I was having the same problem. I’ve renamed /usr/lib/insync/libGL.so.1 to libGL.so.1.bak and it works again. I understand why you’re bundling OpenGL for the general case but perhaps you should question if it’s necessary.