Insync 3.2.3 and 3.2.4 fail to start

When I upgraded to 3.4.3 I noticed my Insync client wouldn’t start, so I downgraded it.
When 3.2.4 came out I tried upgrading to that, but same problem.
Running insync start doesn’t report an error, it just doesn’t actually start.
I’m not sure where the relevant log files are, so I’m not sure if it’s showing an error there.

1 Like

Seeing the same on Fedora 32 running cinnamon

The same on KDE Neon

I also have the same problem on Debian unstable.

Hi all! Could you check this out and let me know if it persists after the workaround?

If it does, the log files are found in ~/.config. Please send the logs.db and out.txt to with the link to this post.

1 Like

Works after that workaround, thanks!

These updates only start after a reboot for both MX-Linux 19.x and Mint 19.x. Trying the workaround next… works.

Confirm the workaround by miamoran works on Linux Mint 19.1

Work around above worked for me, too, on Linux Mint 20

Glad to know it’s sorted out! If anything comes up just comment on this thread and/or email us at :slight_smile:

Works on Ubuntu 20.04.1 / 5.4.0-42

I can report that the suggested fix works on Kubuntu 20.04 but I have to redo it every time I restart Insync. For anyone else having that issue, I recommend editing the /usr/bin/insync script to delete the file before running Insync. Just add this line after the hashbang (#!):

rm /tmp/insync${UID}.sock


Thanks @Thea_Barnes! I’ve raised this to our engineers-- some users have also emailed us with the same concern (redoing at every restart) & will update this thread accordingly!

Hey all! Just a quick update from our Linux team–

The fix provided isn’t retroactive so you’ll first have to install 3.2.4 and remove the sock file. But when upgrading later on, you shouldn’t have to manually remove the sock file anymore :slight_smile:

For those of you still experiencing the issue above-- please check out 3.2.6. Note that the repo isn’t updated yet (but will be soon!)

Feedback is super welcome-- please post on the 3.2.6 thread instead