Insync disconnects wifi, unable to reconnect

I’m on a nearly fresh Xubuntu install (info below), and I’m having the following issue. Insync starts fine, but at some point stops syncing (I can see this by watching the stream…instead of “last update 1s” it starts to say “last update 5 m”, and keeps getting longer, while there are still things to sync). When this happens, I have no internet access and my pings answer

Temporary failure in name resolution

Starting and restarting Insync does not seem to fix this (as in, I can’t get my internet back). If I disconnect from the wifi and try to reconnect, the system completely freezes, requiring a restart. I suppose the system freeze might not be “because of Insync”, but the source of the problem certainly is - I can happily use this system until I start Insync, at which point is always, after 5-10 min, disconnects the wifi.

Any help would be appreciated. I grabbed the logs right after this happened and will try to attach them here.

$ lsb_release -a
No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 20.04.1 LTS
Release:	20.04
Codename:	focal
$ uname -a
Linux Xubunac 5.4.0-56-generic #62-Ubuntu SMP Mon Nov 23 19:20:19 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

Logs, I hope!

I think I’ve solved this, by switching from the wl module to the b43 module. So although Insync seemed to be creating the problem, it was not the source of the problem.

1 Like

Hi @Christopher_Duston,

Glad to know you were able to sort it out. Can I help you with anything else?