Insync fails to start on Arch/Gnome 40 (with fix)

Insync fails to autostart with systemd on my Laptop with Arch/Gnome 40. I have installed version 3.4.1.40977 from the AUR.

Here is the output of systemctl --user status insync:

#0  0x00007f6e9584ed22 raise (libc.so.6 + 0x3cd22)
#1  0x00007f6e95838862 abort (libc.so.6 + 0x26862)
#2  0x00007f6e8cec1e2c _ZNK14QMessageLogger5fatalEPKcz (libQt5Core.so.5 + 0x85e2c)
#3  0x00007f6e8d7126c8 _ZN22QGuiApplicationPrivate25createPlatformIntegrationEv (libQt5Gui.so.5 + 0x1436c8)
#4  0x00007f6e8d7129dd _ZN22QGuiApplicationPrivate21createEventDispatcherEv (libQt5Gui.so.5 + 0x1439dd)
#5  0x00007f6e8d0b62ff _ZN23QCoreApplicationPrivate4initEv (libQt5Core.so.5 + 0x27a2ff)
#6  0x00007f6e8d71430b _ZN22QGuiApplicationPrivate4initEv (libQt5Gui.so.5 + 0x14530b)
#7  0x00007f6e8df5d1d9 _ZN19QApplicationPrivate4initEv (libQt5Widgets.so.5 + 0x1651d9)
#8  0x00007f6e8ea0e984 Sbk_QApplication_Init (QtWidgets.abi3.so + 0x18b984)
#9  0x00007f6e955c3ae2 type_call (libpython3.7m.so.1.0 + 0xe9ae2)
#10 0x00007f6e9556d7d3 _PyObject_FastCallKeywords (libpython3.7m.so.1.0 + 0x937d3)
#11 0x00007f6e95546b1b call_function (libpython3.7m.so.1.0 + 0x6cb1b)
#12 0x00007f6e955414db function_code_fastcall (libpython3.7m.so.1.0 + 0x674db)
#13 0x00007f6e95549e61 call_function (libpython3.7m.so.1.0 + 0x6fe61)
#14 0x00007f6e955414db function_code_fastcall (libpython3.7m.so.1.0 + 0x674db)
#15 0x00007f6e9554adf9 call_function (libpython3.7m.so.1.0 + 0x70df9)
#16 0x00007f6e9564288e _PyEval_EvalCodeWithName (libpython3.7m.so.1.0 + 0x16888e)
#17 0x00007f6e9556cf3b _PyFunction_FastCallDict (libpython3.7m.so.1.0 + 0x92f3b)
#18 0x00007f6e95545cbd do_call_core (libpython3.7m.so.1.0 + 0x6bcbd)
#19 0x00007f6e9564288e _PyEval_EvalCodeWithName (libpython3.7m.so.1.0 + 0x16888e)
#20 0x00007f6e9556cf3b _PyFunction_FastCallDict (libpython3.7m.so.1.0 + 0x92f3b)
#21 0x00007f6e9556e0fd _PyObject_Call_Prepend (libpython3.7m.so.1.0 + 0x940fd)
#22 0x00007f6e9556f305 PyObject_Call (libpython3.7m.so.1.0 + 0x95305)
#23 0x00007f6e95545cbd do_call_core (libpython3.7m.so.1.0 + 0x6bcbd)
#24 0x00007f6e955414db function_code_fastcall (libpython3.7m.so.1.0 + 0x674db)
#25 0x00007f6e95549e61 call_function (libpython3.7m.so.1.0 + 0x6fe61)
#26 0x00007f6e9564288e _PyEval_EvalCodeWithName (libpython3.7m.so.1.0 + 0x16888e)
#27 0x00007f6e9556d0f3 _PyFunction_FastCallKeywords (libpython3.7m.so.1.0 + 0x930f3)
#28 0x00007f6e95549e61 call_function (libpython3.7m.so.1.0 + 0x6fe61)
#29 0x00007f6e9564288e _PyEval_EvalCodeWithName (libpython3.7m.so.1.0 + 0x16888e)
#30 0x00007f6e9556cf3b _PyFunction_FastCallDict (libpython3.7m.so.1.0 + 0x92f3b)
#31 0x00007f6e9556e0fd _PyObject_Call_Prepend (libpython3.7m.so.1.0 + 0x940fd)
#32 0x00007f6e9556f305 PyObject_Call (libpython3.7m.so.1.0 + 0x95305)
#33 0x00007f6e95545cbd do_call_core (libpython3.7m.so.1.0 + 0x6bcbd)
#34 0x00007f6e9564288e _PyEval_EvalCodeWithName (libpython3.7m.so.1.0 + 0x16888e)
#35 0x00007f6e9556cf3b _PyFunction_FastCallDict (libpython3.7m.so.1.0 + 0x92f3b)
#36 0x00007f6e9556e0fd _PyObject_Call_Prepend (libpython3.7m.so.1.0 + 0x940fd)
#37 0x00007f6e955cbea5 slot_tp_call (libpython3.7m.so.1.0 + 0xf1ea5)
#38 0x00007f6e9556d7d3 _PyObject_FastCallKeywords (libpython3.7m.so.1.0 + 0x937d3)
#39 0x00007f6e95545e17 call_function (libpython3.7m.so.1.0 + 0x6be17)
#40 0x00007f6e9564288e _PyEval_EvalCodeWithName (libpython3.7m.so.1.0 + 0x16888e)
#41 0x00007f6e95642b0e PyEval_EvalCodeEx (libpython3.7m.so.1.0 + 0x168b0e)
#42 0x00007f6e95642b3b PyEval_EvalCode (libpython3.7m.so.1.0 + 0x168b3b)
#43 0x0000000000402ca1 n/a (insync + 0x2ca1)
#44 0x0000000000403087 n/a (insync + 0x3087)
#45 0x00007f6e95839b25 __libc_start_main (libc.so.6 + 0x27b25)
#46 0x0000000000401a9e n/a (insync + 0x1a9e)

The systemd unit file is here: Link

1 Like

Hi @fabwu-- could you also run insync start --no-daemon and share the output here? Thank you!

For me also don’t start.
My output here:

Warning: Ignoring XDG_SESSION_TYPE=wayland on Gnome. Use QT_QPA_PLATFORM=wayland to run on Wayland anyway.

(insync:2344659): GLib-GIO-ERROR **: 12:17:20.793: Settings schema 'org.gnome.settings-daemon.plugins.xsettings' does not contain a key named 'antialiasing'

I am using: QT_QPA_PLATFORM=wayland insync start and ìnsync show.
However, i can’t handle the window and icon don´t show.

Hi @clautercarlos, are you also running Insync 3.4.1?

Here’s the output:

$ insync start --no-daemon
Warning: Ignoring XDG_SESSION_TYPE=wayland on Gnome. Use QT_QPA_PLATFORM=wayland to run on Wayland anyway.

(insync:3792): GLib-GIO-ERROR **: 07:32:49.043: Settings schema 'org.gnome.settings-daemon.plugins.xsettings' does not contain a key named 'antialiasing'
Trace/breakpoint trap (core dumped)

and here the insync version:

$ insync version
3.4.1.40977

insync version: 3.4.1.40977

Thank you both for sending the additional information. Let me send this to our Linux team and I’ll update you here!

Hi @fabwu @clautercarlos

Can you install/upgrade gsettings-desktop-schemas to the latest version?

If it still doesn’t work, replacing the above package with gsettings-desktop-schemas-git in the AUR help?

There was a bug with gsettings-desktop-schemas that is fixed in later versions

No luck with gsettings-desktop-schemas-git.

The key exists under:

$ gsettings get org.gnome.settings-daemon.plugins.xsettings.deprecated:/ antialiasing
'grayscale'

It looks like antialiasing was replaced with font-antialiasing.

Hi @fabwu

What are the versions of gtk3/gtk4 do you have installed?
Ref: https://gitlab.gnome.org/GNOME/gtk/-/issues/3680#note_1040412

I have gtk 3.24.29 and gtk 4.2.1 installed.

If I start insync with GDK_BACKEND=x11 insync start --no-daemon it does work (see here). Not sure if that helps…

Same problema with gsettings-desktop-schemas-git.

gtk 3.24.29-2 and gtk 4.2.1-2

I’m using QT_QPA_PLATFORM=wayland but insync don’t start with the system and no icon appear yet.

Thanks

Hi @fabwu @clautercarlos

Would it work w/o setting the extra env variables? (GDK_BACKEND=x11/QT_QPA_PLATFORM=wayland)

Does running only insync start --no-daemon show the same error or a different one?

1 Like

Hi @Kurt_Ko

Here’s the output of insync start --no-daemon without the extra env variables:

Warning: Ignoring XDG_SESSION_TYPE=wayland on Gnome. Use QT_QPA_PLATFORM=wayland to run on Wayland anyway.

(insync:2907): GLib-GIO-ERROR **: 08:13:29.329: Settings schema 'org.gnome.settings-daemon.plugins.xsettings' does not contain a key named 'antialiasing'
Trace/breakpoint trap (core dumped)

GDK_BACKEND=x11 insync start Works!.
I can see the icon and handle the window. However, don’ t start with the system.

1 Like

Hi @clautercarlos

For the setting to be enabled on startup, modify these 2 files ~/.config/autostart/insync.desktop
and /usr/share/applications/insync.desktop. Change the line Exec=insync start to Exec=env GDK_BACKEND=x11 insync start

1 Like

Hi @fabwu

Do you have a GPU? If so which drivers are you using with it? Does running QTWEBENGINE_CHROMIUM_FLAGS="--disable-gpu" insync start --no-daemon fix the crash issue?

1 Like

Hi @Kurt_Ko

Yes, I have a GPU that runs with the nouveau driver.

I tried your command but insync still crashes with the same antialiasing error.

Hi @Kurt_Ko

Today I’ve got an update for gnome-shell 40.3, and now Insync starts without any errors.

Autostart still doesn’t work, but I create a separate topic for this problem.

Thanks for your help!

EDIT: Starting insync with systemd didn’t work but using Gnome Autostart does work so all problems are fixed :slight_smile:

1 Like