Insync-headless doesn't show "Shared with me" section


#1

Hi there,

I’m trying to use insync-headless, and set up selective sync with the manage_selective_sync interface, but I’m finding a catastrophic bug: the manage_selective_sync curses interface doesn’t show the “Shared with me” section. The headless client is, by default, syncing everything in the “Shared with me” section, but that’s tens and tens of terabytes! It makes the headless client unusable! I had to immediately pause syncing so as to make sure that the headless client wasn’t going to try and download tens of terabytes.

This is on CentOS 7.4.

This is a serious bug.


#2

Hey @sethgoldin!

We’ve replied to your chat message. Could you kindly send your log files to support@insynchq.com? :slight_smile:


#3

Looks like there’s a hidden way to navigate over to the Shared with me section within the curses interface.

Kurt emailed me to let me know:

If you run ‘insync manage_selective_sync [EMAIL]’ and the press Ctrl+X, an option should appear to switch to the “Shared with me” view.

It would be great if the documentation for insync-headless were updated, but until then, hopefully this message helps someone…


#4

Thanks for the feedback, @sethgoldin! :slight_smile: