Insync not working with Ubuntu Jammy (FIXED)

Today I upgraded from Ubuntu 20.04.4 LTS to Ubuntu 22.04 LTS and when adding the repository and installing Insync, this application doesn’t work. Below the error output:
~$ insync start --no-daemon
Warning: Ignoring XDG_SESSION_TYPE=wayland on Gnome. Use QT_QPA_PLATFORM=wayland to run on Wayland anyway.
/usr/lib/x86_64-linux-gnu/gio/modules/ undefined symbol: g_tls_channel_binding_error_quark
Failed to load module: /usr/lib/x86_64-linux-gnu/gio/modules/

(insync:31386): GLib-GIO-ERROR **: 18:19:11.217: Settings schema ‘org.gnome.settings-daemon.plugins.xsettings’ does not contain a key named ‘antialiasing’
Trace/breakpoint trap (core image recorded)

1 Like

Hello @fox and @wagnux ,

There is a known bug when running it on Wayland and this is an issue I’ve requested to be investigated further.

@area51pilot Could you quit Insync and Nautilus when that happens and try again, in case you haven’t? If the issue persists, please send your logs.db and out.txt to with the link to this post. The logs can be found in ~/.config/Insync.

Thank you :slight_smile:

I just upgraded to Ubuntu 22.04, and the above workaround stopped the crashing. But I’m now getting the wayland error along with a GLib-GIO-ERROR/core dump:

insync start --no-daemon
Warning: Ignoring XDG_SESSION_TYPE=wayland on Gnome. Use QT_QPA_PLATFORM=wayland to run on Wayland anyway.

(insync:7327): GLib-GIO-ERROR **: 22:18:30.560: Settings schema ‘org.gnome.settings-daemon.plugins.xsettings’ does not contain a key named ‘antialiasing’
Trace/breakpoint trap (core dumped)

your workaround worked for me also in OpenSuse Tumbleweed

Any updates for the build package Ubuntu 22.04 ?


See for more on the antialiasing issue. The workaround in in particular makes it run.

Looks like a gsettings value was deprecated somewhere along the way.

1 Like

@Robert Appreciate your input on this issue and for linking the relevant resources! Let me forward this to our Linux Team as well. :slight_smile:

1 Like

I have used the workaround, and it works now. About the app font being too small on my laptop, I have used this other hint:

Any solution to the problem of not being able to change the destination folder of files? because when clicking on change the insynq locks and closes, not being possible to change.

I’ve been using the web version of google drive for weeks, because Insync is out of use.

It’s not the first time I’ve noticed that you are waiting for the final LTS version to come out, to pay attention to the product, since it has been available for months for developers and users to test in their environments.

Attempting to set up an LSS sync hangs, and then closes the window.

thX! Works perfectly

1 Like

Hi @thiagodalsoto!

Could you please email with the screenshots of the error message that you come across when trying to change the destination? It sounds like this is a known issue that our team is looking into and I’d like to confirm so I can send you the necessary steps to get out of that locked state.

As for the pain point of not having a readily available build for the latest OS releases: I completely understand. I have raised this concern with our Product and Linux teams to assess ways on how we can improve our release processes.

@dennyi Hi!

Could you please send the exact steps you took and email them to with the link to this post? Screenshots would also be appreciated!

Please do include your logs.db and out.txt files which should be in ~/.config/Insync.

Information sent in the requested email

After thinking about it, and not seeing anyone else complaining about it, I installed on a Virtual 22.04 ubuntu, using the impish version, and it worked the way it should. Using the workaround mentioned above.

I had used the focal install on my laptop, and that was the one that had the problem.

So, I reinstalled my laptop using impish, and it is ok now.

1 Like

Thank you @dennyi for letting us know what workarounds you used to get Insync running on your machine :slight_smile:

This is interesting… normally we’d ask users to try the latest build available in our repositories when an upcoming Linux release is on its way. I’ve had a couple of users tell me that the Impish build wasn’t working, which could be a main driver to the continuous discussion here.

Regardless, thank you for the information!! I will keep this in mind when attending to similar reports. :slight_smile:

I used this workaround, found in this discussion:


Same error - KUbuntu 22.04 + Dell XPS 9510
The workaround is to remove

sudo mv /usr/lib/insync/./ /usr/lib/insync/./

Insync starts and seems to be working fine. @mia - I hope this helps

1 Like

Thank you @dennyi! The same workaround has been shared to other Ubuntu users as well, thanks to this community. :slight_smile:

I am going to wait for an official fix rather than move a C++ standard library. Yikes

1 Like

For me insync is also not working on Ubuntu 22.04 LTS. If I start insync with

insync start --no-daemon

I get the following error:

Failed to create OpenGL context for format QSurfaceFormat(version 2.0, options QFlags<QSurfaceFormat::FormatOption>(), depthBufferSize 24, redBufferSize -1, greenBufferSize -1, blueBufferSize -1, alphaBufferSize -1, stencilBufferSize 8, samples 0, swapBehavior QSurfaceFormat::DefaultSwapBehavior, swapInterval 1, colorSpace QSurfaceFormat::DefaultColorSpace, profile  QSurfaceFormat::NoProfile) 
Fatal Python error: Aborted

Thread 0x00007f940b7fe640 (most recent call first):
  File "concurrent/futures/", line 78 in _worker
  File "", line 870 in run
  File "", line 926 in _bootstrap_inner
  File "", line 890 in _bootstrap

Thread 0x00007f940bfff640 (most recent call first):
  File "concurrent/futures/", line 78 in _worker

When there is an update of insync available?