Insync stopped starting automatically (Fedora 34, KDE)

Hello,
using Fedora Insync suddenly stopped starting automatically after login. Does anyone have the same problem?
Thanks
Tom

Yes, in fact I was about to post about this same issue. I’m on Fedora 34 and have to start insync-headless manually every time I log in. I use the KDE desktop and putting ‘insync-headless start’ in the Autostart configuration does not work.

1 Like

In your case it could be a KDE setting, have you tried setting the settings to start with an empty session?

Greetings.

The problem is that the KDE Autostart dialogue doesn’t appear to allow arguments to startup commands. You just fill in the name of the program. One workaround would be presumably to use a script (I haven’t tried it yet), but it shouldn’t really be necessary for the user to come up with this. There’s been some discussion elsewhere about creating a systemd unit for these cases, but that’s even more burdensome for the average user. See for example:

https://superuser.com/questions/1037466/how-to-start-a-systemd-service-after-user-login-and-stop-it-before-user-logout

and

https://unix.stackexchange.com/questions/597990/enabled-systemd-user-service-doesnt-start-at-login

Hey all! Let me forward this to our Linux team. Can you share your Insync versions here please, regardless it’s the GUI or headless version?

Thank you!!

3.5.0.50109 on Fedora 34 KDE with KDE Plasma 5.22.4

1 Like

Can you confirm if the startup setting is checked when you hover on the 3 dots on the upper right (. . .) > Preferences > App settings?

Hi everyone,

yes, I have “Start Insync on login” checked and also I have Insync listed in automatic launch setting in KDE setup…

Still no automatic lauch after KDE login.

I have Fedora 34 KDE with KDE Plasma 5.22.4, using Insyng 3.5.1.50115.

Gotcha, seems to be the pattern that it’s affecting Fedora users on KDE. I’ve notified our engineers so we can investigate this further and provide a fix as soon as possible!

Hi @Tomas_Drvota @POC @reiscw

While insync-headless is running, can you run the following command?

insync-headless config run_on_startup true

Let us know if it works

Well I don’t have insync-headless installed. I use insync instead.

Adding in a quick “me too!” here; I’ve been manually starting insync for some time now (months) under the latest KDE on Fedora 34.

2 Likes

This is a known issue and our engineers have created a bug report to line this up for a fix. I’ll update this thread as soon as the build is available!

2 Likes