New Insync version: 3.0.29

Release notes:

  • Limit memory usage of Activity Feed
  • Windows: Fix syncing to top level folder on external drives
  • Display the local or cloud item associated with unexpected errors in Attention required
  • Mac: Fix cross-partition moves on Mac (such as when moving a base folder to an external drive)
  • Fix a rare error when renaming a local item

Windows 7 and later
macOS 10.10 (Yosemite and later)

Ubuntu (16.04 Xenial) & (18.04 Bionic)
Linux Mint (18.x) & (19.x)
Debian (8 Jessie) , (9 Stretch) & (10 Buster)
Fedora (27) , (28) , (29) & (30)

  • Limit memory usage of Activity Feed

So does this fix the Out of Memory issues on OSX?

Hi @inforr,

This addresses the memory leak issues reported by OSX Catalina users. Please let me know if your Activity Monitor still shows a large memory consumption when running Insync.

I have uninstalled the previous version. I delele Insync folder on appdata.
After that I installed insync [3.0.29] and wizard stuck at the point which choice Google Drive, open url to confirm and more specific Connecting to Insync…

There is still one major bug. Can you please clarify if you are even aware of it?
Insync does still not reliably sync all files to the local directory between multiple computers. Not even root directory but right within already synced folders. I continuously have to manually open the Insync App and browse to a sub-folder where I know more files are present in Drive than locally are available. Miraculously the app suddenly recognizes the missing files and loads them. Working without a client is almost as practical as with Insync as I do not always 100% remember which of the thousands of files are omitted. Persists since a long time sadly.

Not sure if only Shared drives or private and shared. Mostly using shared drives at work.

1 Like

I noticed that when I installed insync on a new computer, nothing was synching. I had to go into each folder one by one and click the synch icon to get it moving. Seems like a bug to me, because I would have thought once you install it and kick it off, it should start downloading everything.

Hi @xpusostomos,

For new computers, you need to either click Select all or choose files to sync during onboarding as explained here.

Hi @Nikolaos_Karanikolas,

Can you check for any firewalls that may be blocking Insync? Furthermore, could you try doing the alternative login?

Hi @wolfi,

We have received reports that Insync misses folders that are supposed to be synced, and we’re looking into this. Can you send me your latest logs.db and out.txt files to with the link to this post?

I check firewall. It’s ok.
I tried also alternative way to login but again it stuck when i press login.

Do you know if must reinstall python or something else?

I uninstalled insync, cleaned up the registry and the appdata folder, restarted explorer.exe, and then reistall from scratch.Also i cleanup Google Chrome. Now it works.
I think the problem was the Chrome. I am not sure.

Thank you.


" For new computers, you need to either click Select all or choose files to sync during onboarding as explained [here]"

So… you’re saying that if I DON’T want selective sync… aka, I want to sync everything… I have to click the button labeled “selective sync”? Hmm, a prize for figuring out what is wrong with this user interface.

how do i install om OpenSuse with a repo…??

Hi! The repo hasn’t been updated with 3.0.29, but we will do so once the build is released in our webpage! :slight_smile: For now I suggest to install the builds from this page. :slight_smile:

1 Like

in addition to getting insync 3 more stable and reliable, we have started efforts with redoing the UI starting with HDPI support and resizable windows. we hope to have this soon.

thank you :slight_smile: keep updating the main repo to install the latest version…

I think it is time now to finally develop really functional Thunar desktop plugin for InSync3!!! What do you think???

OSX 10.15.3
The Finder Integration keeps crashing, even after fresh reinstall.

Process: Insync Finder Integration [1971]
Path: /Applications/ Finder Integration.appex/Contents/MacOS/Insync Finder Integration
Identifier: Insync Finder Integration
Version: 2 (2)
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: Insync Finder Integration [1971]
User ID: 501

Date/Time: 2020-02-14 17:46:30.300 +0800
OS Version: Mac OS X 10.15.3 (19D76)
Report Version: 12
Bridge OS Version: 4.2 (17P3050)
Anonymous UUID: 0C388DF3-14CD-4DFA-8E46-605032216D48

Time Awake Since Boot: 290 seconds

System Integrity Protection: enabled

Crashed Thread: 0

Exception Type: EXC_CRASH (SIGABRT)
Exception Codes: 0x0000000000000000, 0x0000000000000000

Termination Reason: DYLD, [0x1] Library missing

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
Library not loaded: @rpath/FinderSync.framework/Versions/A/FinderSync
Referenced from: /Applications/ Finder Integration.appex/Contents/MacOS/Insync Finder Integration
Reason: image not found

Binary Images:
0x1034b2000 - 0x1034b7ff7 +com.insynchq.Insync.Insync-Finder-Integration (2 - 2) /Applications/ Finder Integration.appex/Contents/MacOS/Insync Finder Integration
0x10cdfc000 - 0x10ce8ccb7 dyld (733.8) /usr/lib/dyld
0x7fff296fa000 - 0x7fff2a4b5fff (6.9 - 1894.30.142) <5A1752C0-67F4-3EDF-97DA-81AB42824B7B> /System/Library/Frameworks/AppKit.framework/Versions/C/AppKit
0x7fff2c4f2000 - 0x7fff2c972fe7 (6.9 - 1674.114) <5810CC45-FB5D-3A78-861F-7BE03F9B2FDD> /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation
0x7fff2ebb7000 - 0x7fff2ef7fffc (6.9 - 1674.114) <532BBAE7-F2BA-3779-94E0-BFEDF2D7AB38> /System/Library/Frameworks/Foundation.framework/Versions/C/Foundation
0x7fff60a45000 - 0x7fff60a46ff3 libSystem.B.dylib (1281) /usr/lib/libSystem.B.dylib
0x7fff6289a000 - 0x7fff628cbfc6 libobjc.A.dylib (781.2) <7B72F50A-5381-36D7-A616-65D3EA9748A5> /usr/lib/libobjc.A.dylib

I have been an insync user for years (since the first version). However I have a problem for several updates of version 3, which has not been corrected yet. I currently use version in Ubuntu 16.04.6 LTS with all packages fully updated. I am suffering from these problems since I updated several versions of insync.

I have two accounts in the insync application. The first account works perfectly. However, in the second account the files stop syncing (files are stuck on queue, no progress is happening). Synchronization starts well but after a minutes it stops.

I have tried all the recommendations that you indicate on your website. I have tried everything: uninstall the application, update the application, remove the accounts, completely erase all files from Google Drive and re-synchronize them… and nothing works.

Hi @miamoran

Its better - but still the biggest consumer of RAM on my Mojave and High Sierra machines. I don’t know why this was thought to just be related to Catalina.