No tray icon in ubuntu 17.10 (solved)


#21

For those on Arch, try to install the sni-qt-patched package from the AUR. That fixed the problem for me.


#22

The first option worked for me.
You are a Genius! Thanks!


#23

Hi guys, Arch Linux + GNOME user here. (I already posted this in another topic, but I think it will be useful here too.)

I was finally able to solve this issue now! I already had sni-qt installed, which wasn’t making the icon show up, however I noticed someone saying about conflicting indicators apps, so I went on and uninstalled libappindicator-gtk3 and libindicator-gtk3 - which I had installed a long time ago - and the icon started showing up after starting the session.

I don’t know exactly what’s happening, since I wasn’t able to inspect any logs that might lead to the clues, but my guts tell me insync might be trying to use libindicator-gtk3’s API first instead of sni-qt and end up “thinking” that it’s already showing up. In other words, libindicator-gtk3 might be tricking insync that it’s showing up properly, when it’s actually not.

Cheers!
Diogo


#24

Hi, Thanks @jaduenas

On Ubuntu 18.04 installing sni-qt worked - Along with having the extension
(K) Status Notifier
(since topicons is no longer supported.)
Eli


#25

Simple restart of the Gnome shell seems to correct this (running 18.04 and have insync starting at boot).

The icon is almost always missing from the menu bar, so doing a ALT+F2, then typing r in the command window box that opens up, then hitting the enter key solves it for me.

The above worked when ALL of prior suggested solutions had been attempted and failed for me.