Not sync from HD root level folder to Google Drive folder

I want to share a selective folder from my Google Drive to my D: drive (in the root level, not in a folder). The Google Drive folder is replicatet in my root HD level and sync is OK. However, the following problem occurs:

If I put a file in a new file in my Google Drive folder, then the file is synchronized well

But if I put (or delete) a file on my drive D: then this file is not synchronized with my Google Drive

It is not possible to synchronize from a HD root level folder to the Google Drive folder?

Running Windows 7 ultimate 64 bits.

@akatarmo Could you elaborate your Insync setup – where is the main Insync folder and how have you added D drive to Insync?

Also, checkout if the following how-to thread is useful for you: How to change the syncing location of a file/folder to outside of the Insync folder


In the InSync initial setup process for my local drive, I change the default path from C:\Users\ [Username]\ to my unit D: (main level, no folder) in the dialog window.

In the process setup for the remote unit (Google Dirve GSuite), I choose “Selective Folder”, I uncheck “share all folders” and I choose, for example, only the “Test” folder.

Then, at the end of the setup, I can see that InSync starts working and then I see that a “Test” folder has been created in my Local D: and all the files in the “Test” folder of my remote unit ( GoogleDrive) are synchronized to my local drive D:\Test. So far, all OK.

So, as I explained before, if I put a file in the GoogleDrive\Test folder, this file is immediately synchronized (replicated) in my local drive D:\Test.

— However — If I put a file in my local drive D:\Test, this file is never synchronized to my remote drive GoogleDrive\Test folder. This problem does not occur if I use C:\Users\ [Username]\email@domain or D:\SomeFolder (instead of D:) as a local drive folder.

I hope to have explained the problem in an understandable way, it is a little hard for me to write in English, it is not my native language.


@akatarmo Thank you for the comprehensive and clear description of the problem.

Please send to us a copy of Insync logs and “dbs” from your machine to The “dbs” folder is located beside the log files. Create the copy of the “dbs” folder, compress it and then send it to us (upload it to Google Drive and send the share link if it is too big to email).

In the email kindly mention the path of an example file/folder which is not uploading.


Hello, I’m sorry, after many hours, I’ve already set up (and running) my entire system and I would have to delete the account now and start from scratch to reproduce the problem.

Obviously, I have had to use a folder at a lower level to synchronize without problems. In this way:


My remote files in Google Drive (Test folder) are synchronized well in both directions in my local folder D:\AKSuite\Test

I expected that you could simulate the problem and solve it.

Hello @akatarmo,

Unfortunately, we could not replicate the issue; perhaps it is an environment specific issue. Please get back to us if you ever encounter such issue again.


Enter his computer with remote access… you GENIUS!!!

Hello. I have the same “issue”. I have insync running on a computer where it’s only purpose is to keep a single folder in sync.

  1. c:\gdrive is the root for google drive within insync - Nothing has been configured to sync.
  2. c:\gdrive\backup is the only folder now configured to sync and it syncs fine.
  3. From another computer or within Google Drive web a file or folder is created on the root eg: c:\gdrive\test.txt or c:\gdrive\NewFolder
  4. The new file and folder will sync on the insync instance where only c:\gdrive\backup is configured to sync.

This is not a huge deal, I typically do not add things to the root of GoogleDrive. But I have run into a situation where something large was created on the root of GoogleDrive and it consumed all the free space on this computer that should only sync the “backup” folder.

I think a work around might be to ignore all *except “backup” ? Does such an option exist in the Ignore rules?

Thank you,

Hey @OverRide0x01 :slight_smile: Is this happening on My Drive, Shared with me, or Shared Drives?