"Open with insync helper" doesn't work

I use Linux Mint 17.3 (Cinnamon Edition) and I can’t open google documents when i double-click document icon. If I type in terminal usr/lib/insync/insync open_in_gdrive it works. If I right-click on icon, go to Insync and Open in Google Drive it works. But if I double-click on document icon then nothing happens. Any ideas how to resolve this problem?

Tagging our engineer @lpugoy and he will get back to you :smile:

@Michal_L: Apologies for the trouble. Please do the following:

  • Run Insync with insync start --no-daemon
  • Double click on the Google document
  • Check if there’s any error in the terminal

When I double-click on google docs nothing happens in terminal. When I start with insync start --no-daemon in terminal appears only:

INFO 2016-03-10 17:53:27,316 [__init__:info:1614] insync version: INFO 2016-03-10 17:53:27,318 [__init__:info:1614] client created <ideskmain.client.Client object at 0x7f923bcc3d90> INFO 2016-03-10 17:53:27,318 [__init__:info:1614] unix socket server thread start INFO 2016-03-10 17:53:27,319 [__init__:info:1614] starting client INFO 2016-03-10 17:53:27,324 [__init__:info:1614] LinuxFSWatcher._start INFO 2016-03-10 17:53:27,326 [__init__:info:1614] Inotify loop enter INFO 2016-03-10 17:53:27,384 [__init__:info:1614] Syncing GDUser(id=u'xxxx', email=u'xxxx', name=u'Micha\u0142 xxxx'). INFO 2016-03-10 17:53:27,466 [__init__:info:1614] watch origin: /home/michal/Gdrive INFO 2016-03-10 17:53:27,520 [__init__:info:1614] GDUser(id=u'xxx', email=u'xxxx', name=u'Micha\u0142 xxxx') (existing) is now being synced

@Michal_L: I see. Please send your logs to support@insynchq.com for investigation: How to find the log files.

OK. Thanks. I’ve just sent my logs

I’ve found one matter that may be useful in solution of the problem. Double-click on Google Docs doesn’t work only if I have Polish national letters (ą,ć,ę,ł,ń,ó,ś,ź,ż) in a name of file or/and in a directory. The coding in my operation and in Chrome is UTF-8. Now I know that I can change file/directory name and everything will be ok, but is there any possibility to both keep my old names of files/directories and to have double-click working?

@Michal_L: Thanks for the clue. I will investigate this.

Hi. For me it doesn’t work either (Ubuntu 15.10), regardless of whether there are any Czech characters or just plain ASCII.
Nothing showed up in the terminal.

@Jiri_Richter: What is the output when you run insync open_gd_url /path/to/gdlink/file? Does open_in_gdrive work for you?

insync open_gd_url ./my_file.gddoc
open_gd_url not a valid command

insync open_in_gdrive ./my_file.gddoc
shows nothing and doesn’t open the file in browser

@Jiri_Richter: Apologies for that, the correct command should be open_gdurl (no _ between gd and url).

Hello, many thanks for the correction. Unfortunately even insync open_gdurl ./file.gddoc doesn’t output anything and also doesn’t open the file in browser.
Can I get any logs on my side?
I’m using chrome by the way.

@Jiri_Richter: Please check this to locate the logs: How to find the log files.

Could you try passing the full path as well, like /full/path/to/my_file.gddoc instead of ./myfile_doc.

Many thanks, I have located the error. I have a non-ascii character in the path (“á”).

Traceback (most recent call last):
  File "<string>", line 6, in <module>
  File "__main__.py", line 128, in <module>
  File "__main__insync__.py", line 145, in <module>
  File "isyncd/linux/insync_cli_parser.py", line 275, in parse
  File "isyncd/linux/insync_cli_parser.py", line 322, in parse_command
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 47: ordinal not in range(128)

Would this be supported in the future?

Very good question, I would also really need this… Is this a Linux only issue?

@Jiri_Richter: Thanks. This is a bug that was introduced in the last version. A fix will be included in the next release, apologies for the trouble. @helgeklemm

I have the same problem with my laptop (Fedora 27). I am able to open the Drive in Firefox or Chrome (both) only from the command line. The strange thing is that on my desktop (Centos 7) the double click works. This is somewhat irritating for a test user,

Ubuntu 19.04 - Insync v3.0.22.40446 - unable to double click to open gddoc & gdsheet files after latest update.

Using Insync v3.0.22.40446 on a Ubuntu 19.04 fresh install, in nautilus can’t open any gd docs with double clic.
clic “open with insync helper” doesn’t work.
only can open gd docs in nautilus, by right clic menu and then insync option > view on the web, then firefox launches and open gdsheet normally.

1 Like