Repository for openSUSE


#19

Ok, I managed to make it work. I am using OpenSuse Tumbleweed but it shouldn’t make any difference on other versions

  1. import the rpm key sudo rpm --import https://d2t3ff60b2tol4.cloudfront.net/repomd.xml.key
  2. Add the new repository from the Yast2 interface. It will fail due permissions, but that’s fine. Accept it and save it.
    I personally used the latest fedora version, so the url was http://yum.insynchq.com/fedora/24.
  3. open the repository in vim located in /etc/zypp/repos.d/ and add these two lines

gpgcheck=1
gpgkey=https://d2t3ff60b2tol4.cloudfront.net/repomd.xml.key

Now you should be able to list and install


Need help on installation on opensuse
#20

Thank you @ftonello! Your guide worked for me! Although I used http://yum.insynchq.com/fedora/21 instead of 20. I am curious if this isn’t too old since Fedora 24 is out?

Also the menu bar icon is has a really low resolution. I am using openSUSE Tumbleweed with KDE Plasma.

My final question wouldn’t it be possible to make a separate repository for openSUSE only? This feels too hacky for me. Or if that’s not possible release an rpm noarch? Or maybe use the power of the OBS?

Maybe AppImage could also be an option.

Sorry but I really dislike it to integrate a repository intended for another Distribution into my production machine.

Besides that I really love Insync!


#21

Actually I used Fedora’s 24 repository instead. I fixed on my comment above.

I also have the same problems. Are you sure the icon is not like that on other distros or DE’s?

So yes, AppImage or OBS would be great. TBH I never looked into any. But I prefer AppImage’s approach, but then iSync itself could release it officially.


#22

Ah okay that makes more sense, thanks! :slight_smile:

Before I came to openSUSE I used Manjaro which is based on Arch. The AUR has an unofficial insync package which I installed. I also used KDE Plasma with Manjaro and the icon was much better. But the AUR uses the .deb-package as source.

I also think AppImage would be the best option since - I build carefully - they would only have to make/maintain one package for all major Linux Distros.


#23

Hi! I am using insync on ubuntu 16.04 amd64. Recently I began receiving the error:

W: GPG error: http://apt.insynchq.com/ubuntu xenial InRelease: The following signatures were invalid: KEYEXPIRED 1473479811 KEYEXPIRED 1473479811 KEYEXPIRED 1473479811 KEYEXPIRED 1473479811 KEYEXPIRED 1473479811 KEYEXPIRED 1473479811 KEYEXPIRED 1473479811
E: The repository ‘http://apt.insynchq.com/ubuntu xenial InRelease’ is not signed.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

I tried eliminating insync from software sources and followed steps 1-4 to set up the repository through APT, however I still receive the same error when updating “apt get update” as before. How can I solve this problem? Thanks!


#24

@Andres_Jurado: Very sorry for the trouble. Please see this page on how to fix the issue: New Insync version: 1.3.11.


#25

Have you guys had any issues with Insync 1.3.12?
It hangs when finishing the instalation. It has something to do with the rpm gpg key. RPM hangs for some reason.
Installation of insync-1.3.12.36116-fc21.x86_64 failed: Error: Subprocess failed. Error: RPM failed: warning: waiting for transaction lock on /var/lib/rpm/.rpm.lock


#26

tagging our engineer @lpugoy


#27

@ftonello: Apologies for that. That is a known issue that we don’t have a fix for yet. I’ll try to take a look at it soon.


#28

@lpugoy, Is there any news about the rpm lock error, @ftonello mentioned? I can’t install insync because of this.


#29

@Dener: No work on this issue yet, apologies. The install should still succeed though, it will just take a while. Were you unable to run Insync after installing it and running into the rpm lock error?


#30

I were waiting for 5 minutes, it hangs. Then stopped installation with Ctrl+C. After that I tried to launch insync, but nothing happens:

14:28:04 $ insync start 
14:28:08 $ insync get_status
 Insync doesn't seem to be running. Start it first.

#31

@Dener: The output of insync get_status suggests that Insync was installed though. If Insync was not installed then the error would have been that the insync command was not found. There is likely an error when trying to start Insync. Please try running insync start --no-daemon to show if there are any error messages.


#32

I used the YUM repository (Fedora) and it works.


#33

I understand that it was installed. The problem is that I am not able to start it. Thanks for --no-daemon option. Now it’s clear what’s the problem:

$ insync start --no-daemon
Exception in thread GeventThread:
Traceback (most recent call last):
  File "threading.py", line 813, in __bootstrap_inner
  File "ideskutils/gevent_init.py", line 47, in run
  File "gevent/__init__.py", line 40, in <module>
  File "gevent/core.py", line 7, in <module>
  File "gevent/core.py", line 6, in __bootstrap__
ImportError: libevent-2.0.so.5: невозможно открыть разделяемый объектный файл: Нет такого файла или каталога

I have only libevent 2.1 in the system available. Will try to install 2.0 version as addition. Why has it passed dependencies check?


#34

Installed libevent 2.0, now looks like Insync is working. Thanks for support!


#35

The same thing happened to me. The rpm Insync package should declare the required dependencies versions. Also, right now there’s no official libevent-2.0 package on opensuse tumbleweed, I don’t like installing older versions from untrusted repositories and building libevent-2.0 myself just to be able to use insync it’s too much.

In general insync for linux is in very bad shape. I believe that as paying customers we deserve better packaging and support.


#36

@cesarizu: Apologies for the trouble. This is a compatible libevent library you can add to /usr/lib/insync as a workaround: https://drive.google.com/file/d/0B7O9tPLwuUymYm5Ba3lpXzh1OGM/view. We aim to resolve this in the next release.


#37

I’m trying to update insync but now I get the following error:

(1/1) Installing: insync-1.3.14.36131-fc21.x86_64 .....................................................................................................[error]
Installation of insync-1.3.14.36131-fc21.x86_64 failed:
Error: Subprocess failed. Error: RPM failed: error: unpacking of archive failed: cpio: lstat
error: insync-1.3.14.36131-fc21.x86_64: install failed

It’s been long time since I could just use Insync on linux and not worry about all this stuff… please give it some love, seems like lately it has been getting worse.


#38

Note that the version says “fc21” even though I’m using the fedora 25 repository.