Selective sync doesn't apply

I’ve a link to another GDrive hosted directory. This link I want to exclude from sync.


/other/xxx/@adm --> /adm/

So, I unchecked /other/xxx/@adm on the selective sync page. But @adm get’s synced!

This is really annoying. This topic is highly related to Ignore list doesn't apply.

Will be tagging our engineer @lpugoy and he will get back to you :smile:

@normenmueller: Just to confirm, do you mean that:

  • /adm is a folder that is under an account, for example account1@gmail.
  • /other/xxx@adm is on a separate account, like account2@gmail.
  • You unchecked /other/xxx@adm in the selective sync settings of account2, but it is still synced under account2.
  • Does /adm also sync under account1?


account2@gmail/misc/@adm --> account1@gmail/adm

but I also have this case (all in one account)

account2@gmail/misc/@adm --> account1@gmail/adm

I have the feeling the ignore list has to be improved a lot to accept regex, relative paths, and there like.

In addition it would be awesome to have a case by case option to tell Isync to handle links as such, i.e., to not sync the link target but just the link. But, clearly, only case by case. Sometimes one wants to sync the link target, sometimes just the link itself.

Best, /nm

@normenmueller: I wasn’t able to reproduce your issue unfortunately. Please send your logs to for investigation: How to find the log files.

I will search for the logs.

But, how would you put this entry in the ignore list? misc/@adm or the full path?

@normenmueller: If you unchecked the folder in the selective sync settings then there should be no need to put it in the ignore list as well. Also the ignore list is only for new entries, and because @adm already exists then the ignore list would not have an effect.

Don’t get it. Let’s assume I have the following structure


Now I want to add a new sub-directory (or a link to another directory) to dir1. As soon as I create such a sub-directory, it gets synced.

So what happens if I uncheck this new directory … which obviously I can only do AFTER creation and thus AFTER sync.

I even tried to enter the full path of the to be created sub-directory. This also didn’t work. The new sub-directory got synced.

BTW, why don’t you just enable a power user feature and have a ignore file per directory? Like Git utilizing .gitignore you could have something like .insyncignore. That would make things much easier. This also relates to How to find the log files

@normenmueller: You seem to be describing the selective sync functionality, not the ignore list. Selective sync can be thought of as a way to manage syncing of existing files, while the ignore list is used to manage syncing of new files that are added to your Drive account or to your local folder. You are correct in that the new directory will only be added to the selective sync interface after it has been synced. If you uncheck it then it will be retained in your Drive account but removed in your local folder. Implementing path based ignore settings is a common request and we are considering it.

I have a directory My Drive/foo in the Google Drive, synched on two computers, one a laptop with diskspace running out. I want to retain foo in the Google Drive and delete it on the laptop. I went to Manage->Selective Sync and unchecked foo. It didn’t disappear from my laptop. Then I moved foo to another directory on my laptop and it disappeared from the Google Drive.

How do I arrange it so that deleting a file on my laptop has no effect on the Google Drive?


Update: if I instead right-click foo on my laptop and choose ISync->Selectively Unsync, it seems to have the desired effect.

What is the intended effect of unchecking a box in Manage->Selective Sync? The same as ISync->Selectively Unsync, or not?

General comment: you have How-To docs but it would be nice if they explained semantics, as in this case.


@David_Gillman: They should have had the same effect. I’ll take a look at this, please send your logs to for investigation: How to find the log files. If possible please include in your mail the name of the folder that wasn’t deleted.