(Solved) Insync doesn't start on Xenial (16.04)


insync no longer starts on Ubuntu 16.04 LTS (Xenial).

uname -a:
Linux leopard 4.4.0-135-generic #161-Ubuntu SMP Mon Aug 27 10:45:01 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

lsb_release -a:
$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 16.04.5 LTS
Release: 16.04
Codename: xenial

Starting insync with “insync start --no-daemon” shows the following:

$ insync start --no-daemon INFO 2018-09-14 00:09:58,966 [__main__insync__:main:98] insync version: INFO 2018-09-14 00:09:58,968 [__main__insync__:main:99] client created <ideskmain.client.Client object at 0x7f4e6e3d6790> INFO 2018-09-14 00:09:58,969 [unix_socket_server_portable:start:49] unix socket server thread start INFO 2018-09-14 00:09:58,970 [__main__insync__:main:107] starting client INFO 2018-09-14 00:09:58,978 [fswatch:_start:532] LinuxFSWatcher._start INFO 2018-09-14 00:09:58,981 [fswatch:_pull_loop:267] Inotify loop enter libpng warning: iCCP: known incorrect sRGB profile [0914/000959.008449:WARNING:stack_trace_posix.cc(699)] Failed to open file: /tmp/.glfMACpf (deleted) Error: No such file or directory libGL error: No matching fbConfigs or visuals found libGL error: failed to load driver: swrast Received signal 11 SEGV_MAPERR 0000000001c5 #0 0x7f4e72d8c95f <unknown> #1 0x7f4e717be85d <unknown> #2 0x7f4e72d8ce6e <unknown> #3 0x7f4eb18e1390 <unknown> #4 0x7f4e39089321 <unknown> #5 0x7f4e71820949 <unknown> #6 0x7f4e7180b9a8 <unknown> #7 0x7f4e738c8add <unknown> #8 0x7f4e71b0f411 <unknown> #9 0x7f4e71b10c05 <unknown> #10 0x7f4e73d7eea7 <unknown> #11 0x7f4e755b5c65 <unknown> #12 0x7f4e72df5315 <unknown> #13 0x7f4e72df06b0 <unknown> #14 0x7f4eb18d76ba start_thread #15 0x7f4eb0ce341d clone r8: 0000000000000000 r9: 0000000000000000 r10: 00007f4df6b8c788 r11: 0000000000000000 r12: 000000000000010d r13: 000000000000000a r14: 000000000000009a r15: 000000000000000a di: 00000000014e9164 si: 0000000000000001 bp: 00007f4e3a7fb590 bx: 00000000014e1350 dx: 0000000000000019 ax: 00000000014e9150 cx: 0000000000000001 sp: 00007f4e3a7fb530 ip: 00007f4e39089321 efl: 0000000000010206 cgf: 0000000000000033 erf: 0000000000000004 trp: 000000000000000e msk: 0000000000000000 cr2: 00000000000001c5 [end of stack trace] Calling _exit(1). Core file will not be generated.


I don’t have permission to delete the topic even though I created it so I am just replying. After filing this I found another thread with the same problem and with a solution that worked. See [After upgrade from 1.4.9 to 1.5.1, Insync fails to start]


Hey @le_avion,

Good to know you were able to find a solution! :slight_smile: