Ubuntu 16.10 with xfce. No tray icon


#5

@lpugoy, @jaduenas
The tray icon shows up when insync is started with sudo. But it messes up file ownership and permissions. Is there a way to start insync with sudo that does not make owner and group root:root for the synced files?


#6

@btnadiga: I see. I don’t believe that’s possible unfortunately. One workaround could be to set the setgid flag on your Insync folder so that files and folders created there would inherit its group ID (https://en.wikipedia.org/wiki/Setuid#setuid_and_setgid_on_directories). The owner would still be root though. Have you tried testing on a different Linux user account if the tray icon would be shown for it?


#7

@lpugoy Today by chance, I discovered in my temporary folder this:
/tmp/sni-qt_insync_2745-gms6II/icons
Inside there is nothing, should the icons be here??
I hope this can help you to discover the issue.
Thank you.


#8

Confirmed here, I’m using Fedora 25 and suddenly it’s gone (the tray icon).

I tried run this insync start --no-daemon

and here’s the output from terminal

QGtkStyle could not resolve GTK. Make sure you have installed the proper libraries.
/home/aditia/.python-eggs/gevent-0.13.8-py2.7-linux-x86_64.egg-tmp/gevent/core.so:7: UserWarning: libevent version mismatch: system version is '2.0.22-stable' but this gevent is compiled against '2.0.21-stable'
  4�
       ���=
                  r��
                            ;�Ygye
                                                   D��N�W�
                                                                     V~
QSystemTrayIcon::setVisible: No Icon set
"sni-qt/32315" WARN  05:54:09.647 void StatusNotifierItemFactory::connectToSnw() Invalid interface to SNW_SERVICE 
INFO     2016-12-25 05:54:09,981 [__init__:info:1622] insync version: 1.3.13.36129
INFO     2016-12-25 05:54:09,983 [__init__:info:1622] client created <ideskmain.client.Client object at 0x7f6c2a65c6d0>
INFO     2016-12-25 05:54:09,984 [__init__:info:1622] unix socket server thread start
INFO     2016-12-25 05:54:09,985 [__init__:info:1622] starting client
INFO     2016-12-25 05:54:09,997 [__init__:info:1622] LinuxFSWatcher._start
INFO     2016-12-25 05:54:09,999 [__init__:info:1622] Inotify loop enter
libpng warning: iCCP: Not recognizing known sRGB profile that has been edited
INFO     2016-12-25 05:54:10,084 [__init__:info:1622] Syncing GDUser(id=u'108254296589530646728', email=u'aditia.ap@gmail.com', name=u'Aditia A. Pratama').
INFO     2016-12-25 05:54:10,697 [__init__:info:1622] watch origin: /home/aditia/drive
INFO     2016-12-25 05:54:11,086 [__init__:info:1622] GDUser(id=u'108254296589530646728', email=u'aditia.ap@gmail.com', name=u'Aditia A. Pratama') (existing) is now being synced.
INFO     2016-12-25 05:55:12,039 [__init__:info:1622] No updater available.

#9

@aditiavfx: Apologies for not replying sooner. What desktop environment are you using in Fedora 25? If you’re using GNOME Shell are you using TopIcons or TopIcons Plus?


#10

I’m using fedora 25 with xfce desktop environment, already installed sni-qt and sni-qt:i386

My other systray apps icon are fine, only insync at the moment which doen’t work.

Also my profil picture in insync apps also missing, showing only blue picture.


#11

@aditiavfx: Hmm, it worked in my test though. Did you try the suggestions in this thread? Also do you have the “Notification Area” item in your panel?


#12

@lpugoy yes, I have, it’s weird because it was working fine. I’ve tried many things from this forum already, but nothing solves. I also has empty sni-qt_insync in tmp, Does that normally happen?


#13

@aditiavfx: I see. When I checked I saw that I actually didn’t have sni-qt installed, please check if that works for you too. But the tray icon was still shown in my case when I installed sni-qt. There is a folder inside the /tmp/sni-qt_insync... folder named icons but that was empty.

If that didn’t work please send a list of installed packages so I can try to replicate your setup. You can get it by running dnf list installed. To prevent posting a very long message in this thread you can attach the output to a file instead.


#14

Hi,

same issue there with ubuntu 16.10. Finally, is there a workaround to solve this with ubuntu 16.10?

I can shaare my desktop if needed.

Regards


#15

Same issue on Fedora 25 KDE, at some point stopped working. sni-qt is installed, but the suggested package xembed-sni-proxy is not available in RPMfusion nor in Fedora repos (outdated/absolete package?)

There are following lines in out.txt:

Current thread 0x00007f27dc8ed700:
File “main__insync.py”, line 117 in main
File “main__insync.py”, line 180 in
File “main.py”, line 128 in
File “”, line 6 in
QSystemTrayIcon::setVisible: No Icon set

It happened quite some time ago, so I can’t remember at what point it stopped working. If I re-install InSync it works until the reboot.


#16

@Gautier_Avril: Please confirm if you have flatpack installed with the steps shown here: No tray icon in lastest version. If you do and you are not using it please try removing the folder /home/USERNAME/.local/share/flatpak/exports/share/icons/hicolor.


#17

I never installer flatpak, also I don’t have this folder on my computer.


#18

@Gautier_Avril: I see. Did you try running the script in the forums post? What is the output?


#19

not sure about which script has to be launch.

Here is the --no-daemon output. Hope it helps.

insync start --no-daemon
INFO 2017-04-11 11:38:33,682 [init:info:1610] insync version: 1.3.14.36131
INFO 2017-04-11 11:38:33,686 [init:info:1610] client created <ideskmain.client.Client object at 0x29f4ad0>
INFO 2017-04-11 11:38:33,687 [init:info:1610] unix socket server thread start
INFO 2017-04-11 11:38:33,688 [init:info:1610] starting client
INFO 2017-04-11 11:38:33,695 [init:info:1610] LinuxFSWatcher._start
INFO 2017-04-11 11:38:33,697 [init:info:1610] Inotify loop enter

(insync:11588): IBUS-WARNING **: Unable to connect to ibus: Impossible de se connecter : Aucun fichier ou dossier de ce type
INFO 2017-04-11 11:38:33,884 [init:info:1610] Syncing GDUser(id=u’bbbbbbbbbbbbbbbbbbbb’, email=u’xxx.xxx@yyy.com’, name=u’xxx xxx’).
INFO 2017-04-11 11:38:34,231 [init:info:1610] watch origin: /home/xxx/Documents/googledrive
INFO 2017-04-11 11:38:36,454 [init:info:1610] GDUser(id=u’115684160488100737121’, email=u’xxx.xxx@yyy.com’, name=u’xxx xxx’) (existing) is now being synced.

(insync:11588): Gtk-CRITICAL **: IA__gtk_widget_style_get: assertion ‘GTK_IS_WIDGET (widget)’ failed
(insync:11588): Gtk-CRITICAL **: IA__gtk_widget_style_get: assertion ‘GTK_IS_WIDGET (widget)’ failed
(insync:11588): Gtk-CRITICAL **: IA__gtk_widget_style_get: assertion ‘GTK_IS_WIDGET (widget)’ failed
(insync:11588): Gtk-CRITICAL **: IA__gtk_widget_style_get: assertion ‘GTK_IS_WIDGET (widget)’ failed
(insync:11588): Gtk-CRITICAL **: IA__gtk_widget_style_get: assertion ‘GTK_IS_WIDGET (widget)’ failed
(insync:11588): Gtk-CRITICAL **: IA__gtk_widget_style_get: assertion ‘GTK_IS_WIDGET (widget)’ failed
(insync:11588): Gtk-CRITICAL **: IA__gtk_widget_style_get: assertion ‘GTK_IS_WIDGET (widget)’ failed


#20

Hi,

I updated to ubuntu 17.04, still not working.

Gautier


#21

@Gautier_Avril: Apologies for not replying sooner. Regarding the script, this is what I meant:

from PySide.QtGui import QApplication, QIcon, QSystemTrayIcon
import sys, signal

app = QApplication(sys.argv)
QIcon.setThemeName('hicolor')
icon = QIcon.fromTheme('insync-normal')
tray = QSystemTrayIcon(icon)
tray.show()
signal.signal(signal.SIGINT, signal.SIG_DFL)

for path in QIcon.themeSearchPaths():
        print "%s/%s" % (path, QIcon.themeName())

sys.exit(app.exec_())

Please copy it to a file like /tmp/script.py then run it with /usr/lib/insync/py /tmp/script.py then paste the output here. You can then stop it with ctrl+c.

Additionally please try the test build for Ubuntu 17.04 available here: New Insync version: 1.3.15.


#22

Concerning the python script. Here is the output :

/usr/share/ubuntu/icons/hicolor
/usr/local/share/icons/hicolor
/usr/share/icons/hicolor
/var/lib/snapd/desktop/icons/hicolor
:/icons/hicolor

Please note that the insync icon is present when I run the script (but I get an error when I click on it).

I’m on ubuntu 17.04 and I didn’t installed the test build yet.


#23

OK,

Everything (including the icon) is working with the test build with ubuntu 17.04

Regards


#24

@Gautier_Avril: Thanks for the feedback. Let us know if you encounter any more issues.