Workaround for Insync not starting (segmentation fault) after Fedora 34 libxkbcommon update

Same problem. Urgently waiting for a fix as I’d rather not make manual modifications to files that are managed by the OS’ package manager.

1 Like

Hi @linuser :slight_smile: Thanks so much for sharing the workaround. I’ve raised this issue to our Linux team so we can work on deploying a fix.

1 Like

Thanks for the workaround, @linuser.

The sooner this is fixed at Insync’s end, the better.

Thank you very much for sharing this. I spoke to support via chat, they do not know about it.

We really need Fedora 34 support fixed as soon as possible

Just to report same issue with OpenSuse Thumbleweed, Workaround fix the issue. Thanks @linuser

2 Likes

Same here (Tumbleweed - fix).

1 Like

Hi all-- our Linux team is working on the Fedora 34 build. I’ll update this thread as soon as the version is available.

Thank you!

1 Like

The same problem occurs on Manjaro 21.0.4, and yes - workaround fixed it.

1 Like

v3.3.10.40961 just came in through the InSync Fedora repo. Can confirm the issue is fixed.

I’m happy that the issue is now fixed, but I’m honestly a bit disappointed that the fix to an issue that broke the entire application took 2 weeks to be released. Not being able to use a file sync application for an entire 2 weeks (without making manual system modifications) is pretty bad.

I generally like the application and appreciate the work that is put into it, but I really hope issues like these can be prioritised more in future.

@RobinJ1995 If you did the workaround like a real linux user you wouldn’t of had to wait. :wink:

Hello everyone!! Please give this Fedora 34 build a try:
https://d2t3ff60b2tol4.cloudfront.net/builds/insync-3.3.10.40961-fc34.x86_64.rpm

Let me know how it goes by replying to this thread :slight_smile: Thank you!

@miamoran Confirmed fixed. Got the update from the repo yesterday.

Fedora 34 KDE

Unless you’re a Linux user with a full-time job that doesn’t have time to “fix” other developers’ applications, and to then possibly have to fix their own system later because they stupidly made manual modifications to libraries that were managed by the package manager :wink: When you pull tricks like these there’s always a good possibility that you end up causing problems down the line because your package manager realises the files it manages are not in the state it expects them to be in.

Works. Fedora 34 Gnome.

It’s a 3 line fix, so you are just lazy in my opinion. Dnf is smart enough to replace files.

I have installed insync-3.3.10.40961-fc34.x86_64 and can verify that it fixes the issue, and seems to work fine now on Fedora 34.

Thank you to the Insync team for fixing this!

1 Like

Im using Fedora 34. Download version 3.4 and still not working well. Thanks for the quick response and looking fordward to this issue to be corrected. :slight_smile:

@yerch82 Thank you for cross-posting! I have responded to the other thread :slight_smile:

Hey, everyone! We’ve released a fix for this error. Kindly download the latest version of our app here and let us know if it works!