[1.2.8] insync-thunar fails to create private links


I’m running these versions on Xubuntu 15.04:


insync-thunar fails to copy private links, always generating the same error notification, for instance:

No matter which file I use, it always fails with exactly the same error message.

I can copy the links using GDrive’s web interface, for instance, for the same file that insync-thunar failed to create the private link:

Please fix this, otherwise insync-thunar is unusable.

Issue 918 seems resolved, since notifications are being shown.

This bug renders insync-thunar unusable.

EDIT: I uploaded a tarball of my ~/.config/Insync here

EDIT 2: I rebooted the laptop after upgrading insync and insync-thunar, just in case, but the bug persisted.

[Xubuntu 15.04] insync not showing notifications
[Xubuntu 15.04] insync not showing notifications
[1.2.8 on Xubuntu 15.04] insync taking an unusually long time to complete initial syncing
[1.2.8 on Xubuntu 15.04] How do we downgrade to 1.2.7?

Exactly the same error:

Here’s the console output:

paulo@monk:~/tmp$ insync start --no-daemon
INFO     2015-05-05 06:45:10,346 [__init__:info:1614] insync version:
INFO     2015-05-05 06:45:10,350 [__init__:info:1614] client created <ideskmain.client.Client object at 0x7fb8717b8810>
INFO     2015-05-05 06:45:10,352 [__init__:info:1614] unix socket server thread start
INFO     2015-05-05 06:45:10,353 [__init__:info:1614] starting client
INFO     2015-05-05 06:45:10,369 [__init__:info:1614] LinuxFSWatcher._start
INFO     2015-05-05 06:45:10,372 [__init__:info:1614] Inotify loop enter
/usr/lib/insync/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /usr/lib/x86_64-linux-gnu/libproxy.so.1)
Failed to load module: /usr/lib/x86_64-linux-gnu/gio/modules/libgiolibproxy.so
INFO     2015-05-05 06:45:10,527 [__init__:info:1614] Syncing GDUser(id=u'108004781291236804203', email=u'marcelpaulo@gmail.com', name=u'Paulo Marcel Coelho Arag\xe3o').
INFO     2015-05-05 06:45:12,279 [__init__:info:1614] watch origin: /home/paulo/Google Drive
INFO     2015-05-05 06:45:12,651 [__init__:info:1614] GDUser(id=u'108004781291236804203', email=u'marcelpaulo@gmail.com', name=u'Paulo Marcel Coelho Arag\xe3o') (existing) is now being synced.
INFO     2015-05-05 06:45:12,901 [__init__:info:1614] state: SYNCING
INFO     2015-05-05 06:46:13,120 [__init__:info:1614] No updater available.
ERROR    2015-05-05 06:47:12,778 [__init__:error:1588] While creating private link.
Traceback (most recent call last):
  File "ideskmain/clientmenuitems.py", line 513, in __get_private_link
  File "idesksyncer/shareapi.py", line 168, in create_private_link
  File "idesksyncer/shareapi.py", line 85, in insert_permission
  File "idesksyncer/gdstate.py", line 531, in insert_permission
  File "idesksyncer/gdstate.py", line 793, in _to_contact
AttributeError: 'PermissionResource' object has no attribute 'emailAddress'

and insync never seems to finish syncing:


This has been addressed in 1.2.9.


Apologies, @lpugoy, for not replying earlier: I didn’t get the usual email notification that a comment had been published in this thread.

I can confirm, have just tested, that 1.2.9 solved this issue: private links are not only being copied, but notifications generated too.

Thank you so much for the swift fix !