After logging in Google in browser, nothing happens


in Linux (Fedora 30) Insync starts properly. I select “Google Drive” in the insync client. The browser (Firefox) launches, asks for a login in a Google account. I then login and give permissions to Insync to use my Drive folder. Then Firefox loads a page “Connecting to Insync…” and remains stucked.

1 Like

adblocker? or something else?
can you try another browser?

I have disabled adblocker and used other browsers with no luck.

Cross posting from here: Are you on Linux OpenSUSE?

If so, can you please run the following commands:

sudo mkdir -p /etc/pki/tls/certs
sudo ln -s /etc/ssl/ca-bundle.pem /etc/pki/tls/certs/ca-bundle.crt

You are more than welcome to post the output here. Otherwise, shoot us an email at with the output and the link to this post. :slight_smile:

I did this, being on OpenSuse 15.1. No output, just the prompt.


With version*19 everything works. Thanks.

1 Like

Thank you for the update, @Rainer_Lodemann! :slight_smile:

I continue to not log in, even with the last 19 version.

So FYI I had this issue for several hours too and I will share how I solved it for myself in hopes it might help someone else, though I don’t know how. I have a rather uncommon setup - Windows default firewall set with a DEFAULT DENY OUTBOUND rule. Only programs I whitelist can access the network/internet. I did however whitelist inSync and never had issues with this in the past.

When trying to log into inSync 3 for the first time I could not login, the oauth page just sat at the “connecting to insync” page like OP. However I disabled the firewall momentarily and boom, login successful, app working (kind of). The app still won’t sync when I have the firewall on, but I suspect this is a deeper issue as I see successful connections to some Google and Digital Ocean IPs from inSync.

But in case anyone else has an outbound firewall, inSync is doing something funky with networking (maybe using a service of some sort or Microsoft BITS or something?) which may require disabling the firewall.

Since no one from insync seems to will help me in making insync 3.0.19 operative in Linux Fedora 30, I have tried to downgrade to Insync 1.5.7. It does not work in graphical mode, but in headless mode works well. In particular, it successed in logging in my account by browser as reported in attached image.

I am still waiting… please fix it (or reintroduce “Alternative login” option!!!).

Hi @artu72,

My apologies for the delayed response! Can you let me know if this login issue persists on 3.0.21? New Insync version: 3.0.21