After upgrade from 1.4.9 to 1.5.1, Insync fails to start


#21

Same problem here but, i suspect, different cause. I am on Kubuntu Trusty and NO Nvidia drivers (Radeon free drivers). Meanwhile, i downgraded Insync to version 1.4.9.37127-trusty_amd64 and all is working again. This is the relevant output when trying to start version 1.5.1:

/usr/lib/insync/QtWebEngineProcess: /usr/lib/insync/libdbus-1.so.3: no version information available (required by /usr/lib/insync/libQt5WebEngineCore.so.5)
libpng warning: iCCP: known incorrect sRGB profile
*** Error in `./insync’: munmap_chunk(): invalid pointer: 0x00007ff4887f6f90 ***
Received signal 6
#0 0x7ff4c721d95f
#1 0x7ff4c5c4f85d
#2 0x7ff4c721de6e
#3 0x7ff4ec9ac330
#4 0x7ff4ebce3c37 gsignal
#5 0x7ff4ebce7028 abort
#6 0x7ff4ebd202a4
#7 0x7ff4ebd2b007
#8 0x7ff4d5e2b588 std::_Hashtable<>::_M_insert_unique_node()
#9 0x7ff4c7828e04 std::_Hashtable<>::_M_insert<>()
#10 0x7ff4c78295ed
#11 0x7ff4c7829c50
#12 0x7ff4c7cc4feb
#13 0x7ff4c7cc7178
#14 0x7ff4c7cc76e2
#15 0x7ff4c5de473f
#16 0x7ff4c659bcfd
#17 0x7ff4c65b6f00
#18 0x7ff4c65b709f
#19 0x7ff4c79af3e3
#20 0x7ff4c721e069
#21 0x7ff4c723fb10
#22 0x7ff4c724056d
#23 0x7ff4c7240857
#24 0x7ff4c7242cb1
#25 0x7ff4c72625ff
#26 0x7ff4c639782b
#27 0x7ff4c6397cdb
#28 0x7ff4c7286308
#29 0x7ff4c72816b0
#30 0x7ff4ec9a4184 start_thread
#31 0x7ff4ebdab03d clone
r8: 3039663666373838 r9: 0000000000000000 r10: 0000000000000008 r11: 0000000000000206
r12: 00007ff4887f6bc0 r13: 0000000000000007 r14: 0000000000000051 r15: 0000000000000007
di: 0000000000000bb1 si: 000000000000102d bp: 00007ff4887f6db0 bx: 0000000000000051
dx: 0000000000000006 ax: 0000000000000000 cx: 00007ff4ebce3c37 sp: 00007ff4887f6a18
ip: 00007ff4ebce3c37 efl: 0000000000000206 cgf: 0000000000000033 erf: 0000000000000000
trp: 0000000000000000 msk: 0000000000000000 cr2: 0000000000000000
[end of stack trace]
Calling _exit(1). Core file will not be generated.


#22

Is Insync support working on this problem?


#23

Yes, I also would like to know that.

It would be nice to find and remove older Nvidia-related libraries, but why 1.4.9 didn’t suffer using my current setup, but 1.5.1 all of a sudden broke?

I would appreciate the support’s further response. Thank you in advance.


#24

@Kurt_Ko is investigating :slight_smile:


#25

In the meantime, some of us need 1.4.9 for the trusty distro.


#26

Here is the link for the Trusty deb:

http://s.insynchq.com/builds/insync_1.4.9.37127-trusty_amd64.deb


#27

On installation there was one error message.

Gtk-Message: 12:48:31.046: GtkDialog mapped without a transient parent. This is discouraged.
Insync doesn’t seem to be running. Start it first.


#28

I found this in .config/Insync/out.txt.

libGL error: unable to load driver: r600_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: r600
libGL error: unable to load driver: r600_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: r600
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast
Unrecognized OpenGL version
Unrecognized OpenGL version


#29

Hey everyone!

You can download the latest builds below. :slight_smile:

Ubuntu 17.10/18.04 6
Ubuntu 16.04 15
Ubuntu 14.04 3
Fedora 25+ 3
Debian 9 4
Debian 8 1
CentOS 7 1

Let us know if this works for you!
Cheers!


#30

Not working for me. Same errors i reported above.


#31

same for me. Nothing solved. Using ubuntu 14.04.


#32

Hey @Marco_Antonucci and @Dirk_De_Muynck,

Have you guys downloaded the latest build in my post above? :slight_smile:


#33

Yes. Same as reported before:

*** Error in `./insync’: munmap_chunk(): invalid pointer: 0x00007f31637fcf90 ***
Received signal 6
#0 0x7f319983595f
#1 0x7f319826785d
#2 0x7f3199835e6e
#3 0x7f31befaa330
#4 0x7f31be2e1c37 gsignal
#5 0x7f31be2e5028 abort
#6 0x7f31be31e2a4
#7 0x7f31be329007
#8 0x7f31a86e7588 std::_Hashtable<>::_M_insert_unique_node()
#9 0x7f3199e40e04 std::_Hashtable<>::_M_insert<>()
#10 0x7f3199e415ed
#11 0x7f3199e41c50
#12 0x7f319a2dcfeb
#13 0x7f319a2df178
#14 0x7f319a2df6e2
#15 0x7f31983fc73f
#16 0x7f3198bb3cfd
#17 0x7f3198bcef00
#18 0x7f3198bcf09f
#19 0x7f3199fc73e3
#20 0x7f3199836069
#21 0x7f3199857b10
#22 0x7f319985856d
#23 0x7f3199858857
#24 0x7f319985acb1
#25 0x7f319987a5ff
#26 0x7f31989af82b
#27 0x7f31989afcdb
#28 0x7f319989e308
#29 0x7f31998996b0
#30 0x7f31befa2184 start_thread
#31 0x7f31be3a903d clone
r8: 3039666366373336 r9: 0000000000000000 r10: 0000000000000008 r11: 0000000000000206
r12: 00007f31637fcbc0 r13: 0000000000000007 r14: 0000000000000051 r15: 0000000000000007
di: 0000000000001ac5 si: 0000000000001b24 bp: 00007f31637fcdb0 bx: 0000000000000051
dx: 0000000000000006 ax: 0000000000000000 cx: 00007f31be2e1c37 sp: 00007f31637fca18
ip: 00007f31be2e1c37 efl: 0000000000000206 cgf: 0000000000000033 erf: 0000000000000000
trp: 0000000000000000 msk: 0000000000000000 cr2: 0000000000000000
[end of stack trace]
Calling _exit(1). Core file will not be generated.


#34

My package manager found a version 1.5.2.37346, but it still fails to start on Ubuntu 16.04. Here’s the output from insync start --no-daemon:

** (insync:7886): WARNING **: Error retrieving accessibility bus address: org.freedesktop.DBus.Error.ServiceUnknown: The name org.a11y.Bus was not provided by any .service files
INFO 2018-09-20 12:32:45,286 [main__insync:main:105] insync version: 1.5.2.37346
INFO 2018-09-20 12:32:45,288 [main__insync:main:106] client created <ideskmain.client.Client object at 0x7fefc5805cd0>
INFO 2018-09-20 12:32:45,289 [unix_socket_server_portable:start:49] unix socket server thread start
INFO 2018-09-20 12:32:45,289 [main__insync:main:114] starting client
INFO 2018-09-20 12:32:45,294 [fswatch:_start:532] LinuxFSWatcher._start
INFO 2018-09-20 12:32:45,298 [fswatch:_pull_loop:267] Inotify loop enter
libpng warning: iCCP: known incorrect sRGB profile
OpenGL Warning: glXCreatePbuffer not implemented by Chromium
[7886:7955:0920/123245.401495:ERROR:gl_surface_glx_qt.cpp(186)] glXCreatePbuffer failed.
Received signal 11 SEGV_MAPERR 000000000000
#0 0x7fefcad8c95f
#1 0x7fefc97be85d
#2 0x7fefcad8ce6e
#3 0x7ff000b34390
#4 0x7fefc982008d
#5 0x7fefc980b828
#6 0x7fefcb8c8add
#7 0x7fefc9b0f411
#8 0x7fefc9b10c05
#9 0x7fefcbd7eea7
#10 0x7fefcd5b5c65
#11 0x7fefcadf5315
#12 0x7fefcadf06b0
#13 0x7ff000b2a6ba start_thread
#14 0x7feffff3641d clone
r8: 00007fef50002b50 r9: 0000000000000000 r10: 0000000000000059 r11: 0000000000000000
r12: 00007fef797f9770 r13: 00007fef797f9a40 r14: 00007fefc981ffe0 r15: 00007fef797f9930
di: 0000000000000000 si: 0000000002ae0ba0 bp: 00007fef797f9750 bx: 00007fef500054e0
dx: 0000000000000021 ax: 00007fefcfec0ad0 cx: 00007fef797f9590 sp: 00007fef797f9590
ip: 00007fefc982008d efl: 0000000000010206 cgf: 002b000000000033 erf: 0000000000000004
trp: 000000000000000e msk: 0000000000000000 cr2: 0000000000000000
[end of stack trace]
Calling _exit(1). Core file will not be generated.

This is in a virtual machine, so it shouldn’t have any NVIDIA drivers.

libwayland-egl.so.1 (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/libwayland-egl.so.1
libfltk_gl.so.1.1 (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/libfltk_gl.so.1.1
libcogl.so.20 (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/libcogl.so.20
libQt5OpenGL.so.5 (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/libQt5OpenGL.so.5
libGL.so.1 (libc6,x86-64) => /var/lib/VBoxGuestAdditions/lib/libGL.so.1
libGL.so.1 (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/mesa/libGL.so.1
libEGL.so.1 (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/mesa-egl/libEGL.so.1

#35

Hi @Marco_Antonucci!
Can you try doing an upgrade of your system packages ‘sudo apt-get update && sudo apt-get upgrade’?
If it still doesn’t work, try installing the libdbus-1-3 package ‘sudo apt-get install libdbus-1-3’

Let me know what happens.

Thanks!


#36

Hi @Richard_Blum!

Can you send me the output of ‘sudo apt list --installed | grep mesa’?

Thanks!


#37

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

libegl1-mesa/xenial-updates,now 18.0.5-0ubuntu0~16.04.1 amd64 [installed,automatic]
libgl1-mesa-dri/xenial-updates,now 18.0.5-0ubuntu0~16.04.1 amd64 [installed,automatic]
libgl1-mesa-glx/xenial-updates,now 18.0.5-0ubuntu0~16.04.1 amd64 [installed,automatic]
libglapi-mesa/xenial-updates,now 18.0.5-0ubuntu0~16.04.1 amd64 [installed,automatic]
libgles2-mesa/xenial-updates,now 18.0.5-0ubuntu0~16.04.1 amd64 [installed,automatic]
libglu1-mesa/xenial,now 9.0.0-2.1 amd64 [installed,automatic]
libwayland-egl1-mesa/xenial-updates,now 18.0.5-0ubuntu0~16.04.1 amd64 [installed,automatic]
mesa-utils/xenial,now 8.3.0-1 amd64 [installed,automatic]


#38

Tests done with system up to date and libdbus-1-3 already installed.


#39

Can you try removing/purging the following packages?
libegl1-mesa
libgl1-mesa-dri
libgl1-mesa-glx
libgles2-mesa
libglu1-mesa
mesa-utils

Let me know what happens.


#40

Can you send me the output of ‘ls /usr/lib/x86_64-linux-gnu/’?