Apt repository errors [1.4.8.37107] [Linux Mint 19]

Receiving apt errors after installing Insync [1.4.8.37107] on a fresh Linux Mint 19 install. Assuming that something needs to be updated in the repository as Mint 19 was just released? I’m using the version of Insync provided for Ubuntu 18.04.

Failed to fetch http://apt.insynchq.com/mint/dists/tara/InRelease  403  Forbidden [IP: 143.204.29.92 80]
The repository 'http://apt.insynchq.com/mint tara InRelease' is not signed.

EDIT: insync-nemo also appears to be missing from the repository.

1 Like

I’m also having this issue.

Does the Ubuntu 18.04 version work fine?

Insync seems to be working fine, although the integration with nemo isn’t there so files don’t have the sync status emblem. I did go into Software Sources and disable the Insync repository to stop getting apt errors every time the system checks for updates. Hopefully support will let us know when it’s fixed and then I’ll re-enable it.

1 Like

I am also getting the same error. Insync seems to be working but I have on integration in nemo

Ditto. Insync works, no Nemo integration, repo and keys are wrong.

Seems like a minor thing but searching a bitm this has been a problem with Ubuntu bionic since at least April. What’s up, Insync?

1 Like

If I remember correctly, the filename of the .deb download for bionic still references artful aardvark.

Hey guys–

Sorry for the trouble. Tagging our engineer @Kurt_Ko for assistance.

1 Like

Good news! At least as far as Mint 19 is concerned, the solution is simply to use the ubuntu bionic repository, then updates go through. Also, nemo integration seems to work, even though the nemo package is labeled for ubuntu precise. There isn’t a mint tara repository yet, but there doesn’t seem to be a need.

FWIW, the debian stretch repository’s version worked out of the box.

Did you go in and manually add a repository for bionic? B/c I used the bionic .deb to install but then get the apt errors referencing tara.

Nemo integration doesn’t seem to work as the repository errors out when installing the 18.04 deb file

I created a file insync.list in /etc/apt/sources.list.d that has a single line in it:

deb http://apt.insynchq.com/ubuntu bionic non-free contrib

I installed the key as suggested on insynchq. After that, i was able to install the nemo plugin and run update. I’ve used the plugin to add and remove a few folders from within nemo. Everything appears to be working.

FWIW, here’s my system:

CPU~Dual core Intel Core i7-4510U (-MT-MCP-) speed/max~2386/3100 MHz Kernel~4.15.0-24-generic x86_64 Up~55 min Mem~3102.9/7911.1MB HDD~2000.4GB(56.5% used) Procs~235 Client~Shell inxi~2.3.56 

But I did the same thing on a different laptop running Mint 19, and it worked, too.

FYI, I got an email from support “…our apt repo for Linux Mint 19 has been updated.” I can confirm that there aren’t anymore apt errors and insync-nemo is available. All I did was re-enable the repo in software sources (I had previously un-selected it).

1 Like

Hey guys. @Victoria_Walker is correct-- Linux 19 apt repo is now updated. :slight_smile: Shoot us a message for any app issues. Thanks!

Hi, I have this problem in linux mint 19.2 XFCE.
I use the install repository, but there are errors in updates. See:

Err: 5 http://apt.insync.io/mint tina InRelease
403 Forbidden [IP: 52.216.130.163 80]

I installed the version “insync_3.0.13.40201-bionic_amd64.deb”.
I’m in Brazil. Does anyone know how to fix?

Thank you.

Hi @Kelvin_Arruda,

Could you reinstall using 3.0.15 (repos are updated) and let me know if this still happens?

I’m experiencing the same problem after having downloaded insync_3.0.15.40277-bionic_amd64.deb on a system running Ubuntu 18.04 + KDE.

Full error:

Err:13 http://apt.insync.io/ubuntu precise InRelease                                             
  403  Forbidden [IP: 52.216.133.11 80]
Reading package lists... Done                                                         
E: Failed to fetch http://apt.insync.io/ubuntu/dists/precise/InRelease  403  Forbidden [IP: 52.216.133.11 80]
E: The repository 'http://apt.insync.io/ubuntu precise InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

I disabled the repository for now, but it would of course be nice if it worked.

Hi @jmerle,

Could you update the codename on your /etc/apt/sources.list.d/insync.list file from precise to bionic? Let me know how it goes!

1 Like

Thanks for the fix! Changed precise to bionic, re-enabled the repository, refreshed again and the error was gone.

2 Likes