Automatic synching after changes


this behaviour has been occurring for some weeks now… When I change something on location one, Windows clients on other locations don’t sync (download newer versions) those files automatically. Folders in the main Insync window keep yellow but synchronization begins by simply clicking on them. This happens only when files need to be synched from other locations. When I change something on my Linux station or in those Windows machines, syncing (uploading) is automatic and all right.

Has anyone got the same behaviour issue?


Hi @Tomas_Drvota!

Just to clarify: one has to double-click the folder to expand it, which somehow triggers the sync, correct?

Follow up question: Are all the files synced in those folders that are marked yellow? Or is the folder partially synced?


exactly. I need to double-click the yellow marked folder and the sync starts. It needs to be done even in the subfolders. I see “syncing…” at the right bottom corner and the files really sync. But the icon remains yellow even the files are synced. :frowning:

Hi! I want to try something… if all those folders are completely synced, please try these:

  1. Click the CSS button on the upper right and select “2-way”, like so:

  2. Uncheck then immediately re-check the yellow boxes so they turn from yellow to green

  3. Click “2-way sync” on the bottom right.

These yellow checks should change to green. Once done, restart Insync and please observe if the issue perists on having to double-click the folders for the sync to start.

Well… after applying your thoughts it started to sync the yellow one immediately and It seems like some of the files were not synced in the subfolders. Now it looks like all folders are green. Let’s take it as solved and when I have a chance to test it on my other station, I’ll let you know in case any problem appears.


@Tomas_Drvota Sounds like a plan. Thank you!