Cannot install insync-thunar on Xubuntu 18.10


#1

I recently installed Insync for the first time. I then tried to install insync-thunar without success. My system is running Xubuntu 18.10.

The following packages have unmet dependencies:
 insync-thunar : Depends: thunarx-python but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Try to install thunarx-python

The following packages have unmet dependencies:
 thunarx-python : Depends: libthunarx-2-0 (>= 1.1.0) but it is not installable
E: Unable to correct problems, you have held broken packages.

Xubuntu 18.10 doesn’t offer libthunarx-2-0. Looks like it only offers libthunarx-3-0.

$ sudo apt-cache search libthunarx
libthunarx-3-0 - extension library for thunar
libthunarx-3-dev - Development files for libthunarx

Is a fix or workaround possible?

Thank you.


#2

Hi @Jorge_Paulo,

My sincerest apologies for this :slightly_frowning_face:

This is a known issue that our devs are working on fixing in our next major release. Unfortunately, there is no known fix or workaround for this at the moment


#3

Hi @najdc,

Thank you for the quick reply. Looking forward to a fix in the next release.


#4

New version - Ubuntu Disco (19.04) is out. Any updates regarding the next major release?


#5

Hi @Jorge_Paulo,

We’re working on it. In the meantime, our 18.10 build should work okay.


#6

Hi, having a similar issue installing insync-thunar on Ubuntu 19.04. In my case, the missing package is thunarx-python

 insync-thunar : Depends: thunarx-python but it is not installable
E: Unable to correct problems, you have held broken packages.