Can't change base folder

Following the steps on the help forum, I get an error message every time I try to change the base folder. Already contacted privately for support but the response wasn’t effective at all. Would be nice to have a fix on this issue.

I’m currently running the change base folder in a windows desktop: Win-amd64/x86-10.0.19041-10-

Thanks for the attention,

Hi @RicardoSampaio :slight_smile:

I sent you a reply via email for some additional steps including reinstalling Insync (if you haven’t!). It seems like this directory is no longer in your local computer as per your updates, so let me know if the reinstallation works. Thanks!

Hey @mia , the directory in the error message exists, and it is in both - the present base folder and in the future base folder. It seems Insync is confusing itself - detecting an existing folder that itself created and raising a error message that the folder already exists. I really don’t feel like reinstalling because I’m afraid more inconsistencies will show. Would be nice if the software worked and I didn’t spend work hours trying to solve this.
I have to admit, I’m a bit frustrated that I payed for a software that seems to be in development. Other issues I’ve been through have already been raised by hundreds of other users.
Just to make everything clear for everyone about the error:
I’m running Win-amd64/x86-10.0.19041-10-
and the error message I get is:
[WinError 183] - Cannot create a file when that file already exists: [path to the folder in question]

1 Like

Hi Ricardo,

Do these two directories have the same contents? If so, would you please try and move the contents from the future base folder to another location, then proceed to change the Base Folder?

Hey, @mia.

On the weekend I did what you suggested - reinstalled. Basically deleting and downloading everything from the cloud. For me it is clear the feature is not working. Will be happy to help the developers in providing information, if there’s interest from them.
The new directory is a brand new one, with nothing in it. The error appears after 9GB of files have been copied into the new directory - so definitely an algorithm error detecting something already exists. There are no two folders with the same name also - so not an unexpected behaviour with a clear explanation. To be clear the directory is in another partition in another ssd - so nothing to do with path inside another path - btw you should throw a warning and a work around when doing that too.

1 Like

Hi @RicardoSampaio,

Thanks for walking me through what happened and what you observed!

Could you send your logs.db and out.txt files to with the link to this post? You can follow the steps here:

Has this been resolved? I am having exactly the same problem.
Installed a second internal drive and am trying to move the base folder to the new drive. All runs well for about 600Gb but then I get:
[WinError 183] - Cannot create a file when that file already exists: [path to the folder in question]
There is about 800Gb in total to move. I have tried renaming folders and reinstalling Insync but the problem persists.
Maybe the Db is corrupt? Help! We need this for work.

Hey Spike,
They never gave me a solution and don’t think they ever will…
Insync needs to treat proprietary software more seriously. Feels like an in dev open source software in which I’m the tester lol

HI @Spike,

My apologies for the trouble! Please also send your logs to and include the following files in the folder:

  • logs.db
  • out.txt
  • data folder
  • live folder

If these are too big for an attachment, feel free to send us a link so we can download these.

@Ricardo_Sampaio Hi! So sorry for not having a permanent fix for this issue yet. I recall that we had an email exchange about this too, and I was wondering if you were able to send me your latest log files after I advised to do the reinstallation?

I tried to change my Base folder in Insync, because I moved my Base folder (external folder on a NAS).
In the Insync I got an error message “Base folder is not exists”. OK, it’s normal.
But when I click on “Choose another location” I see a black screen only with a small grey rectangle with in it.


OS: Linux Mint 20.1 Cinnamon (4.8.6) x64
Linux Kernel: 5.4.0-88-generic


Is there other way to modify directly my Base location?
There only needed a small change: from to

Thank you,

Hi @MikeGabor,

Pressing Esc should unlock this frozen screen for you. Afterwards, to clear the error please remove and re-add your account, then point the Base Folder to the correct location.