Change base folder not working

My base folder was originally on a different external drive (E:) now it is on (D:).
However I have been unable to change the folder.
I have now tried removing my account and reconnecting to OneDrive, but it always starts syncing to a local folder under c:\users\me\insync…
Even if I change the folder under the file menu, then click the “open base folder” option, it continues to sync to C: and opens that folder.

What to do?

Hi @Graeme,

Could you confirm that you are changing the base folder during the setup (first step), as shown here:


Hello Mia,
When I did this yesterday (remove / re-adding OneDrive account), I changed the base folder but when clicking on the “Open base folder” link, it opened the c:\users folder and continued to sync there.

I have tried again now and have managed to get it to sync to my external drive, however… I see no opportunity to set the sync style before it starts syncing. I selected one folder during the setup and Insync immediately starts two way syncing all folders from OneDrive.

I pause sync then from the File menu I can uncheck the 2 checkboxes for 2-way sync. But already all folders have started 2-way syncing.

So, how can I setup so that only one-way syncing of my OneDrive to external drive is selected?

Hi @Graeme,

Thank you for walking me through what happened and I apologize for the troubles. This is great insight btw – I’ll file a request to improve the onboarding and enable users to select the sync style, rather than the default 2-way sync.

In order to set up 1-way syncing from OneDrive to external drive, it would be best to uncheck all the items that have been 2-way syncing. If there’s a lot of items checked, Insync may need a few moments to catch up with all the changes. You’ll notice that the local copies would be removed, but remain in the cloud. Afterwards, you can do 1-way sync by following this visual: