Deleting entire Google drive is not sane behaviour

Hi, I just experienced some weird syncing issues and wanted to start from fresh.

So I stopped insync, renamed my root drive folder, created a new empty folder and started insync again.

I naively thought that insync would recognize this as a brand new folder that needed to sync from cloud -> local.

Instead insync decided that i had deleted my entire google drive, which moved ~3000 files to the trash bin.

I’m still picking up the pieces, and I am fairly shocked that you have no failsafe to prevent this kind of mistake.

ffs. how can you start deleting EVERYTHING without so much as a prompt asking the user to confirm?!

I have since understood start that in order to get a freshly synced folder, i must delete my entire insync config folder. that is not… user friendly lets say…

For now insync is uninstalled to avoid further damage. And I am debating whether to reinstalling it again. Especially after reading a lot of post regarding wild deletion behavior from the last year or so.


Thanks for reporting this @Emillynge24. This sounds like a potential bug – Insync should bring up an error message if you renamed your base folder while it’s not running.

Tried it on my Mac:

It also shouldn’t have deleted your files. We’ll investigate this! If you haven’t already, please send an email to with your log files as it may help with the investigation. cc @jaduenas

1 Like

@gio to be clear: I renamed the root folder and created an empty folder in its place.
This was done in the hope that insync would start over from scratch and do an initial sync.

1 Like

Your new versions are RUBBISH and UNTESTED … yesterday all syncing stopped … nothing updated and was working perfectly. Now broken. Then I check AUR and there is an update so I updated … still NO syncing … really I paid for this great software which since version 3 is utter rubbish. My entire workday revolves around Drive and you have severely broken it. Fire your developers or at least go back to versions that worked. You are getting as bad as Google, Facebook and Twitter who break more than they fix. I have lost 5 hours yesterday and 4 hours today and STILL I cannot get anything to sync. Unsyncing and Resyncing 80+ GB is the only thing that works and then it break again later. Seriously disappointed in this product I paid for. Used to be great now it sucks !!!


Same problem here. I stopped using Insync and waiting till I have time to clear all the duplicate or missing files and folder from an offline backup. Also remarks that I send logs and try to find a solution with support people but without finding.

1 Like

Were you also attempting to rename your base folder?

  1. stop insync
  2. mv ~/gdrive ~/gdrive.bak
  3. mkdir ~/gdrive
  4. start insync

Insync then started deleting all files on cloud.

1 Like

I see. Thanks for this additional info, to confirm you have send your logs to support?

I had the same problem yesterday using version I accidentally deleted the local folder and Insync deleted everything from my Google Drive. This was also on Linux.
This is a very serious issue! Fortunately i have a backup.
Now while re-uploading everything it does not get past some files. Just stays at 0 bytes. For hours. I have restarted it multiple times. Doesn’t help.

1 Like

Similar issues here, too. Insync started sending my whole drive to .Trash-1000 until I stopped it, leaving me with half my files in the trash, impossibly sorted.

Also, Insync should have bug reporting built into their “fancy” new version 3 rather than the unsystematic route of asking every other person who manages to find this forum and complains to kindly send their logs.

Nasty. I’d imagine the “correct” way to do it would be to stop insync. Rename the old folder. Start insync and change the synced folder to the new folder. Now create a new folder with the previous name. Now change insync’s sync folder to the new folder. But don’t quote me on that. :slight_smile:

1 Like

Hi there, you are correct. This is in the works and will be coming out before this year ends. Thanks for the suggestion!

Hello all—

We just released 3.0.28 here.

Please note that there are no autoupdates and this is not in the Linux repos yet since it’s an early Forums release.