New Insync version: 3.0.28

Release notes:

  • Add share dialog support for OneDrive items
  • Prevent cloud deletions when deleting/moving externally synced folders while Insync is not running
  • Windows: Fix auto-updater bug introduced in 3.0.27
  • Fix syncing zero sized OneDrive file resulting in RangeNotSatisfiable/416 error
  • Fix uploads getting stuck due to ‘internal errors’
  • Linux: Fix startup issues in Xfce desktop environments
  • Fix permission errors when removing a shared file listed in “My Drive”
  • Linux: Allow QT_QPA_PLATFORM to be set via environment variable (INSYNC_START_QT_QPA_PLATFORM)

Windows 7 and later
macOS 10.10 (Yosemite and later)

Ubuntu (16.04 Xenial) & (18.04 Bionic)
Linux Mint (18.x) & (19.x)
Debian (8 Jessie) , (9 Stretch) & (10 Buster)
Fedora (27) , (28) , (29) & (30)

1 Like

I use Opensuse Tumbleewed:

Traceback (most recent call last):
File “”, line 9, in
File “”, line 983, in _find_and_load
File “”, line 967, in _find_and_load_unlocked
File “”, line 677, in _load_unlocked
File “/usr/local/lib64/python3.7/site-packages/PyInstaller/loader/”, line 627, in exec_module
File “idesklinux/”, line 15, in
File “”, line 983, in _find_and_load
File “”, line 967, in _find_and_load_unlocked
File “”, line 677, in _load_unlocked
File “/usr/local/lib64/python3.7/site-packages/PyInstaller/loader/”, line 627, in exec_module
File “idesklinux/libgio/”, line 10825, in
File “idesklinux/libgio/”, line 373, in rpythonic_function
File “idesklinux/libgio/”, line 412, in init
File “idesklinux/libgio/”, line 431, in reset
TypeError: item 3 in argtypes passes a union by value, which is unsupported.
[3620] Failed to execute script insync

It doen’t start

1 Like

Exactly the same error message with Fedora 31 too.

Hi @txutxifel

Can you uninstall Insync and install the Fedora 27 installer?


Hi @David_Bartlett

We will take a look and have a working build for Fedora 31 soon.
For now, can you uninstall and try out the Fedora 29 build?

Thank you!


Seeing as you guys have started to respond quickly and usefully…

If I took the latest 3.x build and installed it over my trusty 1.5.7 that handles around 1.5TB of Google Drive folders and files. Can I expect the transition to take less than a fortnight at home broadband speeds and also can I count on not loosing any data through cloud and/or local deletions? Because my initial 3.x experience burnt me terribly.

Linux Mint 19.3, fully upgraded/patched etc

1.5.7 to 3.x initially cost me data and many, many days, plus 3.x not exactly working in the same way as 1.5.7

Going back to 1.5.7 was trouble-free but took weeks of sync/download/upload at home broadband speeds.

What I am after is installing 3.x and it figuring things out in reasonable time without any data loss or excessive UL/DL. It also needs to pick up settings and work exactly the same as 1.5.7 - no point in upgrading if I have to stand on my head and wave arms counterclockwise seven times before I have the same environment.

None of the 3.x versions so far qualified.

Can I upgrade safely from latest v3 to this v3 on Ubuntu 19.10?

i would not recommend the migration for 1.5.7 to 3.0.28 just yet.

we are in the process of looking at the migration issues but it’s slated for 3.0.30 or beyond so if 1.5.7 still works for you, just stay with that.


1 Like

Thank you!

Finally a useful, to the point reply and advice.

I shall wait for 3.0.30 or later then.

Sad to see all these issues, really

i really appreciate the feedback and yeah it sucks but the good news: we are focused on issues + headless.

we are listening :pray:t4:

unable to download from repo VERY SLOW

  1. I have my current insync install(s) 3.0.27 (Ubuntu Bionic / Deb Buster) set up the way I want and they are working.
    a. If its not broke don’t “fix” it?
    b. When / if upgrade will I have to reset everything … on 3 different machines all running different distros
  2. 1/29/2020 8:45a EST 3.0.28 does not show up* the Bionic repo at this time.
    a. Wait?
    *after running sudo apt update
  3. What happens if I run the new 3.0.28 .deb(s)? … over current installation(s)?


Getting this error and can’t seem to “clear” it. How do I clear this issue?


Hi @Andre_Verwijs,

This version is not yet available in the Linux repo, but we’ll put it up as soon as we release the update in our downloads page. :slight_smile: In the meantime, you may download the builds we linked above. Let me know if you’re having trouble with that.

Hi @rrhobbs,

This is not yet available in our Linux repositories but we’ll update it as soon as the build can be released in our downloads page. :slight_smile: When you update, you won’t have to reset everything. You just need to quit your current version and install the latest.

Hi @Andor_Kiss,

This is currently being worked on by our engineers. We’ll update all affected users as soon as the fix is available.

miamoran: is this the long file name issue, or a different issue?

Using the Ubuntu 18.04 version worked well and resolved the 416 error on Ubuntu 19.10.

1 Like

Wierd, I have not problem running it after upgrade on my Fedora 31, although I’m on KDE Spin, but shouldn’t make a difference.