Error when moving file to a newly created folder

In 2-way sync mode, if I create a folder and move a file into it before the folder is uploaded, Insync will upload the file I just moved rather than perform move operation.

Hi @ganziheng,

I’m not sure I follow the steps correctly (for my testing and replication purposes). Any chance you could please replicate this, and send a screen recording to with the link to this post?

Sorry I didn’t describe clearly.

For example, I have a 2-way synced folder tmp which contains a file named file.

Screenshot from 2023-02-13 14-55-49

Then, I create a new folder dir inside tmp. Since in 2-way sync mode, Insync will begin to sync dir. Before the sync is finished, I move file to dir locally and I could see the log below in Google Drive.

We could see that Insync actually reuploads file to folder dir, but not moves file into dir. And Insync status is shown below.

Screenshot from 2023-02-13 14-59-15

Hi @ganziheng :slight_smile:

Thank you for walking me through what happened! I tried the steps and got the same result - it says “upload” rather than “move” so I’ll clarify that with our engineers. The interesting part is that file didn’t show a red X on my end. Do you see a visible error message on Insync regarding file?

Please also send your logs.db and out.txt files to with the link to this post. You can find your log files by following this guide:

Thank you!

Hello @mia :blush:

Do you see a visible error message on Insync regarding file?

No, there is no any visible error message on Insync.

Please also send your logs.db and out.txt files.

Sorry, I don’t want to upload for privacy reasons. And because you can reproduce the error, I think it may be unnecessary for me to upload logfile :slight_smile:.

Hope you can figure out the reason and fix this problem. If the file is large, the reuploading may be annoying for users.

1 Like

Hi, @ganziheng. While I can reproduce the upload versus move activity, I am unable to reproduce the error where it shows a red X on that particular file.

The red X may indicate a failed sync in some cases. However, I completely respect your decision to not send your logs our way for privacy reasons. We can look into the activity type but we would be unable to determine the causes of said red X further, without user logs.

Thank you!

Ok, log files have already been sent to :grinning:

1 Like

Got them, thanks so much for doing so!!

1 Like