Fedora 30 and Insync 1.5.7.37371

I am sorry but this isn’t a solution, I have other binaries which depends on libstdc++.so.6, it can not be removed like that.

Still not a real solution from my point of view guys, I had to restore it to get some other tools working.

1 Like

The libstdc++ library that Insync have recommended be removed from the Fedora installation is the version of the library that they distribute with the insync client (at /usr/lib/insync/libstdc++.so.6). Deleting this file should not impact your other binaries that depend upon libstdc++ surely? They should be dependent upon the version of libstdc++ located at /lib64/libstdc++.so.6.0.26 (provided by the libsdtc++ RPM package?

If you’ve self-compiled binaries against the libstdc++ distributed by Insync then you should probably change to use the distribution supplied libraries (compiling against a 3rd party [insync in this case] provided libraries is bad practice).

I have the same problem on openSUSE Tumbleweed. I can confirm that deleting the /usr/lib/insync/libstdc++.so.6 library fixes the problem here, too.
However, I have a problem with the Insync repo, which may be similar to the problem other users have reported on Fedora.
Zypper reports that my insync client isn’t the latest one:

~> LANG=C zypper se -s insync
Loading repository data...

Reading installed packages…

S | Name | Type | Version | Arch | Repository
—±-------------------------±--------±------------------±-------±-----------
v | insync | package | 1.5.7.37371-fc26 | x86_64 | insync repo
v | insync | package | 1.5.5.37367-fc26 | x86_64 | insync repo
i+ | insync | package | 1.5.4.37362-fc26 | x86_64 | insync repo
v | insync | package | 1.5.2.37346-fc25 | x86_64 | insync repo
v | insync | package | 1.4.5.37069-fc25 | x86_64 | insync repo
v | insync | package | 1.4.5.37069-fc25 | i686 | insync repo
| insync-caja | package | 1.3.12.36116-fc17 | noarch | insync repo
i+ | insync-dolphin | package | 1.3.12.36116-fc17 | noarch | insync repo
v | insync-dolphin | package | 1.3.8.36087-fc17 | noarch | insync repo
| insync-headless | package | 1.5.7.37371-fc26 | x86_64 | insync repo
| insync-headless | package | 1.5.5.37367-fc26 | x86_64 | insync repo
| insync-headless | package | 1.5.4.37362-fc26 | x86_64 | insync repo
| insync-headless | package | 1.5.2.37346-fc25 | x86_64 | insync repo
| insync-nautilus | package | 1.3.12.36116-fc17 | noarch | insync repo
| insync-nautilus | package | 1.3.8.36087-fc17 | noarch | insync repo
| insync-nautilus-opensuse | package | 1.3.12.36116-fc17 | noarch | insync repo
| insync-nautilus-opensuse | package | 1.3.8.36087-fc17 | noarch | insync repo
| insync-nemo | package | 1.3.12.36116-fc17 | noarch | insync repo
| insync-nemo | package | 1.3.10.36104-fc17 | noarch | insync repo

But if I try to update, insync is ignored:

~> LANG=C sudo zypper dup --from insync
Loading repository data...
Reading installed packages...
Computing distribution upgrade...

The following 2 items are locked and will not be changed by any action:
Available:
 teamviewer
Installed:
 teamviewer-suse

Nothing to do.

Thanks for the workaround. Is there an ETA for a proper fix to the upstream repo, and explicit support for Fedora 30?

Thanks.

Yeah, I’m starting to wonder if the package and repo will ever be updated for F30. It doesn’t look like such a monumental task now that a fix is out.

i moved to rclone an loving it… really a shame… love @insync team wish you all the best!

M

2 Likes

Workaround work, when will the F30 repo come online?

1 Like

Hi @Danesh_Manoharan,

What I can do is recommend the Fed 30 build of Insync 3, now available via: Insync version: 3.0.11 beta - sync OneDrive!

Please let me know if this works or if you run into anything.

Fed 30 still not working right. Nautilus still not working and it want to sync my whole drive again. file matching is not working correctly!

Hi @Ehsan_El_Nakhala,

Are you still running version 1.5.7 on your Fedora 30 machine, or have you migrated to Insync 3.x?

I have migrated to insync 3 but in my opinion version 3 is even worse. There are many bugs, some parts are still not complete (with an anoucement they are working on it) and strange behaviour… for example different users on the same Fedora 30 machine have different errors…

Hi Tomas,

So sorry for the trouble and I appreciate your patience with us. :slight_smile: Our engineers are working to make sure that these issues are resolved as soon as possible.

Could you shoot me an email at support@insynchq.com regarding the bugs you encountered, including your OS and Insync versions? Please include the link to this post as well for reference. Thank you!

After reading user’s feedback on v3 and known issues list I decided (and I suggest) to stay on v1.5. Just erase that library using the instructions in this thread and v1.5 will work as a charm.

1 Like

I used to have 1.5.7 but then I had to remove it and install 3

1 Like

This is not a recommendation, this is an explicit lack of respect.
I am a client with 5 licenses.
My mistake was to believe in this team responsibility.

1 Like

After I updated the kernel (and a bunch of libraries) yesterday, insync doesn’t start anymore on Fedora 30. This is the error I get:

insync start --no-daemon
qt.qpa.plugin: Could not load the Qt platform plugin "wayland" in "" even though it was found.
which: no kreadconfig in (/usr/lib/insync:/home/costalocal/.local/bin:/home/costalocal/bin:/home/costalocal/.local/bin:/home/costalocal/bin:/usr/share/Modules/bin:/usr/local/bin:/usr/local/sbin:/usr/bin:/usr/sbin)
INFO     2019-09-18 16:15:54,324 [__main__insync__:main:105] insync version: 1.5.7.37371
INFO     2019-09-18 16:15:54,326 [__main__insync__:main:106] client created <ideskmain.client.Client object at 0x7f5cc97c6e10>
INFO     2019-09-18 16:15:54,327 [unix_socket_server_portable:start:49] unix socket server thread start
INFO     2019-09-18 16:15:54,328 [__main__insync__:main:114] starting client
INFO     2019-09-18 16:15:54,335 [fswatch:_start:532] LinuxFSWatcher._start
INFO     2019-09-18 16:15:54,337 [fswatch:_pull_loop:267] Inotify loop enter
Received signal 11 SEGV_MAPERR 000000000108
#0 0x7f5cced9e58f <unknown>
#1 0x7f5ccd7d085d <unknown>
#2 0x7f5cced9ea9e <unknown>
#3 0x7f5d09d5cc60 <unknown>
#4 0x7f5ced9f3068 <unknown>
#5 0x7f5ced9f4307 <unknown>
#6 0x7f5cf81012a9 glXCreatePbuffer
#7 0x7f5ccd8327b9 <unknown>
#8 0x7f5ccd81d818 <unknown>
#9 0x7f5ccf8da47d <unknown>
#10 0x7f5ccdb21151 <unknown>
#11 0x7f5ccdb22945 <unknown>
#12 0x7f5ccfd90707 <unknown>
#13 0x7f5cd15c7375 <unknown>
#14 0x7f5ccee06f45 <unknown>
#15 0x7f5ccee022e0 <unknown>
#16 0x7f5d09d524c0 start_thread
#17 0x7f5d096ef553 __GI___clone
  r8: 000055a20bee05b0  r9: 0000000000000000 r10: 0000000000000000 r11: 0000000000000206
 r12: 000055a20beea7c0 r13: 000055a20c004910 r14: 0000000000000001 r15: 0000000000000009
  di: 000055a20beea7c0  si: 0000000000000000  bp: 000055a20beea7c0  bx: 0000000000000000
  dx: 0000000000008041  ax: ffffffffffffff50  cx: 0000000000000000  sp: 00007f5c6affc480
  ip: 00007f5ced9f3068 efl: 0000000000010202 cgf: 002b000000000033 erf: 0000000000000004
 trp: 000000000000000e msk: 0000000000000000 cr2: 0000000000000108
[end of stack trace]
Calling _exit(1). Core file will not be generated.

The last updates were:

dnf history info 76
[...]
Packages Altered:
    Upgrade  curl-7.65.3-4.fc30.x86_64    @updates
    Upgraded curl-7.65.3-3.fc30.x86_64    @@System
    Upgrade  libcurl-7.65.3-4.fc30.x86_64 @updates
    Upgraded libcurl-7.65.3-3.fc30.x86_64 @@System
    Upgrade  libv4l-1.16.7-1.fc30.x86_64  @updates
    Upgraded libv4l-1.16.5-3.fc30.x86_64  @@System

dnf history info 75
[...]
Packages Altered:
    Reinstall   xorg-x11-server-Xorg-1.20.5-7.fc30.x86_64             @updates
    Reinstalled xorg-x11-server-Xorg-1.20.5-7.fc30.x86_64             @@System
    Reinstall   xorg-x11-server-Xwayland-1.20.5-7.fc30.x86_64         @updates
    Reinstalled xorg-x11-server-Xwayland-1.20.5-7.fc30.x86_64         @@System
    Reinstall   xorg-x11-server-common-1.20.5-7.fc30.x86_64           @updates
    Reinstalled xorg-x11-server-common-1.20.5-7.fc30.x86_64           @@System
    Install     kernel-5.2.14-200.fc30.x86_64                         @updates
    Install     kernel-core-5.2.14-200.fc30.x86_64                    @updates
    Install     kernel-devel-5.2.14-200.fc30.x86_64                   @updates
    Install     kernel-modules-5.2.14-200.fc30.x86_64                 @updates
    Install     kernel-modules-extra-5.2.14-200.fc30.x86_64           @updates
    Upgrade     gimp-2:2.10.12-3.module_f30+6174+bc22f659.x86_64      @updates-modular
    Upgraded    gimp-2:2.10.12-2.module_f30+5292+0833adf4.x86_64      @@System
    Upgrade     gimp-libs-2:2.10.12-3.module_f30+6174+bc22f659.x86_64 @updates-modular
    Upgraded    gimp-libs-2:2.10.12-2.module_f30+5292+0833adf4.x86_64 @@System
    Upgrade     annobin-8.71-3.fc30.x86_64                            @updates
    Upgraded    annobin-8.71-2.fc30.x86_64                            @@System
    Upgrade     dnf-4.2.8-2.fc30.noarch                               @updates
    Upgraded    dnf-4.2.8-1.fc30.noarch                               @@System
    Upgrade     dnf-data-4.2.8-2.fc30.noarch                          @updates
    Upgraded    dnf-data-4.2.8-1.fc30.noarch                          @@System
    Upgrade     dnf-yum-4.2.8-2.fc30.noarch                           @updates
    Upgraded    dnf-yum-4.2.8-1.fc30.noarch                           @@System
    Upgrade     dnsmasq-2.80-10.fc30.x86_64                           @updates
    Upgraded    dnsmasq-2.80-9.fc30.x86_64                            @@System
    Upgrade     file-roller-3.32.2-1.fc30.x86_64                      @updates
    Upgraded    file-roller-3.32.1-2.fc30.x86_64                      @@System
    Upgrade     file-roller-nautilus-3.32.2-1.fc30.x86_64             @updates
    Upgraded    file-roller-nautilus-3.32.1-2.fc30.x86_64             @@System
    Upgrade     fontconfig-2.13.1-9.fc30.x86_64                       @updates
    Upgraded    fontconfig-2.13.1-8.fc30.x86_64                       @@System
    Upgrade     fontconfig-devel-2.13.1-9.fc30.x86_64                 @updates
    Upgraded    fontconfig-devel-2.13.1-8.fc30.x86_64                 @@System
    Upgrade     gjs-1.56.2-6.fc30.x86_64                              @updates
    Upgraded    gjs-1.56.2-5.fc30.x86_64                              @@System
    Upgrade     jbig2dec-libs-0.16-1.fc30.x86_64                      @updates
    Upgraded    jbig2dec-libs-0.14-5.fc30.x86_64                      @@System
    Upgrade     kernel-headers-5.2.14-200.fc30.x86_64                 @updates
    Upgraded    kernel-headers-5.2.13-200.fc30.x86_64                 @@System
    Upgrade     libcacard-3:2.7.0-3.fc30.x86_64                       @updates
    Upgraded    libcacard-3:2.6.1-2.fc30.x86_64                       @@System
    Upgrade     libdnf-0.35.2-3.fc30.x86_64                           @updates
    Upgraded    libdnf-0.35.2-1.fc30.x86_64                           @@System
    Upgrade     libmodulemd-2.8.0-1.fc30.x86_64                       @updates
    Upgraded    libmodulemd-2.7.0-1.fc30.x86_64                       @@System
    Upgrade     libnfsidmap-1:2.4.1-0.rc1.fc30.x86_64                 @updates
    Upgraded    libnfsidmap-1:2.4.1-0.fc30.x86_64                     @@System
    Upgrade     libselinux-2.9-3.1.fc30.x86_64                        @updates
    Upgraded    libselinux-2.9-1.fc30.x86_64                          @@System
    Upgrade     libselinux-utils-2.9-3.1.fc30.x86_64                  @updates
    Upgraded    libselinux-utils-2.9-1.fc30.x86_64                    @@System
    Upgrade     libxcrypt-4.4.9-1.fc30.x86_64                         @updates
    Upgraded    libxcrypt-4.4.8-1.fc30.x86_64                         @@System
    Upgrade     libxcrypt-compat-4.4.9-1.fc30.x86_64                  @updates
    Upgraded    libxcrypt-compat-4.4.8-1.fc30.x86_64                  @@System
    Upgrade     libxcrypt-devel-4.4.9-1.fc30.x86_64                   @updates
    Upgraded    libxcrypt-devel-4.4.8-1.fc30.x86_64                   @@System
    Upgrade     mozjs60-60.9.0-2.fc30.x86_64                          @updates
    Upgraded    mozjs60-60.8.0-2.fc30.x86_64                          @@System
    Upgrade     nfs-utils-1:2.4.1-0.rc1.fc30.x86_64                   @updates
    Upgraded    nfs-utils-1:2.4.1-0.fc30.x86_64                       @@System
    Upgrade     polkit-0.116-2.fc30.x86_64                            @updates
    Upgraded    polkit-0.116-1.fc30.x86_64                            @@System
    Upgrade     polkit-libs-0.116-2.fc30.x86_64                       @updates
    Upgraded    polkit-libs-0.116-1.fc30.x86_64                       @@System
    Upgrade     python3-dnf-4.2.8-2.fc30.noarch                       @updates
    Upgraded    python3-dnf-4.2.8-1.fc30.noarch                       @@System
    Upgrade     python3-hawkey-0.35.2-3.fc30.x86_64                   @updates
    Upgraded    python3-hawkey-0.35.2-1.fc30.x86_64                   @@System
    Upgrade     python3-libdnf-0.35.2-3.fc30.x86_64                   @updates
    Upgraded    python3-libdnf-0.35.2-1.fc30.x86_64                   @@System
    Upgrade     python3-libselinux-2.9-3.1.fc30.x86_64                @updates
    Upgraded    python3-libselinux-2.9-1.fc30.x86_64                  @@System
    Upgrade     shared-mime-info-1.13.1-1.fc30.x86_64                 @updates
    Upgraded    shared-mime-info-1.12-2.fc30.x86_64                   @@System
    Upgrade     vim-minimal-2:8.1.1991-2.fc30.x86_64                  @updates
    Upgraded    vim-minimal-2:8.1.1912-1.fc30.x86_64                  @@System
    Upgrade     virtualbox-guest-additions-6.0.12-1.fc30.x86_64       @updates
    Upgraded    virtualbox-guest-additions-6.0.10-1.fc30.x86_64       @@System
    Removed     kernel-5.2.9-200.fc30.x86_64                          @@System
    Removed     kernel-core-5.2.9-200.fc30.x86_64                     @@System
    Removed     kernel-devel-5.2.9-200.fc30.x86_64                    @@System
    Removed     kernel-modules-5.2.9-200.fc30.x86_64                  @@System
    Removed     kernel-modules-extra-5.2.9-200.fc30.x86_64            @@System

I know you guys have been working hard to stabilize 3.0 but, IMHO, it is still not production-ready, judging by all the feedback I’ve been seeing. So, I kindly ask you to release a fix for this error on the 1.5 branch instead of simply suggesting the upgrade to 3.0. Can we have any hope to see it fixed on 1.5?

Hi @Costa,

Got your message in the Slack channel.

For reference, here’s the link for the Fedora 29 build:
http://s.insynchq.com/builds/insync-1.5.7.37371-fc29.x86_64.rpm

Please run sudo rm /usr/lib/insync/libstdc++.so.6 and restart Insync 1.5.7. Our engineer tested it out and it works on Fedora 30. :slight_smile:

Hi @Cosme_Correa,

I responded to your email regarding this issue. I sent you the same Fedora 29 build with the sudo command that would make 1.5.7 run on your Fedora 30 setup. :slight_smile: Let me know if any issues persist (either here or via email is okay!).

Thank you very much!

It worked, gracefully.

Almost obvious suggestions:

  • restore the fedora repo for 1.5
  • put this link on your homepage
  • explain when / how you will abandon 1.5 for Fedora, in you homepage

Thank you.

Thanks a lot, it worked! :smile: The weird thing is that I have two F30 boxes, one at home, and another at work, and only the one at work was showing this error. Granted, they are not identical (eg. at home I use the proprietary Nvidia driver, at work is the opensource Intel driver). Anyway, I’m glad it is working again. Now I can go back to safely waiting for insync 3 to stabilize :wink:

1 Like