"File changed on disk" message

On Ubuntu, when editing text files monitored by InSync, both Emacs and Sublime Text regularly throw up a message that the file has changed on disk. This can’t be an editor issue, as it happens in both editors, and it does not happen with any files outside of the InSync folders. So, I’m thinking the issue is probably with InSync. Does anyone have an idea about what is going on here (and how to fix it)?


Bluefish is also affected on Ubuntu 14.04. Such a message occurs frequently and is very annoying. Any solution?

Bluefish guys have fixed the problem quickly by allowing to set “never check if file is modified” (https://bugzilla.gnome.org/show_bug.cgi?id=748402#c1). So, the annoying message is gone forever.

However, I still expect that Insync will not trigger the detection of file modification. Bluefish checks for the last modified time and the file size change to determine if the file is modified. Any chance that Insyc does not modify the time?

Well, it has been 8 days since the first post. The “sync’ing” is really slow…

Sorry for the delayed reponse, I will tag our engineer @lpugoy so he can help you with your concerns. But if we are talking about Insync being able to determine if the file has been modified, that feature is not available yet but being actively worked on by the team.

@rosslaird @yltang We are aware of this issue but we are working on other priorities at the moment. Apologies for the inconvenience.

I am having this problem in a big way with Emacs. This seems to be fundamental. I use network time on all my machines so that having different clock settings on different machines should not be an issue. I have at least 2 machines on at any one time, if that helps.

glad you’re aware of the issue, this is affecting me quite badly as I was using it to sync files.

What I might do is copy the files over to another folder, and then copy them back again to sync.

Was there ever a solution to that? I just upgraded to ubuntu 16.04and started to have the same trouble. If I pause Insync, emacs works fine, but as soon as I resume it, emacs has trouble with managing the files.

This is affecting me for a long time, also. It seems minor, but it gets really annoying. On the other hand, disabling the notification would be very bad, as sometimes I do actually change a file at a computer while the buffer is open at another.

@Alexandre_L_Madureir: Could you give a step by step on how to reproduce the issue? It was supposed to be fixed in the 1.2.15 version.

1 Like

Problem solved after updating my Insync. Thanks.

1 Like

5 years after the original post in this issue I still get a message about file changed when saving from Emacs:

changed on disk; really edit the buffer? (y, n, r or C-h)

It doesn’t happen at every save, but quite frequently. I have noticed it only in LaTeX (.tex) files, but it might be because it is what I modify the most. I am on Ubuntu 20.04, insync, Emacs v. 27.2.

Any fix?

1 Like

Hi @Roberto_Zamparelli,

Would you mind sending your logs.db and out.txt files to support@insynchq.com? Those two should be in ~/.config/Insync. Please do include a link to this post so I can trace the report :slight_smile: