File/Folder indicator signs disappear after upgrading to Windows 10


I am now upgrading several machines which runs Windows 7 and 8.1 to WIndows 10 and it works great as well as Insync. However, today I found that folders and files under control of Insync shows no iconic signs (syncing, up-to-date, … circulating or green check mark).

Such issue also occured on Dropbox (sorry, I am using several cloud storages) and it solved by re-installing. Using this lesson, I applied the same strategy for Insync … uninstallation and re-installation. However, despite re-starting of explorer which expected me to re-appear iconic signs, the issue did not solve and I cannot see any iconic signs.

Basic function of Insync such as file syncing and status window are OK, and icons in system tray seems normal (it shows status with no problem). Is there any idea to solve this issue? Thanks.

@terakin: Could you try uninstalling one of the other apps that use file/folder badges (/indicator signs) and then see if it works?


Thanks for your suggestion … It seems that it happened after uninstalling & installing Dropbox. It urged me to re-install after upgrading to Windows 10, and I did it as it said. Additionally, the reason of re-installation was related to badge (indicator) … Some Dropbox in Upgraded Windows 10 computer cannot display badges (indicators) properly. Do I need to re-install Insync with the same manner as Dropbox?

I tried to uninstall and install Insync, and the situation did not go better. Icon (indicator) is not displayed.

@terakin: Please try the following:

  1. Uninstall dropbox
  2. Install Insync

See if the badges appear then


Thanks, I tried to uninstall Dropbox (and reboot) and confirmed icon (indicator) re-appears on all folders and files under Insync. I’ll try whether re-installation of Dropbox keeps this indicator appear for Insync folders.

Additional info. After installing Dropbox again and restarting my computer, it seems that no indicators appear on Insync folders and files. This strongly suggests that Dropbox occupies icons (indicators) in any way so that other apps cannot use. Also I just noticed that OneDrive, also uses same indicators, has no indicators too. Should I say some complaints to Dropbox … ?
Anyway, @dipesh, thanks again for your perfect suggestion.

@terakin: It is a Windows limitation. You do not have to report it to Dropbox.

Please do the following:
Open regedit.exe, go to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer \ShellIconOverlayIdentifiers and check what other apps have registered overlay icons.
There is a Windows limit (15) on the number of overlay icons that can be registered. Please see if the number of icons registered exceed 15.
If it does, then unfortunately, you will have to uninstall the overlay icons of one of those apps for Insync’s overlay icons to work.


@dipesh, thanks for your suggestion.

I checked the registry entry of my two computers, both of which have same problem.
The screenshot of regedit is attached. As you can see, there are 21 entries of icons in this registry entry. It is over the limit of Windows (15) and maybe this is a cause of problem.

I use OneDrive, Insync and Dropbox and none of them cannot be uninstalled. So, I should be patient until Microsoft changes this limitation …

There is a workaround: rename the InSync keys and enter two or three blanc spaces in front. Then they will be on top of the list and displayed.

Ah - this worked. I’ve just purchased a new computer and first upgraded to 10, then began installing software, including dropbox and insync. The insync folders were missing the checkmark. I checked the registry key and dropbox was using a lot, and I think it only needs 5 actually. So (after backing up the registry folder) I deleted a few of the dropbox keys and got the total in the folder to exactly 15, rebooted, but no luck. Then I tried adding leading blanks as suggested, rebooted, and viola. Thanks. :slight_smile:

Thank you, guys! Finally found a solution to this problem!

How to add the same folder icons in lubuntu? Thanks.

reposted the workaround in official how-to’s. here’s the link

thanks @rrvdplas for the workaround!