Files are being deleted and moved to trash

Since the last update (I think) I’ve noticed that every day I get notifications about deleted files and then they appear in trash folder. I do not delete anything neither on my local nor remote locations. I am worried about my files disappearing…

Do you own these files or are they shared? If shared, please confirm with the owner if they are being deleted.

What computer OS are you using?

Please send us your logs:


I own them. They are not shared. I happens on all 3 of my accounts.
It’s Windows 7 Ultimate.

@Filip Ok, I have cc’d one of our engineers @dipesh

If you haven’t, email the logs to


I just want to know if this issue was solved. It looks that in the last update (I installed it yesterday) on Ubuntu 14.04 everything works well again.
For some reason files are deleted randomly by “Someone”. Im worry about this too.
Thank you.

I have the same issue!

Is it solved?

@Humberto_Jimenez We have to investigate your logs. Please send it to I will forward it immediately to to engineer for investigation.

Thank you for your patience.

Recently I send mail to support with logs attached

I have forwarded your logs and out a hig priority on this issue. @dipesh will get back to you soon.

Thank you.

I just noticed this morning that the same thing is happening to me. Files that were added while Insync was offline are deleted. It’s as if it syncs from Google first, so since those new files didn’t sync and aren’t in my Google Drive yet, they just get wiped out as if I had deleted them from Google instead of being uploaded. This is very not cool, as I’m now deeply concerned about what I may have lost without even realizing it. I guess I’ll go dumpster diving in the Google Drive Trash and Insync trash now.

Also wanted to note, at least some of the files that were deleted are NOT in the Insync trash, so there’s no real way to know what’s been lost. Thankfully, this has happened before, so I back up my Google Drive folders with Crashplan too.

Let me know where to upload my logs, maybe that will help. Thanks!

@Humberto_Jimenez @jtrout: The files’ trashing and re-uploading issue was related to external and network drives getting disconnected frequently. It was fixed a while back in the version 1.2.8

@Humberto_Jimenez I have replied to your email. The Insync version you have been using is 1.2.7 and it hasn’t auto updated because of the connectivity issue to at your end.

@jtrout: This should not happen at all. The files that are added while Insync was offline should get uploaded when it is running again. Insync cannot do direct deletions - if a file has been deleted locally, it trashes on Google Drive. If the file has been trashed/unshared remotely, it puts it in the .insync-trash folder locally for 30 days before permanently deleting it. Please upload the compressed copy of the dbs folder (present next to the logs.db) file to Google Drive and send it to along with the example of filenames that you think were deleted.


Hey @Dipesh, I have the logs zipped up but it’s 68 MB. How would you like me to get these to you?



@jtrout Please share it to and email us the shared link and the link of this post.

Thank you.

Hey @roald and @dipesh,

I sent Support the link to the dbs with a detailed description of the issue, file names, and a link to this forum post. That was a week ago, and I haven’t heard anything - are you able to find out if that was received, and what the status is?



@jtrout I’m trying to look for your logs and I can’t find it. Please re-send your logs.db and out.txt file to

@roald + @dipesh

I have the exact same problem. I can see there is 49.8 Gb in trash from the Insynch data panel. This is more than 2 years of work. I sent the logs.db, out.txt and screenshots to All my 49.8 GB files a been deleted… i and my team don’t have any access. I tried to find the insynchq trash folder but was not possible.

My colleague receive this message as well:
This one also:

It is freezing my complete team, client + collaborators…

Please help! Thank You!

Hi @jtrout !

Where you able to have access or recover the files finally?

Hi @steveestimable

Please send us your logs.db and out.txt to

Also, include the link of this post.

Thank you.

@roald, It has been done.

@steveestimable Thanks! :smile: