Files are being deleted and moved to trash


#8

Recently I send mail to support with logs attached


#9

I have forwarded your logs and out a hig priority on this issue. @dipesh will get back to you soon.

Thank you.


#10

I just noticed this morning that the same thing is happening to me. Files that were added while Insync was offline are deleted. It’s as if it syncs from Google first, so since those new files didn’t sync and aren’t in my Google Drive yet, they just get wiped out as if I had deleted them from Google instead of being uploaded. This is very not cool, as I’m now deeply concerned about what I may have lost without even realizing it. I guess I’ll go dumpster diving in the Google Drive Trash and Insync trash now.

Also wanted to note, at least some of the files that were deleted are NOT in the Insync trash, so there’s no real way to know what’s been lost. Thankfully, this has happened before, so I back up my Google Drive folders with Crashplan too.

Let me know where to upload my logs, maybe that will help. Thanks!


#11

@Humberto_Jimenez @jtrout: The files’ trashing and re-uploading issue was related to external and network drives getting disconnected frequently. It was fixed a while back in the version 1.2.8

@Humberto_Jimenez I have replied to your email. The Insync version you have been using is 1.2.7 and it hasn’t auto updated because of the connectivity issue to s.insynchq.com at your end.

@jtrout: This should not happen at all. The files that are added while Insync was offline should get uploaded when it is running again. Insync cannot do direct deletions - if a file has been deleted locally, it trashes on Google Drive. If the file has been trashed/unshared remotely, it puts it in the .insync-trash folder locally for 30 days before permanently deleting it. Please upload the compressed copy of the dbs folder (present next to the logs.db) file to Google Drive and send it to support@insynchq.com along with the example of filenames that you think were deleted.

Thanks


#12

Hey @Dipesh, I have the logs zipped up but it’s 68 MB. How would you like me to get these to you?

Thanks!

~JT


#13

@jtrout Please share it to support@insynchq.com and email us the shared link and the link of this post.

Thank you.


#14

Hey @roald and @dipesh,

I sent Support the link to the dbs with a detailed description of the issue, file names, and a link to this forum post. That was a week ago, and I haven’t heard anything - are you able to find out if that was received, and what the status is?

Thanks!

~JT


#15

@jtrout I’m trying to look for your logs and I can’t find it. Please re-send your logs.db and out.txt file to support@insynchq.com.


#16

@roald + @dipesh

I have the exact same problem. I can see there is 49.8 Gb in trash from the Insynch data panel. This is more than 2 years of work. I sent the logs.db, out.txt and screenshots to support@insynchq.com. All my 49.8 GB files a been deleted… i and my team don’t have any access. I tried to find the insynchq trash folder but was not possible.

My colleague receive this message as well: http://screencast.com/t/jLBdV47XXid
This one also: http://screencast.com/t/MDAiZLOJ

It is freezing my complete team, client + collaborators…

Please help! Thank You!


#17

Hi @jtrout !

Where you able to have access or recover the files finally?


#18

Hi @steveestimable

Please send us your logs.db and out.txt to support@insynchq.com

Also, include the link of this post.

Thank you.


#19

@roald, It has been done.


#20

@steveestimable Thanks! :smile:


#21

Hey everyone!

Sorry I’m so long in getting back to this, it’s been a crazy couple of weeks. @Roald, I just sent my logs.db and out.txt files to support. I replied to my original message with the link to the shared zip of the dbs folder that @dipesh had requested, and asked that someone confirm that they’ve at least received this latest e-mail. Hopefully something in there makes some sense to you guys.

Steve, I’m not honestly sure how many files were lost. I can get some of them out of the Google Drive trash, but others appear to have been deleted from the local hard drive by Insync without ever having been uploaded to Google Drive. I suspect I lost files in that manner that I can’t get back, since the Insync trash is emptied every 30 days.

It’d be great if you guys could let me know if you get the e-mail(s) this morning, or if there’s still some issue?

Thanks again!

~JT


#22

Hello everyone,

I am having the same issue.

When using the trial period, we successfully synced files across 6 different drives. When our trial period expired we had to wait a couple of weeks for the purchase of the pro version to be authorised by our company.

Once we applied the licence, the first thing insync did was to move all online files to Google drive trash. Local files stayed as they were (just not syncing anymore).

We restored all the files from the trash (this resulted in files being duplicated locally). The workaround we found to avoid duplication of files was to delete files locally first, then restore files from Google drive trash.

It worked! Except the next day, all online files had been moved to Google drive trash again.

We use Windows 7 Pro and our files are locally saved on a shared network drive. We own all the files and have shared the vast majority of them (anyone with the links can view – not edit the files).

I have emailed our logs. I am not sure what to do next? How can we stop files from being moved to the trash?

Thank you,

Sarah


#23

Follow up -

I finally got to the bottom of the issue. As it turns out, my microSD card that I had all of my files on was going a little loopy. There must have been some issue with the FAT table or something, because added files would disappear and deleted files would reappear. I moved everything back onto the hard drive, and everything’s been perfectly smooth since. So this one was not Insync, but their support team was great in working with me to try to get to the bottom of it. Kudos!

@Sarah - your issue is because someone is disconnecting from the network. Insync can no longer get to the files because they’re on a network drive, so it believes they’re deleted. That’s why they keep getting wiped out every night (someone’s taking their laptop home, perhaps?). @Dipesh could perhaps shed more light on this - he had mentioned above that there was a fix for network drives disconnecting and files getting trashed in version 1.2.8. Good luck!

~JT


#24

Thanks @jtrout for responding while we could not take this up.

Yes, the trashing of files because of network/external drive getting disconnected had been fixed by 1.2.8 Since then we haven’t encountered any report on the issue.

@Sarah, Please email your Insync logs and compressed copy of the dbs folder (present next to the log.db file) to support@insynchq.com so that we could try analyzing the sync events in your case.

Thanks


#25

No sorry, this problem is not solved yet. I used the latest insynch version for windows (2016-06-16).
I paused the sync process, notebook (win7) on sleep, disconnected my external USB Drive, went to another place, reconnected the external drive and resumed (restartet insync).
3 hours later my important datas had holes like swiss chese AND were NOT in the Trash Folder of insynch. And even worse the deletion was also done on another backup drive connected to another computer…

Insynch is really fast working, but It’s really NOT usable for professional needs, as there is no Conflict Controll, No Process Kill Routine.


#26

Hello Kacy,

Did you use the same external drive folder with Insync app on another machine? If so, please note that this is not supported. Each Insync app instance should have their own separate/exclusive Insync folders - must not be used with Google app or another Insync app instance.

Did you unselect the files that you speak of, under selective sync settings? If so, please note that that’s the expected behaviour. When you unselect the files, Insync deletes them from the local Insync folder but the files are kept intact on Google Drive web. Are the files present on Google Drive web?

Insync never deletes users’ files on its own. Further, it only trashes the files on Google Drive web when you delete them locally. Similarly, when you remove a file from Google Drive web, Insync puts the corresponding file (if it was being sync’d locally) in the .insync-trash folder for 30 days before permanently deleting it.

Re: Conflict control - the local version of the file always takes precedence and overwrites the remote file as a new version so that no data is lost. You can revert to the previous version or extract data from the previous version on Google Drive web by going to File -> Manage versions.

As to Process Kill Routine, Insync does provide the quit functionality: Right click the tray icon -> Quit. Does it not work for you?

Please send to us the logs and compressed copy of the dbs folder (present inside the same location as that of logs) at support@insynchq.com and tell us some example files (their paths) that you think Insync has deleted so that we could tell you what happened with them.

Thanks


#27

Same here with version 1.3.16. Email sent with logs.

[]s