Finder Integration crashes

OSX 10.15.3. Tried reinstalling the app.

Process: Insync Finder Integration [15747]
Path: /Applications/ Finder Integration.appex/Contents/MacOS/Insync Finder Integration
Identifier: Insync Finder Integration
Version: 2 (2)
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: Insync Finder Integration [15747]
User ID: 501

Date/Time: 2020-02-16 09:56:26.043 +0800
OS Version: Mac OS X 10.15.3 (19D76)
Report Version: 12
Bridge OS Version: 4.2 (17P3050)
Anonymous UUID: 0C388DF3-14CD-4DFA-8E46-605032216D48

Sleep/Wake UUID: 8E3C54CD-98CD-4854-AD66-D52F62252958

Time Awake Since Boot: 19000 seconds
Time Since Wake: 2800 seconds

System Integrity Protection: enabled

Crashed Thread: 0

Exception Type: EXC_CRASH (SIGABRT)
Exception Codes: 0x0000000000000000, 0x0000000000000000

Termination Reason: DYLD, [0x1] Library missing

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
Library not loaded: @rpath/FinderSync.framework/Versions/A/FinderSync
Referenced from: /Applications/ Finder Integration.appex/Contents/MacOS/Insync Finder Integration
Reason: image not found

Binary Images:
0x107604000 - 0x107609ff7 +com.insynchq.Insync.Insync-Finder-Integration (2 - 2) /Applications/ Finder Integration.appex/Contents/MacOS/Insync Finder Integration
0x10a2cc000 - 0x10a35ccb7 dyld (733.8) /usr/lib/dyld
0x7fff32f15000 - 0x7fff33cd0fff (6.9 - 1894.30.142) <5A1752C0-67F4-3EDF-97DA-81AB42824B7B> /System/Library/Frameworks/AppKit.framework/Versions/C/AppKit
0x7fff35d0d000 - 0x7fff3618dfe7 (6.9 - 1674.114) <5810CC45-FB5D-3A78-861F-7BE03F9B2FDD> /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation
0x7fff383d2000 - 0x7fff3879affc (6.9 - 1674.114) <532BBAE7-F2BA-3779-94E0-BFEDF2D7AB38> /System/Library/Frameworks/Foundation.framework/Versions/C/Foundation
0x7fff6a260000 - 0x7fff6a261ff3 libSystem.B.dylib (1281) /usr/lib/libSystem.B.dylib
0x7fff6c0b5000 - 0x7fff6c0e6fc6 libobjc.A.dylib (781.2) <7B72F50A-5381-36D7-A616-65D3EA9748A5> /usr/lib/libobjc.A.dylib

Hi @Kuangye_Chen,

If you haven’t, could you also please send your log files to with the link to this post? :slight_smile:

I have the same problem MacOS 10.15.3.
I find the Insync Finder Integration always crashing in the system logs.
I will send the Insync log files to the support email separately


Same issue every time the OS opens a file save window. I also have Google Drive File Stream installed but it is for a separate (work) Google account and doesn’t overlap either of the two Google accounts set up on Insync. Also tried reinstalling Insync w/ no change in crash behavior.

Hi! If you haven’t, please send your log files to with the link to this post.

Same here, on both my MacBookPro 2018 and also on my new 16" 2019 MacBookPro (10.15.3). I’ll send over the log files…

1 Like

I’m having this same issue. TONS of crashes and it’s causing other secondary issues such as Finder steals the focus every time the finder integration crashes.

Hi! Let me know if you have sent your log files to with the link to this post. I will escalate this to our engineers so we can determine why this is happening on your machines.

Thank you!

Same issue, Catalina 10.15.3.

The dyld error is weird.

There’s a FinderSync executable in /System/Library/Frameworks/FinderSync.framework/Versions/A

$ file FinderSync
FinderSync: Mach-O 64-bit dynamically linked shared library x86_64

$ otool -L FinderSync
/System/Library/Frameworks/FinderSync.framework/Versions/A/FinderSync (compatibility version 1.0.0, current version 0.0.0)
/System/Library/Frameworks/Cocoa.framework/Versions/A/Cocoa (compatibility version 1.0.0, current version 23.0.0)
/System/Library/Frameworks/AppKit.framework/Versions/C/AppKit (compatibility version 45.0.0, current version 1894.20.140)
/System/Library/PrivateFrameworks/PlugInKit.framework/Versions/A/PlugInKit (compatibility version 1.0.0, current version 1.0.0)
/System/Library/Frameworks/CoreServices.framework/Versions/A/CoreServices (compatibility version 1.0.0, current version 1069.11.0)
/System/Library/PrivateFrameworks/FinderSyncPriv.framework/Versions/A/FinderSyncPriv (compatibility version 1.0.0, current version 1298.2.10)
/System/Library/Frameworks/Foundation.framework/Versions/C/Foundation (compatibility version 300.0.0, current version 1674.114.0)
/usr/lib/libobjc.A.dylib (compatibility version 1.0.0, current version 228.0.0)
/usr/lib/libc++.1.dylib (compatibility version 1.0.0, current version 800.7.0)
/usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 1281.0.0)
/System/Library/Frameworks/ApplicationServices.framework/Versions/A/ApplicationServices (compatibility version 1.0.0, current version 52.0.0)
/System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation (compatibility version 150.0.0, current version 1674.114.0)

Nothing missing in the plugin either:

$ otool -L Insync\ Finder\ Integration
Insync Finder Integration:
/System/Library/Frameworks/Foundation.framework/Versions/C/Foundation (compatibility version 300.0.0, current version 1256.1.0)
/usr/lib/libobjc.A.dylib (compatibility version 1.0.0, current version 228.0.0)
/usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 1226.10.1)
/System/Library/Frameworks/AppKit.framework/Versions/C/AppKit (compatibility version 45.0.0, current version 1404.32.0)
/System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation (compatibility version 150.0.0, current version 1256.14.0)
@rpath/FinderSync.framework/Versions/A/FinderSync (compatibility version 1.0.0, current version 960.2.6)

Thinking this might be a security issue, I added to System Preferences -> Security & Privacy -> Full Disk Access and Accessibility.

No change. Still get a crash report almost every time I open a new finder window.

1 Like


Appreciate the report! Could you send your logs.db and out.txt files to with the link to this post?

Fixed in

1 Like