General UI issues

In the spirit of providing feedback to help guide the improvements to Insync v3, I’d like to share my experience of using the UI this morning. This is a bit long and rambling but I hope it will be useful to illustrate the collection of small issues which make Insync such a struggle at the moment. I’m on Windows, Insync version 3.0.27.40677.

What I was originally trying to do was investigate the local and cloud selective sync functionality. However for some reason, when I clicked local selective sync, nothing was happening. I don’t know why this is, as it now works, but unresponsive UI is really the main theme of my experience. I thought, having not used this feature before, maybe that’s because the default My Drive screen was the local selective sync screen, like the local/cloud screens were tabs. I now realise that’s not the case, it was just broken for some reason.

I also clicked Cloud selective sync, but it took me a while to work out how to get out of it. Given that the status bar currently says “Syncing” with a big cancel button next to it, it looked a bit like this button might cancel the sync. I now realise it appeared when I clicked Cloud selective sync, and that’s what I needed to press to get back to My Drive. This whole thing is unintuitive and inconsistent since the two selective sync buttons behave in quite different ways and I don’t think there’s anywhere else in the UI where such a cancel button appears.

Then, while I was writing this, I tried closing Insync and reopening it, but it just kept crashing. It appeared in the system tray but the process seemed to terminate when I opened it. I logged out and back in and re-opened insync, and for a while the window would not appear when I clicked on the tray icon. I think it was initialising, but this is not at all clear, and is pretty frustrating. After a couple of minutes it did open, but literally every screen was “this location is empty”. Knowing Insync can be slow, I thought maybe I needed to wait some more and that I would close it for a bit and then reopen it, but then discovered that the close button does nothing during this time. After about 3 mins, the screen has suddenly populated, then about 5 seconds later it disappeared of it’s own accord, presumably finally responding to my clicking of the X several minutes ago.

I hope this example shows one of the reasons it’s such a struggle to use Insync at the moment. I think it’s working for me under the hood, but the UI makes it so so difficult to understand what’s going on, to the extent that I dread having to open it up and try and change my settings.

Is there a reason why the UI can’t be a normal, native window like I would expect on my platform? I appreciate that Insync supports three platforms, but just like in the mobile world, there is a pretty strong argument that the cost of maintaining three native UIs is actually less than maintaining one terrible cross-platform UI. As it stands, it is insanely unresponsive, unintuitive, confusing, and it’s really bizarrely small. I would much rather it looked boring but used standard native widgets and worked properly.

BONUS UPDATE EDIT: Currently I am unable to move the Insync window by dragging the title bar, it’s just stuck there. And as I type this, it’s suddenly caught up and jumped to the cursor. Now it’s kind of stuck to the cursor. Because it’s struggling to keep up with mouse events, I can’t really move it upwards, only downwards, because it doesn’t receive events outside of it’s window and the title bar is obviously right at the top edge. It’s great comedy but not great for business…

2 Likes

I have the same sticky mouse issue described in your edit. Sometimes the title bar seems unresponsive, so I click it multiple times trying to drag the window. Eventually it gets stuck and the entire window moves with the mouse, but nothing is clickable except the current mouse position. Since moving the mouse moves the window, the same thing stays under the cursor. It’s like trying to shake tape off your hand over the trash can.

1 Like

I don’t doubt you guys are experiencing these issues. I just want to mention that I’m on windows 10 pro 1903, and while I’m experiencing syncing issues such as new files being replaced by old, I’ve never had any issues with the ui as you’ve described.

Perhaps you can share more details about your windows installation, relevant software such as antivirus, hardware, and out of curiosity possibly list installed visual c++ runtimes. If we can identify similarities, it might be easier to identify the cause.

Also, ensure your software, drivers, and firmware are up to date. I’ve seen similar issues with other software caused by outdated video drivers.

1 Like