GUI not working on openSUSE Leap 15


#1

I just bought Insync and installed it on openSUSE Leap 15 but the GUI is not working. The tray icon appears briefly and disappears. I downgraded to version 1.5.2 and now it works.

Judging by the multiple posts on this issue, version 1.5.5 seems to affect a lot of people on different distros. You should seriously consider removing this version from the download page while you fix the issue.


#2

I have also experienced the same issue. The icon briefly shows up and then disappears.

Neither the GUI either the CLI app worked.


#3

Yep. Same here. Any suggestions how to solve this?


#4

Same here!
Executed insync start --no-daemon and got the following output:

INFO 2018-12-31 18:42:06,686 [main__insync:main:105] insync version: 1.5.5.37367
INFO 2018-12-31 18:42:06,688 [main__insync:main:106] client created <ideskmain.client.Client object at 0x7f86586972d0>
INFO 2018-12-31 18:42:06,689 [unix_socket_server_portable:start:49] unix socket server thread start
INFO 2018-12-31 18:42:06,690 [main__insync:main:114] starting client
INFO 2018-12-31 18:42:06,698 [fswatch:_start:532] LinuxFSWatcher._start
INFO 2018-12-31 18:42:06,700 [fswatch:_pull_loop:267] Inotify loop enter
libpng warning: iCCP: known incorrect sRGB profile
[7248:7298:1231/184206.986541:ERROR:nss_util.cc(653)] Error initializing NSS with a persistent database (sql:/home/xpete/.pki/nssdb): NSS error code: -8023
[7248:7298:1231/184206.986657:ERROR:nss_util.cc(154)] Error initializing NSS without a persistent database: NSS error code: -8023
[7248:7298:1231/184206.986672:FATAL:nss_util.cc(156)] nss_error=-8023, os_error=0
#0 0x7f865ad9e58f
#1 0x7f865adb9aac
#2 0x7f865b61a003
#3 0x7f865b61a5b0
#4 0x7f865b61a61c
#5 0x7f865b54038e
#6 0x7f865b540499
#7 0x7f865b3da8bf
#8 0x7f865b39c9f1
#9 0x7f865982b605
#10 0x7f865982cf77
#11 0x7f865982f0f1
#12 0x7f8659ec2d61
#13 0x7f865a30b7e1
#14 0x7f865ad9ec99
#15 0x7f865adc0740
#16 0x7f865adc119d
#17 0x7f865adc1487
#18 0x7f865adc38e1
#19 0x7f865ade322f
#20 0x7f8659f184ab
#21 0x7f8659f1895b
#22 0x7f865ae06f38
#23 0x7f865ae022e0
#24 0x7f868d190559 start_thread
#25 0x7f868c33481f __GI___clone

Received signal 6
#0 0x7f865ad9e58f
#1 0x7f86597d085d
#2 0x7f865ad9ea9e
#3 0x7f868d19b2e0
#4 0x7f868c2720e0 __GI_raise
#5 0x7f868c2736c1 __GI_abort
#6 0x7f865ad9d009
#7 0x7f865adb9bff
#8 0x7f865b61a003
#9 0x7f865b61a5b0
#10 0x7f865b61a61c
#11 0x7f865b54038e
#12 0x7f865b540499
#13 0x7f865b3da8bf
#14 0x7f865b39c9f1
#15 0x7f865982b605
#16 0x7f865982cf77
#17 0x7f865982f0f1
#18 0x7f8659ec2d61
#19 0x7f865a30b7e1
#20 0x7f865ad9ec99
#21 0x7f865adc0740
#22 0x7f865adc119d
#23 0x7f865adc1487
#24 0x7f865adc38e1
#25 0x7f865ade322f INFO 2018-12-31 18:42:07,009 [gdsyncer:sync_account:153] Syncing GDUser(id=uā€™ā€™, email=uā€™ā€™, name=uā€™ā€™).

#26 0x7f8659f184ab
#27 0x7f8659f1895b
#28 0x7f865ae06f38
#29 0x7f865ae022e0
#30 0x7f868d190559 start_thread
#31 0x7f868c33481f __GI___clone
r8: 0000000000000000 r9: 00007f862b7fc920 r10: 0000000000000008 r11: 0000000000000246
r12: 00007f8684258fa0 r13: 00007f862b7fcdd0 r14: 0000000000000051 r15: 00007f8684258060
di: 0000000000000002 si: 00007f862b7fc920 bp: 00007f862b7fcb70 bx: 0000000000000006
dx: 0000000000000000 ax: 0000000000000000 cx: 00007f868c2720e0 sp: 00007f862b7fc920
ip: 00007f868c2720e0 efl: 0000000000000246 cgf: 002b000000000033 erf: 0000000000000000
trp: 0000000000000000 msk: 0000000000000000 cr2: 0000000000000000
[end of stack trace]
Calling _exit(1). Core file will not be generated.
[3:3:0100/000000.042811:FATAL:zygote_linux.cc(495)] Check failed: len > 0 (0 vs. 0)
#0 0x7fe10794558f
#1 0x7fe107960aac
#2 0x7fe106a107da
#3 0x7fe106a11608
#4 0x7fe106a11aab
#5 0x7fe106a12033
#6 0x7fe106a1246d
#7 0x7fe106a13c8c
#8 0x7fe10790a7bc
#9 0x7fe10790ae0f
#10 0x7fe108b375b4
#11 0x7fe107909aa5
#12 0x7fe1063dc2c3 QtWebEngine::processMain()
#13 0x000000400bad main
#14 0x7fe10259ff4a __libc_start_main
#15 0x000000400c19

Received signal 6
#0 0x7fe10794558f
#1 0x7fe10637785d
#2 0x7fe107945a9e
#3 0x7fe1032352e0
#4 0x7fe1025b50e0 __GI_raise
#5 0x7fe1025b66c1 __GI_abort
#6 0x7fe107944009
#7 0x7fe107960bff xpete@linux-m97p:~>
#8 0x7fe106a107da
#9 0x7fe106a11608
#10 0x7fe106a11aab
#11 0x7fe106a12033
#12 0x7fe106a1246d
#13 0x7fe106a13c8c
#14 0x7fe10790a7bc
#15 0x7fe10790ae0f
#16 0x7fe108b375b4
#17 0x7fe107909aa5
#18 0x7fe1063dc2c3 QtWebEngine::processMain()
#19 0x000000400bad main
#20 0x7fe10259ff4a __libc_start_main
#21 0x000000400c19
r8: 0000000000000000 r9: 00007ffd7ea35850 r10: 0000000000000008 r11: 0000000000000246
r12: 00007fe103221fa0 r13: 00007ffd7ea35d00 r14: 0000000000000053 r15: 00007fe103221060
di: 0000000000000002 si: 00007ffd7ea35850 bp: 00007ffd7ea35aa0 bx: 0000000000000006
dx: 0000000000000000 ax: 0000000000000000 cx: 00007fe1025b50e0 sp: 00007ffd7ea35850
ip: 00007fe1025b50e0 efl: 0000000000000246 cgf: 002b000000000033 erf: 0000000000000000
trp: 0000000000000000 msk: 0000000000010000 cr2: 0000000000000000
[end of stack trace]
Calling _exit(1). Core file will not be generated.


#5

Just installed the version for fc26 and it works now.
The recommended download for OpenSuse 15 is wrong and should be fixed.


#7

Just installed the Fedora 26 version on Leap 15 and it works on my system too. Thanks for finding this workaround xpete!