HiDPI monitor font is too small

I have an ASUS laptop with a 3200x1800 HiDPI screen. Running Element OS (mainly for this reason) - everything else looks great EXCEPT this one thing. The words on the app menu are so small that I literally can’t see them. Is this a known issue or is there something I might be able to do?
Thanks

2 Likes

Tagging our engineer @lpugoy and he will get back to you

@Joseph_Luquette: Apologies for not replying sooner. What are the output of the commands gsettings get org.gnome.desktop.interface scaling-factor and gsettings get org.gnome.desktop.interface text-scaling-factor?

gsettings: command not found

@Joseph_Luquette: I see. Please run the command sudo apt-get install libglib2.0-bin to install the package that contains the gsettings command then retry.

Also just to confirm are you using Element OS or Elementary OS?

@lpugoy Insync should honor GDK_SCALE/GDK_DPI_SCALE env vars in addition to GSettings for non-GNOME desktops:

https://developer.gnome.org/gtk3/stable/gtk-x11.html

I also had this issue, until a few minutes ago, on Ubuntu Gnome 17.04, on a 3840x2160 Dell laptop display.

$ gsettings get org.gnome.desktop.interface scaling-factor
uint32 0

$ gsettings get org.gnome.desktop.interface text-scaling-factor
1.0

Then I opened the Gnome GUI app “Tweak Tool” and changed the Windows -> HiDPI -> Window Scaling there. I changed it from 1 to 2, then back to 1. Then I quit Insync, and restarted it. Now its UI looks correct.

So touching the window scaling setting using the Tweak Tool seems to be a workaround. Hopefully the issue can be fixed better some other way…

Please let me know @lpugoy if I can assist with any further testing or data.