How to open insync GUI on Linux


#1

Hi, I am running insync 1.2.3 on Ubuntu.

Since I use an alternate window manager that doesn’t have a dock like unity, I don’t have the insync icon in my dock that I can use to open the insync GUI.

Is there any other way to open the insync GUI? For example. is there a command-line argument that I can give to insync to start the GUI?

Thanks


#2

Hi,

There is no way currently to show the app window from the CLI. What window manager are you using?


#3

Thank you for your reply!

I’m using Xmonad.


#4

I see. As a workaround can you see if wmsystemtray works on your window manager?


#5

I have Ubuntu 17.1 installed and insync icon doesn’t show up in the tray. Seems like there’s gotta be a way to manage insync!!

I installed wmsystemtray, and it runs but there’s nothing in it.


#6

I am having this same issue. Any help would be appreciated.


#7

Hi. Just want to confirm that your Insync icon isn’t showing up? If ever, below are the common causes for the tray icon not showing:

  • sni-qt is not installed. Try installing it then restart Insync.
  • In some cases, when Insync is set to run at startup the tray icon is not shown. To confirm that Insync is running, run ps -ef | grep ‘insync start’; if there’s an output then Insync is running. In this case, try stopping then restarting Insync to see if the tray icon will show
  • Sometimes an outdated video card driver could cause the tray icon to not show. Try updating your video card driver if possible and restart Insync.
  • When using GNOME Shell, legacy tray icons are moved to the bottom left of the screen. They are not shown by default, which makes them hard to find. To show them on the upper right try the TopIcons extension: https://extensions.gnome.org/extension/495/topicons/ (note that in recent versions of GNOME, tray icons have been disabled entirely)

If none of these work, let me know so we can investigate further. :slight_smile:


#8

I’ve done all these steps.

  1. sni-qt is installed
  2. insync quit && insync start
  3. how can outdated video card affect this? I have a vega 64, anyways
  4. I’m using gnome-shell and I have the topicons extensions and all my icons shows, except insync

I’m on Ubuntu-18.04


#9

Ok, here’s what’s needed to be done:

  1. Disable TopIcons Extension
  2. Install https://extensions.gnome.org/extension/615/appindicator-support/