I have an error when installing inSync on Linux - Debian 8 - Mate/Gnome desktop


#1

Hi,

As the proud owner of a “Pro” version of inSync, I was able to install that on Linux.
For different reasons, I reinstalled Linux. It’s a Debian 8.3-64 bits version.
I installed the Mate desktop over the “standard GNOME” that comes with Debian.

I downloaded the latest inSync version 1.3.6 36076 - Wheezy (which is Debian 7, but I don’t think it makes a difference).

Went to terminal and made “sudo dpkg -i insync”.
Installation begins…
It asks if I want to connect right now.
I answer yes.

Here’s the output :
root@Debian-On-Mac:/home/user# Traceback (most recent call last):
File “main__insync.py”, line 115, in ipc_insync
File “socket.py”, line 224, in meth
error: [Errno 111] Connection refused

Any idea why this happens ?

Regards.

FRED


Insync error need clarification
#2

Hi,

Replying to myself to help solve the problem…

If I look at the “output” file located in /user/.config/insync it seems there are 2 kind of errors :

  • 1°) insync doesn’t have permission to write a file… this I have solved ;
  • 2°) it seems there’s a problem with Qt 4 lib. If I can read the output correctly, it seems that insync expects a 4.8.4 version, and the one that is installed on my computer is 4.8.6. And it reports those to be incompatible.

I am reluctant to downgrade… I fear to compromise the whole system :frowning:

Anyways, if I can help solving this problem…

Regards.


#3

Hi,

Replying to myself again,

It seems version 1.3.6 is completely bugged with Linux, or at least with Debian.
I tried to install version 1.3.6 with no problems…
Well, output was the same… but inSync started nonetheless and syncs files.

So will stick to 1.3.5. Don’t know about the benefits of 1.3.6 anyways…

Regards.


#4

Will be tagging our engineer @lpugoy and he will get back to you :smile:


#5

@inSync_Penguin: The error with ipc_insync is probably raised when Insync’s post uninstall package script was called. It is supposed to stop Insync if it is running, but for some reason it was unable to connect to the Insync process. It should only be a minor issue.

Could you show here the errors messages for the other issues you mentioned? I wasn’t able to replicate your issue unfortunately.


#6

Hi lpugoy,

thanks for your answer.
I don’t think I can post the errors as I installed 1.3.5 and thus erased completely the “.config/insync” folder that contains the output.txt that shows the errors.
As you may now be aware, a lot of other people seem to experience the same problems on Debian…

Anyways, no big deal : 1.3.5 works as expected :smile:

Regards.


#7

@inSync_Penguin: Apologies for the trouble. There was an issue with the Debian builds for 1.3.6. Version 1.3.7 for Debian has been uploaded. The download links in New Insync version: 1.3.6 has been updated. The update has also been pushed to the Debian repos.