Immediately segfaults in GNOME and MATE, Debian Buster


#1

Under GNOME and MATE, insync has recently stopped working. insync start produces no console output at all. Under IceWM I can still launch Insync as usual but in MATE after running insync start, I only see that a small square is being added to the notification area, and before any icon is displayed in the square, it goes away again.
insync start --no-daemon shows that it segfaults:

libpng warning: iCCP: known incorrect sRGB profile
Received signal 11 SEGV_MAPERR 000000000108
#0 0x7ff0a2574c1f <unknown>
#1 0x7ff0a0f9da9d <unknown>
#2 0x7ff0a257512e <unknown>
#3 0x7ff0c85d18e0 <unknown>
#4 0x7ff0b794bb24 <unknown>
#5 0x7ff0b794cda8 <unknown>
#6 0x7ff0c6650dd4 glXCreatePbuffer
#7 0x7ff0a1000c89 <unknown>
#8 0x7ff0a0feba08 <unknown>
#9 0x7ff0a30ba45d <unknown>
#10 0x7ff0a12f5f11 <unknown>
#11 0x7ff0a12f7705 <unknown>
#12 0x7ff0a3570857 <unknown>
#13 0x7ff0a4d8a795 <unknown>
#14 0x7ff0a25dd5d5 <unknown>
#15 0x7ff0a25d8970 <unknown>
#16 0x7ff0c85c6f2a start_thread
#17 0x7ff0c813dedf clone
  r8: 0000000000000000  r9: 0000000000000001 r10: 0000000000000000 r11: 0000000000000206
 r12: 000055ffe0c27f30 r13: 000055ffe0f552e0 r14: 0000000000000005 r15: 000055ffe0cc3e80
  di: 000055ffe0c27f30  si: 0000000000000000  bp: 000055ffe0c27f30  bx: 0000000000000000
  dx: 0000000000008041  ax: ffffffffffffff50  cx: 0000000000000000  sp: 00007ff03effc480
  ip: 00007ff0b794bb24 efl: 0000000000010202 cgf: 002b000000000033 erf: 0000000000000004
 trp: 000000000000000e msk: 0000000000000000 cr2: 0000000000000108
[end of stack trace]
Calling _exit(1). Core file will not be generated.

I guess I will have to install several debug packages to reveal more information, not sure which ones, though. Running debian buster.

Oh, well I see I can’t actually generate a meaningful backtrace because I don’t have debugging symbols for insync itself. Can they be installed from somewhere?


#2

Hi @Johannes_Rohr,

Sorry for the trouble! Tagging our engineer @Kurt_Ko for further assistance.


#3

ok, looking forward to getting contacted by him. Just for the record: It still runs in headless mode.


#4

@miamoran @Kurt_Ko Sorry for nagging but would you be able to look at this?


#5

Hi @Johannes_Rohr

Can you run ‘sudo ldconfig -p | grep -i gl.so’ and send me the output?

Thanks!


#6

I have the same issue: https://pastebin.com/YspcDWBz


#7
	libwayland-egl.so.1 (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/libwayland-egl.so.1
	libwayland-egl.so.1 (libc6) => /usr/lib/i386-linux-gnu/libwayland-egl.so.1
	libcogl.so.20 (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/libcogl.so.20
	libQt5OpenGL.so.5 (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/libQt5OpenGL.so.5
	libGL.so.1 (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/libGL.so.1
	libGL.so.1 (libc6) => /usr/lib/i386-linux-gnu/libGL.so.1
	libEGL.so.1 (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/libEGL.so.1
	libCgl.so.1 (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/libCgl.so.1

#8

@Kurt_Ko what is the status of the resolution of this bug ? What is the expected ETA ?


#9

@Kurt_Ko Sorry for nagging, are you working on it?


#10

@Kurt_Ko do you have a bug tracker where we can see how you progress with this issue ? The insynq is still unusable. If this can’t be resolved soon I will request a re-fund since the software if broken.


#11

Having the same problem here, also using Debian Buster, with Gnome 3.
In addition, I have the following behavior: If I make sudo apt-get remove --purge insync, and then reinstall Insync using the installer I have:

sudo dpkg --install insync_1.5.5.37367-stretch_amd64.deb 
Selecting previously unselected package insync.
(Reading database ... 1198227 files and directories currently installed.)
Preparing to unpack insync_1.5.5.37367-stretch_amd64.deb ...
Unpacking insync (1.5.5.37367-stretch) ...
Setting up insync (1.5.5.37367-stretch) ...
Insync installation has finished. You may now start it.
Processing triggers for shared-mime-info (1.10-1) ...
Traceback (most recent call last):
  File "isyncd/linux/headless/cli.py", line 108, in ipc_insync
  File "socket.py", line 228, in meth
error: [Errno 111] Connection refused

As you can see, the app does not open when it prompts me if I want to open it, and I confirm, after the installation. However, after the “fresh install” and that error, if I go to the terminal and make insync start --no-daemon, the app opens, no error is reported, and everything works fine - until I quit the app, or the computer is rebooted. In such case, it does not autostart (it is configured to autostart at boot), and when I try to initialize it from the terminal again, I have the following error:

insync start --no-daemon
INFO     2019-01-05 21:14:36,422 [__main__insync__:main:105] insync version: 1.5.5.37367
INFO     2019-01-05 21:14:36,424 [__main__insync__:main:106] client created <ideskmain.client.Client object at 0x7f6b70d443d0>
INFO     2019-01-05 21:14:36,424 [unix_socket_server_portable:start:49] unix socket server thread start
INFO     2019-01-05 21:14:36,425 [__main__insync__:main:114] starting client
INFO     2019-01-05 21:14:36,431 [fswatch:_start:532] LinuxFSWatcher._start
INFO     2019-01-05 21:14:36,432 [fswatch:_pull_loop:267] Inotify loop enter
Received signal 11 SEGV_MAPERR 000000000108
#0 0x7f6b76da3c1f <unknown>
#1 0x7f6b757cca9d <unknown>
#2 0x7f6b76da412e <unknown>
#3 0x7f6ba2c5b6b0 <unknown>
#4 0x7f6b956ffb24 <unknown>
#5 0x7f6b95700da8 <unknown>
#6 0x7f6ba0b7bdd4 glXCreatePbuffer
#7 0x7f6b7582fc89 <unknown>
#8 0x7f6b7581aa08 <unknown>
#9 0x7f6b778e945d <unknown>
#10 0x7f6b75b24f11 <unknown>
#11 0x7f6b75b26705 <unknown>
#12 0x7f6b77d9f857 <unknown>
#13 0x7f6b795b9795 <unknown>
#14 0x7f6b76e0c5d5 <unknown>
#15 0x7f6b76e07970 <unknown>
#16 0x7f6ba2c50fa3 start_thread
#17 0x7f6ba27d488f clone
  r8: 0000000000000000  r9: 0000000000000001 r10: 0000000000000004 r11: 0000000000000206
 r12: 0000564997b66bd0 r13: 0000564997d53e70 r14: 000000000000000b r15: 0000564997c19c20
  di: 0000564997b66bd0  si: 0000000000000000  bp: 0000564997b66bd0  bx: 0000000000000000
  dx: 0000000000008041  ax: ffffffffffffff50  cx: 0000000000000000  sp: 00007f6b2b7fd480
  ip: 00007f6b956ffb24 efl: 0000000000010202 cgf: 002b000000000033 erf: 0000000000000004
 trp: 000000000000000e msk: 0000000000000000 cr2: 0000000000000108
[end of stack trace]
Calling _exit(1). Core file will not be generated.

And the output of ‘sudo ldconfig -p | grep -i gl.so’ :

sudo ldconfig -p | grep -i gl.so
	libwayland-egl.so.1 (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/libwayland-egl.so.1
	libwayland-egl.so.1 (libc6) => /usr/lib/i386-linux-gnu/libwayland-egl.so.1
	libwayland-egl.so (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/libwayland-egl.so
	libugL.so.2.6.0 (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/libugL.so.2.6.0
	libugL.so (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/libugL.so
	libmgl.so.7.5.0 (libc6,x86-64) => /usr/lib/libmgl.so.7.5.0
	libftgl.so.2 (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/libftgl.so.2
	libfltk_gl.so.1.3 (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/libfltk_gl.so.1.3
	libfltk_gl.so.1.1 (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/libfltk_gl.so.1.1
	libcogl.so.20 (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/libcogl.so.20
	libTKOpenGl.so.7 (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/libTKOpenGl.so.7
	libQt5OpenGL.so.5 (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/libQt5OpenGL.so.5
	libQtOpenGL.so.4 (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/libQtOpenGL.so.4
	libOpenGL.so.0 (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/libOpenGL.so.0
	libOpenGL.so (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/libOpenGL.so
	libGL.so.1 (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/libGL.so.1
	libGL.so.1 (libc6) => /usr/lib/i386-linux-gnu/libGL.so.1
	libGL.so (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/libGL.so
	libEGL.so.1 (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/libEGL.so.1
	libEGL.so (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/libEGL.so
	libCgl.so.1 (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/libCgl.so.1
	libCgGL.so (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/libCgGL.so

This has been happening for a while. I would really appreciate some effort on solving that; I am about to quit Dropbox to use GDrive. And I have to tell you guys, your Linux app is sooo much better than the Dropbox app for Linux that almost fries my CPU when I reboot my laptop. However, if you do not address this, I am going to look for another option for this service.


#12

Hi @rado @Johannes_Rohr @SabrinaTigik

Do you have a dedicated GPU in your machine? If so, did you install graphics drivers for them? Is Insync running in a VM?
Could you send me the output of the following commands?
lspci -k | grep -EA3 'VGA|3D|Display'
cat /etc/X11/xorg.conf
cat /var/log/Xorg.0.log | grep LoadModule
cd /usr/lib/insync && ./py -c "import ctypes.util; print(ctypes.CDLL(ctypes.util.find_library('GL'), ctypes.RTLD_GLOBAL))"


#13

On both affected computers, I have simply onboard intel graphics, which are supported by X.org by the builtin drivers.

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
	Subsystem: Lenovo 2nd Generation Core Processor Family Integrated Graphics Controller
	Kernel driver in use: i915
	Kernel modules: i915
[jr@tommy insync]$ cat /etc/X11/xorg.conf
cat: /etc/X11/xorg.conf: Datei oder Verzeichnis nicht gefunden
[jr@tommy insync]$ cat /var/log/Xorg.0.log | grep LoadModule
[227965.196] (II) LoadModule: "glx"
[227965.270] (II) LoadModule: "modesetting"
[227965.308] (II) LoadModule: "fbdev"
[227965.339] (II) LoadModule: "vesa"
[227965.364] (II) LoadModule: "fbdevhw"
[227965.429] (II) LoadModule: "glamoregl"
[227966.027] (II) LoadModule: "fb"
[227966.344] (II) LoadModule: "libinput"
[jr@tommy insync]$ cd /usr/lib/insync && ./py -c "import ctypes.util; print(ctypes.CDLL(ctypes.util.find_library('GL'), ctypes.RTLD_GLOBAL))"
<CDLL 'libGL.so.1', handle 55badd750610 at 7fe5194d0150>

#14

Hi,

I have a dedicated GPU, but it is in a laptop with an Optimus enabled graphics card. Since I am using bumblebee with primus, my GPU is only activated when I explicitly invoke it or run some application through primusrun. This means that most of the time I am using only the Intel graphics drivers.

lspci -k | grep -EA3 'VGA|3D|Display'
00:02.0 VGA compatible controller: Intel Corporation UHD Graphics 630 (Mobile)
	Subsystem: Micro-Star International Co., Ltd. [MSI] UHD Graphics 630 (Mobile)
	Kernel driver in use: i915
	Kernel modules: i915
--
01:00.0 VGA compatible controller: NVIDIA Corporation GP104M [GeForce GTX 1070] (rev ff)
	Kernel modules: nvidia
02:00.0 Non-Volatile memory controller: Silicon Motion, Inc. Device 2262 (rev 03)
	Subsystem: Silicon Motion, Inc. Device 2262

I do not have a xorg.conf file, since it breakes the bumblebee set up.

cat /etc/X11/xorg.conf
cat: /etc/X11/xorg.conf: No such file or directory

cat /var/log/Xorg.0.log | grep LoadModule
[  9775.039] (II) LoadModule: "glx"
[  9775.040] (II) LoadModule: "modesetting"
[  9775.041] (II) LoadModule: "fbdev"
[  9775.041] (II) LoadModule: "vesa"
[  9775.054] (II) LoadModule: "fbdevhw"
[  9775.055] (II) LoadModule: "glamoregl"
[  9775.376] (II) LoadModule: "fb"
[  9775.454] (II) LoadModule: "libinput"
[  9776.042] (II) LoadModule: "synaptics"

cd /usr/lib/insync/ && ./py -c "import ctypes.util;
> print(ctypes.CDLL(ctypes.util.find_library('GL'), ctypes.RTLD_GLOBAL))"
<CDLL 'libGL.so.1', handle 5582c45751e0 at 7f942ff0e150>

For the sake of completeness, the lspci results with the GPU driver enabled are

lspci -k | grep -EA3 'VGA|3D|Display'
00:02.0 VGA compatible controller: Intel Corporation UHD Graphics 630 (Mobile)
	Subsystem: Micro-Star International Co., Ltd. [MSI] UHD Graphics 630 (Mobile)
	Kernel driver in use: i915
	Kernel modules: i915
--
01:00.0 VGA compatible controller: NVIDIA Corporation GP104M [GeForce GTX 1070] (rev a1)
	Subsystem: Micro-Star International Co., Ltd. [MSI] GP104M [GeForce GTX 1070 Mobile]
	Kernel driver in use: nvidia
	Kernel modules: nvidia

The GPU enabled does not make any difference when it comes to insync crashing.


#15

Hi @Kurt_Ko,
I do have a GPU on the laptop with nVidia driver installed. The appliaction is not running in VM.

Please see output of the commands https://pastebin.com/1hT9Fx2N


#16

Hi everyone,

I came here to tell @rado and @Johannes_Rohr that I installed the Insync app for the latest Ubuntu and it is working fine. It complained a little bit in the first execution, prompting some warnings, but it’s running very well. I can quit and restart the program, it will prompt the same warnings, but it runs. And now Insync also autostarts after boot/reboot. Of course, this is just a workaround. I really hope Insync developers fix this problem as soon as possible so that we can use the right version of the app, for the correct version of Debian.

@Kurt_Ko, I had the idea about trying the Ubuntu version because Debian Buster had a big migration to a new version of the Python libraries lately and Insync developers are using the same version of the app for both Debian Stretch and Debian Buster. So I assumed that the latest Ubuntu version could be compatible with the new Python libraries. And it’s not just Python. There were several important migrations in the last two months that might have affected the usability of your app in Buster. The good news is that Buster is in transition to freeze now, so there will be no more crazy changes on its packages. If this is the real cause, I don’t know, but using the Ubuntu version worked, and it is working quite well so far. I hope that helps you the get some idea for solving this problem.