Installing Insync on RHEL 9

Hello everyone.
I would like to know if anyone here on the forum managed to install and use Insync on RHEL 9. There is a step by step here on the forum but applied to RHEL 8. This step does not work on version 9 of the system.
I am having problems starting the application because it is installed on the system but does not run.
Since the flatpak version of Insync is coming out at a snail’s pace, we have to resort to “workarounds” to use the app.
This makes me very unhappy with Insync, which is not a free program. It should solve these issues in a faster way.
I would be very grateful if someone knows a way out of my situation.
Thanks.

Translated with www.DeepL.com/Translator (free version)

1 Like

Hi @Willian_Armond,

Checking this out for you.

Apologies for not deploying our Flatpak/Snapcraft support sooner to make installation more convenient. We’ve hit a few snags along the way and it was necessary for our team of developers to recalibrate our resources for this feature development.

Same here, application does not start after clicking on insync icon. Tried with insync-3.7.11.50381-fc35.x86_64. Can you provide instruction how to debug this issue?

Hi @brako,

We’re waiting for our Linux team to respond and debug the issue. I’ll update this thread once I have more information. Thank you for your patience!

Hi @mia, what’s the progress on this issue? Thanks.

@brako Hi! Could you please try the F35 installer, and upon starting Insync, please run:

insync start --no-daemon and share the output here. :slight_smile:

Segfault :confused:

$ rpm -q insync
insync-3.7.11.50381-fc35.x86_64
$ insync start --no-daemon
Warning: Ignoring XDG_SESSION_TYPE=wayland on Gnome. Use QT_QPA_PLATFORM=wayland to run on Wayland anyway.
Segmentation fault (core dumped)

Thank you for running this and sending the output. I’ve forwarded it to our Linux engineer and await his reply.

Could you run insync start --qt-qpa-platform=wayland --no-daemon this time? @brako

$ insync start --qt-qpa-platform=wayland --no-daemon
Warning: Ignoring XDG_SESSION_TYPE=wayland on Gnome. Use QT_QPA_PLATFORM=wayland to run on Wayland anyway.
QSocketNotifier: Can only be used with threads started with QThread
Using Wayland-EGL
WARNING:root:While reading /usr/share/applications/defaults.list
Traceback (most recent call last):
  File "idesklinux/application_manager.py", line 53, in __index_default_apps
  File "configparser.py", line 696, in read
  File "configparser.py", line 1091, in _read
configparser.DuplicateOptionError: While reading from '/usr/share/applications/defaults.list' [line 31]: option 'application/rdf+xml' in section 'Default Applications' already exists
WARNING:root:While reading /usr/share/applications/mimeapps.list
Traceback (most recent call last):
  File "idesklinux/application_manager.py", line 53, in __index_default_apps
  File "configparser.py", line 696, in read
  File "configparser.py", line 1091, in _read
configparser.DuplicateOptionError: While reading from '/usr/share/applications/mimeapps.list' [line 331]: option 'image/tiff' in section 'Default Applications' already exists
WARNING:root:While reading /usr/share/applications/gnome-mimeapps.list
Traceback (most recent call last):
  File "idesklinux/application_manager.py", line 53, in __index_default_apps
  File "configparser.py", line 696, in read
  File "configparser.py", line 1091, in _read
configparser.DuplicateOptionError: While reading from '/usr/share/applications/gnome-mimeapps.list' [line 331]: option 'image/tiff' in section 'Default Applications' already exists
WARNING:root:While reading /usr/share/applications/gnome-mimeapps.list
Traceback (most recent call last):
  File "idesklinux/application_manager.py", line 70, in __index_apps_for_mimetypes
  File "configparser.py", line 696, in read
  File "configparser.py", line 1091, in _read
configparser.DuplicateOptionError: While reading from '/usr/share/applications/gnome-mimeapps.list' [line 331]: option 'image/tiff' in section 'Default Applications' already exists
WARNING:root:While reading /usr/share/applications/mimeapps.list
Traceback (most recent call last):
  File "idesklinux/application_manager.py", line 70, in __index_apps_for_mimetypes
  File "configparser.py", line 696, in read
  File "configparser.py", line 1091, in _read
configparser.DuplicateOptionError: While reading from '/usr/share/applications/mimeapps.list' [line 331]: option 'image/tiff' in section 'Default Applications' already exists
WARNING:root:While reading /usr/share/applications/defaults.list
Traceback (most recent call last):
  File "idesklinux/application_manager.py", line 70, in __index_apps_for_mimetypes
  File "configparser.py", line 696, in read
  File "configparser.py", line 1091, in _read
configparser.DuplicateOptionError: While reading from '/usr/share/applications/defaults.list' [line 31]: option 'application/rdf+xml' in section 'Default Applications' already exists
INFO     2022-09-22 10:35:51,584 [mainlogs:_log_run:139] Core(app_version=3.7.11.50381, platform=Linux-x86_64-rhel/9.1) initialized
Using the 'xdg-shell' shell integration
qt.qpa.wayland: Wayland does not support QWindow::requestActivate()
INFO     2022-09-22 10:35:51,770 [app:start_core:65] core started
INFO     2022-09-22 10:35:51,770 [unix_socket_server:start:93] unix socket server thread start

…and “Welcome to Insync!” window appears \o/

I was able to run Insync by providing the following change, from the above information.
I edited the insync.desktop file:
sudo nano /usr/share/applications/insync.desktop
I changed it as follows:

[Desktop Entry]
Version=1.0
Type=Application
Name=Insync
GenericName=Insync
Comment=Launch Insync
Icon=insync
Categories=Network;
Exec=insync start --qt-qpa-platform=wayland --no-daemon
TryExec=insync

I have saved and added the application to the startup list in Gnome Tweaks.
It worked .
Just running the command in the terminal does no good, because when you close the terminal, insync closes as well. The above way keeps it running.
Now I am waiting for a solution from the developers so that I am not left with the “gimmicky” app.

Translated with www.DeepL.com/Translator (free version)

Wonderful to hear that, @brako!! :slight_smile: Can I help you with anything else?

Thank you for the feedback, @Willian_Armond! :slight_smile: I will forward this to our engineers to see how we can line up a more permanent fix than a workaround.