Insync 3.0 woes

Recently upgraded from 1.x to 3.0.13.
It is perpetually stuck here:


I’ve restarted it, hit “retry” about 2500 times, etc. It looks like it is trying to upload stuff that is already on my local machine (which makes sense… I went from 1.x to this, and followed the instructions here.

Can anyone help me?


Hi @yochaigal,

Happened to me when I was migrating too. Can you just let Insync run for a couple of more hours?

I found that mine self-regulated after a while

I let it run for two days straight. I guess I could let it run again…

Ran it for almost three days. Problem persists.

If you see any errors in the Insync log (~/.config/Insync/out.txt) related to having too many files open, you can try the following:

  1. Open /etc/security/limits.conf for editing (using sudo)
  2. Add the following two lines to increase the hard and soft limit for the maximum number of open files to 65535
* soft     nofile         65535
* hard     nofile         65535
  1. Restart computer and insync.

On initial sync I ran into a ton of issues that were related to Insync opening too many files at once, causing it to be stuck at the same point forever. This solved the issue for me, so perhaps worth a try. After the initial sync you can probably set the ulimit back to default unless you frequently update large numbers of files at once.

I did this; still stuck at syncing 813 items.

I see. Would you mind sending in your logs to along with the link to this post?

A few questions:

  1. Are these files shared files?
  2. What version are you on?

I sent the logs!

Many of the files are shared with me, and were previously downloaded to my computer. I’m now on version

I went through and removed/re-added some items that came up with sync errors; Insync simply finds other files to have sync errors with.

Feeling pretty frustrated here.