Insync on Pop_OS 20.04 - ZLIB error

I’m running Pop_OS 20.04, and the latest update to Insync ( no longer works. The version prior to this worked fine.

I get the following error message at launch:

$ insync
Traceback (most recent call last):
File “”, line 9, in
File “/usr/local/lib/python3.7/site-packages/PyInstaller/loader/”, line 627, in exec_module
File “idesklinux/”, line 14, in
File “/usr/local/lib/python3.7/site-packages/PyInstaller/loader/”, line 627, in exec_module
File “idesklinux/”, line 6, in
ImportError: /usr/lib/insync/ version `ZLIB_1.2.9’ not found (required by /lib/x86_64-linux-gnu/
[11091] Failed to execute script insync


I have the same problem, it happened in the update today! (13/05)

Yes, same here. After update, this error appears and insync won’t start on Pop os 20.04

I have a second laptop also running Pop_OS 20.04, but that hasn’t been updated in 3 days. It’s running version, which works just fine. I’m trying to find an Insync repository where I can download it, replace the broken package, then pin the working version in APT until there’s a proper fix.

OK - I’m back on the working version!


1 - Uninstall the broken version:

sudo apt purge insync -y

2 - Tell APT to keep Insync at version 3.1.5-40801:

sudo echo “Package: insync” >> /etc/apt/preferences
sudo echo “Pin: version” >> /etc/apt/preferences
sudo echo “Pin-Priority: 1001” >> /etc/apt/preferences

3 - Download & install Insync 3.1.5-40801:

cd /var/tmp
sudo apt install ./insync_3.1.5.40801-xenial_amd64.deb
rm ./insync_3.1.5.40801-xenial_amd64.deb

4 - Update the APT cache & verify that both the “Installed” & “Candidate” versions are 3.1.5-40801:

sudo apt update -y
sudo apt-cache policy insync

(output of command below)
Installed: <-- should be 3.1.5-40801-xenial
Candidate: <-- should be 3.1.5-40801-xenial
Version table: 500
500 xenial/non-free amd64 Packages
*** 1001
100 /var/lib/dpkg/status

Now you can upgrade your system, but Insync will stay put. When there is a working update, you can simply remove the “/etc/apt/preferences” entries (or remove the file, if this is all that’s in it).


It works for me, although for some reason I had to edit /etc/apt/preferences with a text editor (sudo nano /etc/apt/preferences/ for example) and add manually:

Package: insync
Pin: version
Pin-Priority: 1001

The echo method gave me some weird error that I did not have time to Google :stuck_out_tongue:

Thank you very much, I hope the next version solves this error.


I have the same issue in my Ubuntu 18.04 system.
I solved it replacing the insync library by the system one:

$ cd /usr/lib/insync
$ sudo mv
$ sudo ln -s /lib/x86_64-linux-gnu/

Thank you very much.

The update broke Insync too on another machine with ElementaryOS 5.1 Hera and this solution worked flawlessly without reverting to the previous version.

All the best.

I use the repo for eoan on Ubuntu 20.04 and PopOS 20.04 without issues.

deb eoan non-free contrib

Hi, I have the same problem on POP!_OS 20.04, I solved the with @chus solution.

Also had same issue. Fixed using @chus ’ solution

Thanks Sven - I changed my repo to “eoan”, and I’m now good to to on the latest version.