Insync 3.6.1 crashes on Fedora 35

So, I set up and configured insync on my desktop computer running Fedora 35 and works like a charm. Google Drive, Dropbox, OneDrive, all with custom directories, syncs and runs smoothly.

Then I tried setting it up on my laptop, also running on Fedora 35. I managed to setup Google Drive, but whenever I click anywhere inside the app window, it freezes for a couple of seconds, then crashes. Turned the wifi off and managed to change the syncing path to a custom directory. That’s as far as I got.

When I turn the network back on, it syncs both ways okay, but if I try to bring up the app window, or alas click on it, same thing happens; freezes up for a while, then crashes.

Works for me in the short term, as it does sync my main account, but I’d love to have the full monty, please.


I followed this guide: and now my laptop appears to have all three accounts setup (Google Drive, Dropbox & OneDrive). However, although it displays a green checkmark badge, it still doesn’t sync Dropbox. Google Drive and OneDrive sync okay.

And it still crashes whenever I try to access the app GUI.

Hey, Alex!

Can you please let us know the Insync version you’re using right now? :slight_smile: Is it the same version you’re using in your desktop?

Stepping in for @mara as I was the one handling our email exchanges, @alex.seidanis! Apologies for not realizing sooner, Mara! :sweat_smile:

I confirm that Alex is on v3.6.1 on his Fedora 35 and have also forwarded his emails to the Linux team so we can try to replicate and test the same setup. Thank you!

1 Like