Insync 3 - Unexpected error doing DownloadGDBlob: [Errno 2] No such file or directory

When upgrading from v1.5 to v3 and converting an existing sync folder, I’m seeing a fairly large number of DownloadGDBlob errors for files that are not found on google drive. All seem to have been temporary files that start with .~ and were long since cleared from the drive. The only option that’s available in the action tab is ‘Retry’ and there’s no way to get rid of the messages. Any advice on how to clear these?

1 Like

Hi @Harm_van_Bakel,

So sorry about not responding sooner!

Can you let me know what your Insync 3 version is and your OS? If the errors are still present, could you also include a screenshot of the Error tab? Thanks!

I get the same, even with a fresh directory. 12 of those errors - I have no idea what is synced and what isn’t. Even when this works, it isn’t ideal as I now need to manually sync everything that has changed in the old directory which I had to backup as that wasn’t working either.

OS: OSX 10.15 Beta, Insync Version (

1 Like

Same error here, but with:

  • Windows 10 v1709 (16299.1087 compilation)
  • Insync v3.0.16.40306


I’m now stuck with this message, too…
Insync on Fedora 30

Hi guys! Our engineers are looking into this issue. Please send your log files to with the link to this post. :slight_smile:

I no longer see this error with the latest insync versions (3.0.15 or 3.0.16) on Ubuntu Linux 16.04 (Xenial) or 18.04 (Bionic). I originally got the errors on a first sync with v3.0.14 but it didn’t turn up any more after I did a new sync with v3.0.15. The steps I took for the fresh sync were to stop and uninstall the old insync version, then delete the old synced folder, as well as the insync configuration folder in ~/.config/Insync/. At that point I reinstalled Insync, went through the account registration procedure again, and started a new sync.

I am dead in the water with this issue “Unexpected error doing DownloadGDBlob” on Windows 10b1903 when I upgraded to

I initially reused the original path, then I tried to wipe the install/db and start with a new path, and it persist. It seems it gets to a point where something like 12 files get stuck, and then no further syncing happens. I now have a TB of data at risk and my files are very difficult to use. Help!!!

Looks like a fix may exist: Pointer to fix for DownloadGDBlob errors (inSync 3)

1 Like

Still persists!

I’ve given Version a try. Likewise, still not syncing my files, causing massive problems. Interface locks up and starts flashing. Still not useable, brand new Windows 10 instal…

Back to 1.5. Really need to fix this!!!

The same here.
OneDrive for Business
Kubuntu 19.04
These (bunch of) files are temporary created by insync, they aren’t in my synced folder.